topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • Tuesday August 9, 2022, 9:42 pm
  • Proudly celebrating 15+ years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Last post Author Topic: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon  (Read 4055 times)

dbareis

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 27
    • View Profile
    • Donate to Member
Except for one image which I added boxes and text all icons are generic flowers and not a thumbnail of the captured image.  Modifying another image didn't make its thumbnail appear.

I capture as ".PNG", if I put ".JPG" into the capture directory these show up OK, the image that shows the thumbnail is a ".PNG" like the others that don't.

I only noticed this yesterday but have made no option changes in the app.  If I go to the directory in explorer I can see ALL of the thumbnails correctly so it doesn't appear to be a Windows issue.

The only thing image related I have done recently is fix the mime type for JPEG images as shown here: https://nspeaks.com/...if-heres-how-to-fix/

I have tried putting that back to the original JFIF value and restart the app but that doesn't fix it.  Also why is that one lonely image OK?

« Last Edit: September 15, 2021, 05:03 PM by dbareis, Reason: More info »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,810
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #1 on: September 15, 2021, 06:54 PM »
Can you try restarting windows and see if it fixes it? SC relies on windows to do the heavy lifting of showing thumbnails and occasionally gets stuck making them and a reboot fixes it.

dbareis

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 27
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #2 on: September 16, 2021, 01:55 AM »
Can you try restarting windows and see if it fixes it? SC relies on windows to do the heavy lifting of showing thumbnails and occasionally gets stuck making them and a reboot fixes it.

I'd rebooted before but that didn't fix it.  Just did it again and was about to say it didn't but was showing more than before, but a few more turned up as I scrolled.  Quite a few still appear to be "stuck".  Explorer shows icons for all images. I think you cache them but perhaps also cache failures?  I stopped and restarted the app and this time all but 3 of 711 files show correctly (at least those in the current capture directory, not so great in subfolders though).

Should Tiles overlap making it hard to select the next one? I haven't noticed that before either (on long filenames)?

dbareis

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 27
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #3 on: September 16, 2021, 06:32 PM »
I think I found the problem, I used to have "Tick Auto Move Older Screenshots, set to x days" ticked but just found it unticked, I don't believe I did that.

It seems that around 700 is the upper limit you want in a directory even on a powerful 12 core computer with 32 GB RAM.  Maybe instead (or along with) a number of days option there should be a count of files option: Tick Auto Move Older Screenshots, set to x days, or y files

And maybe that should run periodically or after every capture and not just at startup.


Fribytare

  • Participant
  • Joined in 2015
  • *
  • default avatar
  • Posts: 9
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #4 on: October 08, 2021, 02:13 PM »
Hi, same problem here since one month back. Tried your trick with auto move but no joy.  :(
« Last Edit: October 08, 2021, 02:25 PM by Fribytare »

Fribytare

  • Participant
  • Joined in 2015
  • *
  • default avatar
  • Posts: 9
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #5 on: October 08, 2021, 02:33 PM »
Changed to JPG and got a thumbnail on the next capture. Changed back to PNG but no thumbnail on the next capture.

Fribytare

  • Participant
  • Joined in 2015
  • *
  • default avatar
  • Posts: 9
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #6 on: October 10, 2021, 04:14 PM »
Edit: This solution only worked a few days. Maybe only to the next reboot.

I fixed the problem by following the instructions linked in another thread.

You could try the "nuclear option" and rebuild the thumbnail cache, that might clear out something - instructions here.
« Last Edit: October 13, 2021, 06:02 AM by Fribytare »

dbareis

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 27
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #7 on: October 10, 2021, 04:17 PM »
My auto-move improved things but I still have a few turn up, I will try the "nuclear option" mentioned earlier.

dbareis

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 27
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #8 on: October 12, 2021, 02:17 AM »
The "nuclear option" instructions aren't complete and I had to kill off Screenshot Captor plus some other apps and even use a move utility to delete the files, but after all that it hasn't helped.  I'm guessing it might work for other situations.  The "handle.exe" program (NirSoft?) came in handy or Process Explorer/Hacker would also allow you to determine which processes have the files open.

At least in my case Explorer DOESN'T have the issue and displays all thumbnails, it is ONLY ScreenShotCaptor with the issue.

Fribytare

  • Participant
  • Joined in 2015
  • *
  • default avatar
  • Posts: 9
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #9 on: October 13, 2021, 06:00 AM »
After reboot today the problem is back...  :(

Sorry for misleading you.

Fribytare

  • Participant
  • Joined in 2015
  • *
  • default avatar
  • Posts: 9
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #10 on: October 13, 2021, 06:23 AM »
I tried the portable version and the problem is there too.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,810
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #11 on: October 15, 2021, 08:03 AM »
How strange.. I think it must be something with the windows thumbnail cache.  Does anyone know a good tool to tell windows to recover from a problem caching thumbnails in windows explorer?

Fribytare

  • Participant
  • Joined in 2015
  • *
  • default avatar
  • Posts: 9
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #12 on: October 15, 2021, 10:11 AM »
My latest test was to "Restore defaults" in File Explorer Options - View. Still working after a couple of reboots. So far so good.

Clip.jpgThumbNails No Longer Show Screenshot, Just Generic Flower Icon

I found it here https://www.stellarinfo.com/blog/thumbnail-previews-not-showing/

mateuszlitwin

  • Participant
  • Joined in 2008
  • *
  • Posts: 1
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #13 on: October 16, 2021, 02:46 AM »
Hi, I have just changed View\Extra large icons on folder holding screen shoots. Thumbnails have appeared in SC, after reboot thumbnails are still visible.
Occasionally adjusting slider in SC between list of captured image and preview is required to show thumbnails if they are too big to be loaded.

Screenshot 2021-10-16 094543.pngThumbNails No Longer Show Screenshot, Just Generic Flower Icon

Fribytare

  • Participant
  • Joined in 2015
  • *
  • default avatar
  • Posts: 9
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #14 on: October 17, 2021, 08:34 AM »
My latest test was to "Restore defaults" in File Explorer Options - View. Still working after a couple of reboots. So far so good.

[attachthumb=#,msg446709][/attachthumb]

I found it here https://www.stellarinfo.com/blog/thumbnail-previews-not-showing/

It still works. But I'm angry because I was so tired that I forgot to compare the settings before and after the reset. Very few settings have anything to do with the thumbs.

dbareis

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 27
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #15 on: October 17, 2021, 10:15 PM »
As I said earlier, everything points to this being a ScreenShot Captor and not a Windows issue and now I have more evidence.

I renamed an image (with missing thumbnail) "xxxx" (F5=Refresh didn't do anything) went into "View", clicked on "Simple List on Left" and then back on thumbnail, and it now shows the thumbnail (now that doesn't always do it but the fact that it ever did it shows Windows is not the issue).

Other than that is there any log files we can look at?

dbareis

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 27
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #16 on: October 17, 2021, 10:18 PM »
It still works. But I'm angry because I was so tired that I forgot to compare the settings before and after the reset. Very few settings have anything to do with the thumbs.

"ScreenshotCaptor.ini" if backed up (or one of the others, not sure) will have it.  I record my settings (at least the important ones)  in Evernote.

Fribytare

  • Participant
  • Joined in 2015
  • *
  • default avatar
  • Posts: 9
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #17 on: October 18, 2021, 09:41 AM »
Now it doesn't work anymore but I don't know why or since when. This makes me so confused. Old png-thumbs were still there, but I got no new ones. I cleared the thumbs cache in windows and now I can't even get the old ones showing in Screenshot Captor. Of course, I can use jpg but I don't want to.

Btw, I can't find a ScreenshotCaptor.ini on my hd.
« Last Edit: October 18, 2021, 10:07 AM by Fribytare »

dr_andus

  • Supporting Member
  • Joined in 2012
  • **
  • Posts: 851
    • View Profile
    • Dr Andus's toolbox
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #18 on: October 18, 2021, 03:51 PM »
This is also happening to me. I doubt it's an SC problem, as I haven't changed anything in the application. However, I have installed a few Windows updates (still on Windows 7). This also happened to coincide with a recent Dopus update, I believe. But I suspect the Windows updates.

dbareis

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 27
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #19 on: October 18, 2021, 06:41 PM »
I have it installed portable and the "ini" files are in its root directory.

I also haven't changed the app and it is probably a Windows Update which triggered this, but Explorer works, I have no thumbnail issues there, just because something else triggers a bug doesn't mean that the-something-else is where the bug is.

I am on WIN 10 (latest updates)
« Last Edit: October 18, 2021, 07:08 PM by dbareis, Reason: I am on WIN 10 (latest updates) »

dr_andus

  • Supporting Member
  • Joined in 2012
  • **
  • Posts: 851
    • View Profile
    • Dr Andus's toolbox
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #20 on: October 18, 2021, 06:54 PM »
I see what you mean.

Nucleorion

  • Participant
  • Joined in 2013
  • *
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #21 on: October 19, 2021, 04:23 AM »
I have it installed portable and the "ini" files are in its root directory.

I also haven't changed the app and it is probably a Windows Update which triggered this, but Explorer works, I have no thumbnail issues there, just because something else triggers a bug doesn't mean that the-something-else is where the bug is.

I am on WIN 10 (latest updates)
It happens exactly the same. Maybe some way that Screencaptor has to process the thumbnails has become obsolete and now it no longer works well. I suppose they will have to take the reins and update the program to make it functional again. Meanwhile it is ungrateful to use it.
« Last Edit: November 08, 2021, 06:48 AM by Nucleorion »

dr_andus

  • Supporting Member
  • Joined in 2012
  • **
  • Posts: 851
    • View Profile
    • Dr Andus's toolbox
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #22 on: October 21, 2021, 07:54 AM »
If this helps, for me it was between 2nd October and 4th October that the change has occured (or at least those are the dates on the files, the change may have happened earlier).

Looking at my Windows Update history, the only updates I had (on Win7) around those dates were "Security Intelligence Update for Microsoft Security Essentials".

Earlier and later in the month I also had "Windows Malicious Software Removal Tool x64" updates.

Apart from the Dopus update I had, the only other software change I recall was updating the Google Drive sync tool (whatever it's called).

Jesper Hertel

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 103
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #23 on: March 31, 2022, 07:49 AM »
I have the same problem. The thumbnails only refresh if I open the screenshot folder in Windows Explorer. Then they immediately update in Windows Explorer, and then the updated thumbnails are there again in Screenshot Captor after pressing F5 in Screenshot Captor to refresh. But Screenshot Captor cannot "itself" any longer make thumbnails when taking new screenshots.

That's a pretty big problem, as the thumbnails are quite important for navigation.

I'm using Windows 10 Home (10.0.19043, i.e. 21H1).

Did anyone find a permanent solution that doesn't involve resetting all settings, including settings that have nothing to do with this?

I did install Google Drive recently – could that be the culprit? I don't remember if the problem started at that point, but it could be, since I just remember installing Google Drive during the last 4-6 months and also that the problem with Screenshot Captor appeared within the same time frame. It could also be unrelated.

Nucleorion

  • Participant
  • Joined in 2013
  • *
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Re: ThumbNails No Longer Show Screenshot, Just Generic Flower Icon
« Reply #24 on: March 31, 2022, 08:41 AM »
Hello,

I am currently using jpg instead of png. With the jpg if the thumbnails go