topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • Sunday April 18, 2021, 7:06 pm
  • Proudly celebrating 15+ years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: How to disable auto ScreenShotCaptor software updates  (Read 1143 times)

user7989

  • Participant
  • Joined in 2021
  • *
  • default avatar
  • Posts: 2
    • View Profile
    • Donate to Member
How to disable auto ScreenShotCaptor software updates
« on: January 14, 2021, 12:49 PM »
Ever since the last 3 or so updates, pressing the hotkey to take a capture causes the screen to change resolution.  In other words, the screen gets magnified.  This means that I can not take a screenshot of what I want to, because the part that I want, is now off the screen.

So I found an older version[4.31.1], and it works just fine.  I keep it handy, so that when the software auto-updates, I can tear that out and install the kept version, that is well behaved.

So where do I disable the automatic updates?

TIA

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,509
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: How to disable auto ScreenShotCaptor software updates
« Reply #1 on: January 14, 2021, 03:32 PM »
While SC will not automatically perform updates, it will by default CHECK for updates on startup.  You can disable that by unchecking the last checkbox on the "Startup Options" tab:
Screenshot - 1_14_2021 , 3_32_00 PM.png

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,509
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: How to disable auto ScreenShotCaptor software updates
« Reply #2 on: January 14, 2021, 03:32 PM »
Can you tell me which version of SC you have where this behavior of the magnified window does not happen?

tomos

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 11,799
    • View Profile
    • Donate to Member
Re: How to disable auto ScreenShotCaptor software updates
« Reply #3 on: January 14, 2021, 04:07 PM »
Can you tell me which version of SC you have where this behavior of the magnified window does not happen?
I found an older version[4.31.1], and it works just fine. I keep it handy, so that when the software auto-updates, I can tear that out and install the kept version, that is well behaved
I'm a bit confused by the OP though as SC does not auto-update...
Tom

user7989

  • Participant
  • Joined in 2021
  • *
  • default avatar
  • Posts: 2
    • View Profile
    • Donate to Member
Re: How to disable auto ScreenShotCaptor software updates
« Reply #4 on: January 14, 2021, 05:42 PM »
Can you tell me which version of SC you have where this behavior of the magnified window does not happen?

4.31.1

bombledmonk

  • Supporting Member
  • Joined in 2020
  • **
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Re: How to disable auto ScreenShotCaptor software updates
« Reply #5 on: January 25, 2021, 12:33 PM »
I'm have a similar symptom with v4.36.2 (that's what my about dialog says even though the website says v4.36.1 is the latest) .  It was working fine, then I switched the orientation of my monitors around when I got a new desk (maybe a coincidence?), and now whenever I press the capture hotkey to Grab Selected Region, it zooms in on all my monitors, very strange.  I'm happy to add additional info and help troubleshoot.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,509
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: How to disable auto ScreenShotCaptor software updates
« Reply #6 on: January 29, 2021, 08:27 AM »
Have you rebooted since you swapped monitors around? Or at least restarted SC?

bombledmonk

  • Supporting Member
  • Joined in 2020
  • **
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Re: How to disable auto ScreenShotCaptor software updates
« Reply #7 on: January 29, 2021, 09:52 AM »
Yes, I've restarted many times. Here's  short video with a shot of all the screens while I try to Select A Region.  https://youtu.be/jlwzRozOK70

I download  a fresh portable build and it exhibited these same behavior.    It's so bizarre as It worked before the rearrangement change, but not after.

bombledmonk

  • Supporting Member
  • Joined in 2020
  • **
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Re: How to disable auto ScreenShotCaptor software updates
« Reply #8 on: January 29, 2021, 10:04 AM »
The 38 Beta portable exhibits the behavior as well.

bombledmonk

  • Supporting Member
  • Joined in 2020
  • **
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Re: How to disable auto ScreenShotCaptor software updates
« Reply #9 on: February 08, 2021, 11:21 AM »
So I just tried setting my 4k scale to 100%, and the software behaves normally(with no zooming, aka as expected).   The 4k screen is not my primary screen (see screencap above with the info), but when I set it back 125%, it goes back to the undesirable screen zooming behavior detailed in the video in above post.

My previous setup had monitors to below and to the right hand side of the 4k screen, could it be picking up on the last screen scaling value in some array/list somewhere? 

I just tried changing the organization to having the 4k screen on the left makes it behave normal even with screen scaling of the 4k monitor at 125%.  Working setup is below.Screenshot - 2_8_2021 , 11_18_02 AM.pngHow to disable auto ScreenShotCaptor software updates