topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • Tuesday May 26, 2020, 1:04 pm
  • Proudly celebrating 15+ years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: CHS not capturing URLs in Chrome browser  (Read 1634 times)

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
CHS not capturing URLs in Chrome browser
« on: March 17, 2020, 11:25 AM »
Hi,

I just noticed that %ActiveWindowBrowserUrl% is not capturing the URL in Chrome browser. I guess, this is similar to what has been mentioned in the following post: https://www.donation...ex.php?topic=42687.0.

Does anyone know of a workaround to enable Chrome URL capture in Chrome?

Thanks a ton to everyone here.

m9833

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,214
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #1 on: March 17, 2020, 01:05 PM »
the new alpha release fixes this handily.

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #2 on: March 17, 2020, 01:42 PM »
Ah dear Mouser, it does not matter how many months or years pass between my visits to the forum. Every query that I post is dealt with by you within moments. Much appreciated.

Unfortunately, the alpha version is completely ignoring the quick paste template at my end. It simply results in a simple paste of the clip. Probably, I am overlooking some option.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,214
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #3 on: March 17, 2020, 01:53 PM »
Unfortunately, the alpha version is completely ignoring the quick paste template at my end. It simply results in a simple paste of the clip. Probably, I am overlooking some option.
More likely you found a bug in the alpha..  Can you tell me a bit more how you are using the quick paste template?

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #4 on: March 17, 2020, 02:02 PM »
Of course.

The template, I am trying out is as follows:

====================
%datetime%
%WindowTitle%
%Application%
%Notes.withprefix%
%ActiveWindowBrowserUrl%

%clip%
====================

I did copy the alpha version over the existing setup and overwrote the preexisting files. Will also try with just the alpha version and post the results shortly.

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #5 on: March 17, 2020, 02:07 PM »
Tried just the alpha version, after quitting the existing instance.

The template is again being ignored by the program while pasting. The grid is displaying the information, though.


mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,214
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #6 on: March 17, 2020, 02:30 PM »
What I mean is, what procedure are you using to trigger the paste via template function -- since there are a few different ways to trigger it.

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #7 on: March 17, 2020, 02:39 PM »
Oh! I am sorry for the misunderstanding.

I am using the hotkeys for calling the Quick Paste Menu and then selecting the clip I need from the pop up menu.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,214
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #8 on: March 17, 2020, 02:42 PM »
Ok let me see if I can reproduce and fix.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,214
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #9 on: March 17, 2020, 02:46 PM »
I need more information.

Do you mean that you are right-clicking on a clip and then choosing to paste using the template (can you try that and see if it works?)

Or do you mean you are using the unusual option in CHS to paste *EVERY* clip using the quick template automatically and always?

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #10 on: March 17, 2020, 03:22 PM »
Do you mean that you are right-clicking on a clip and then choosing to paste using the template (can you try that and see if it works?)

Hi Mouser,

This is exactly what I am doing. choosing a clip by right clicking and then pasting it using the template.

Regards,

m

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #11 on: March 17, 2020, 03:54 PM »
Hi Mouser,

I re-downloaded the Alpha version some 5 minutes back and tried quick pasting again. It seems to  be working.

Will give it a try tomorrow on this and another PC and post back the results. Thanks for following through so quickly and tenaciously.

Regards,

m

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,214
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #12 on: March 17, 2020, 04:11 PM »
I'm guessing your problem may only show up when a clip has multiple formats (unicode, etc.); so keep experimenting; it's very likely the problem is still there and just needs the right combination of factors -- when you figure it out let me know so I can fix it.

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #13 on: March 18, 2020, 12:20 PM »
Hi Mouser,

After trying the alpha version on two identical windows 10 PCs I can confirm that every one of the following variables returned a valid value, except %ActiveWindowBrowserUrl%. The URL is however perfectly accessible via %Notes.withprefix%:

====================
%datetime%
%WindowTitle%
%Application%
%Notes.withprefix%
%ActiveWindowBrowserUrl%

%clip%
====================

I also did not find %ActiveWindowBrowserUrl% mentioned as an available variable in the quick paste options window. So probably, I have been trying somethings, which is anyhow not possible. :-)


mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,214
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #14 on: March 18, 2020, 02:41 PM »
Ah I think I understand the problem.

In the database, as you have noticed, the url is store in the Notes/Decription field.
The %ActiveWindowBrowserUrl% variable is actually being cleared I think when you go to paste into a new app.

So I think the solution is just to use the Notes field, no?



EDIT:

So I guess maybe what you're saying is in the template I need to remove the %ActiveWindowUrl% field and make clear to use %Notes% for the url in web captures.
« Last Edit: March 18, 2020, 04:17 PM by mouser »

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #15 on: March 18, 2020, 03:49 PM »
Exactly. Another mystery pounced upon and solved. Thanks a ton Mouser. I plan to hang around much often than in the last years and look forward to our many interactions.

Thanks again for helping me find an excellent working solution.  :Thmbsup:

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,214
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #16 on: March 18, 2020, 04:15 PM »
With the entire world is quarantined indoors, and it feeling very scary outside, at least we have our virtual homes and families!  :Thmbsup:

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #17 on: March 19, 2020, 03:07 AM »
Hear Hear!!!!  :)

Regarding whether the behavior  of %ActiveWindowBrowserUrl% is dependent upon the browser being active or not, I did a small experiment. I copied your last post and pasted the results in my current post.

The template:
====================
%datetime%
%WindowTitle%
%Application%
%Notes.withprefix%
%ActiveWindowBrowserUrl%

%clip%
====================

results in:
====================
19/03/2020 , 3:05:48 am
Post reply - DonationCoder.com - Google Chrome
chrome.exe
Notes: https://www.donation...80.0;last_msg=436924
%ActiveWindowBrowserUrl%

With the entire world is quarantined indoors, and it feeling very scary outside, at least we have our virtual homes and families!  :Thmbsup:

====================

So I guess, %ActiveWindowBrowserUrl%  simply is not active, even when I do not exit the browser. Not that it affects my purpose as %Notes.withprefix% is taking care of the URL.  8)

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,214
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #18 on: March 19, 2020, 03:13 AM »
Yep.  btw "%Notes%" will leave off the "Notes: " word if you dont want that.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,214
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #19 on: March 19, 2020, 03:14 AM »
Regaring ActiveWindowBrowserUrl, what I *could* do if people wanted, was make it hold the url in Notes *IF* there is one, and be blank otherwise (e.g. not display any non-url notes).

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #20 on: March 19, 2020, 03:18 AM »
Yep.  btw "%Notes%" will leave off the "Notes: " word if you dont want that.
5

Hey, Thanks for the tip. This is immensely helpful.

Regaring ActiveWindowBrowserUrl, what I *could* do if people wanted, was make it hold the url in Notes *IF* there is one, and be blank otherwise (e.g. not display any non-url notes).

I guess, this change will make %ActiveWindowBrowserUrl% more useful, if the variable is anyhow inactive.

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 7,531
  • Slartibartfarst
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #21 on: March 19, 2020, 08:40 AM »
@mouser:
With the entire world is quarantined indoors, and it feeling very scary outside, at least we have our virtual homes and families!  :Thmbsup:
Well, I dunno about that. It's pretty scary in MY home. My wife just shouted at me, apropos of nothing in particular: "What the heck are you sitting playing ruddy Fallout 4 for!? You've been playing it for 4 straight hours now! Why don't you get off your fat ugly backside and do something useful instead of wasting your time!" (To a chorus of "Yeah, Dad!" from my two kids. They just want me to get off the laptop so as they can use it. I've been hogging it all morning.)
So I went out for a walk in the deserted streets, crossing the road if I saw a human or a dog or a bat approaching.
It's a lovely day. Early autumn. Deciduous trees starting to come into their glorious reddish-brown shades on the tree-lined avenue where I live, just next door to the local abattoir - which is thankfully silent now.

m9833

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 60
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #22 on: March 19, 2020, 08:47 AM »
Well, I dunno about that. It's pretty scary in MY home. My wife just shouted at me, apropos of nothing in particular: "What the heck are you sitting playing ruddy Fallout 4 for!? You've been playing it for 4 straight hours now! Why don't you get off your fat ugly backside and do something useful instead of wasting your time!" (To a chorus of "Yeah, Dad!" from my two kids. They just want me to get off the laptop so as they can use it. I've been hogging it all morning.)
So I went out for a walk in the deserted streets, crossing the road if I saw a human or a dog or a bat approaching.
It's a lovely day. Early autumn. Deciduous trees starting to come into their glorious reddish-brown shades on the tree-lined avenue where I live, just next door to the local abattoir - which is thankfully silent now.

 :)  You made my day, as I try to create a halfway good online training module, with the clock ticking ominously.

chashnniel

  • Member
  • Joined in 2018
  • **
  • default avatar
  • Posts: 98
    • View Profile
    • Donate to Member
Re: CHS not capturing URLs in Chrome browser
« Reply #23 on: March 20, 2020, 10:34 PM »
Well, I dunno about that. It's pretty scary in MY home. My wife just shouted at me, apropos of nothing in particular: "What the heck are you sitting playing ruddy Fallout 4 for!? You've been playing it for 4 straight hours now! Why don't you get off your fat ugly backside and do something useful instead of wasting your time!" (To a chorus of "Yeah, Dad!" from my two kids. They just want me to get off the laptop so as they can use it. I've been hogging it all morning.)
So I went out for a walk in the deserted streets, crossing the road if I saw a human or a dog or a bat approaching.
It's a lovely day. Early autumn. Deciduous trees starting to come into their glorious reddish-brown shades on the tree-lined avenue where I live, just next door to the local abattoir - which is thankfully silent now.

Here you go...
[ Invalid Attachment ]
WTHfamily.pngCHS not capturing URLs in Chrome browser