topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • Thursday May 19, 2022, 3:47 am
  • Proudly celebrating 15+ years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - jb2233 [ switch to compact view ]

Pages: [1]
1
Screenshot Captor / Re: Settings are reset to default
« on: August 22, 2017, 07:00 PM »
So far the process of restoring the ini file and manually starting SSC has proved to be a successful workaround for the ini file being reset to the default.

I hope this helps in the troubleshooting of the issue.

BTW as per earlier shouldn't the ini files be placed in a subfolder (DonationCoder\AppName\) of the specified folder? not in the specified folder?

2
Screenshot Captor / Re: Settings are reset to default
« on: August 09, 2017, 04:40 PM »
having "skip saving settings on shutdown" ticked or not does stop the settings being overwritten by the defaults

i'm trying, via a bat file at startup; replacing the existing ini file with a copy that has my settings

this seemed to work when the ini had been overwritten

i'll let you know how this goes

3
Screenshot Captor / Re: Settings are reset to default
« on: August 04, 2017, 12:06 AM »
will do

4
Screenshot Captor / Re: Settings are reset to default
« on: August 03, 2017, 10:17 PM »
the "skip saving settings on shutdown" was already unticked

i'll try starting it manually and see what happens

5
Screenshot Captor / Re: Settings are reset to default
« on: August 03, 2017, 09:17 PM »
all files are on the local C: drive, i am the local administrator

i have SC starting with windows, could the setting file's opening be timing out due slow response during windows startup?

i could try starting SC manually after windows has finished initiating - would this be worthwhile?

BTW as per earlier shouldn't the ini files be placed in a subfolder (DonationCoder\AppName\) of the specified folder? not in the specified folder

6
Screenshot Captor / Re: Settings are reset to default
« on: August 03, 2017, 07:29 PM »
this morning the ini file in the base folder specified in the configdir.ini (CONFIGDIR=C:\Applications\) was overwritten with the default settings - this has been working since July 27.

i stopped SC
replaced the default file with a copy of my ini file
restarted SC

and my custom settings were restored, ie set as they should be

so the issue seems to be that for some reason the existing ini file is recreated with the default settings

7
Screenshot Captor / Re: Settings are reset to default
« on: July 27, 2017, 06:17 PM »
my apologies, the previous post has an error

when i moved the ini files to another drive the ini files were created in the base folder ie not the \DonationCoder\ScreenshotCaptor folder

when i copied my ini file to that base folder and restarted SC my preferences were in place

i'll see the current set up works, however, i believe there is still an issue or two to be looked at...

8
Screenshot Captor / Re: Settings are reset to default
« on: July 27, 2017, 05:40 PM »
i changed the configdir to D:\my_data\, when i restarted SC the ini files were created in that folder, ie \DonationCoder\ScreenshotCaptor was appended to the path

i tried moving  \DonationCoder\ScreenshotCaptor  to different drive, and the default settings were used, but the ini files were not created in the base folder used as it was above

see attachments

9
Screenshot Captor / Re: Settings are reset to default
« on: July 27, 2017, 04:38 PM »
yesterday after resetting my preferences i made a copy of my ScreenshotCaptor.ini file.

this morning when i started the pc the preferences had been reset to their defaults.  when i looked at the in explorer the modified time for the ini file was when i started the pc - this may or may not be relevant.  i've attached the reset file, in case you're interested.

restoring the backup ScreenshotCaptor.ini file obviously reset the preferences as i set them.

i will try using the CONFIGDIR=D:\MY_DATA\ option to see if that resolves the issue.

do you have any other suggestions?

10
Screenshot Captor / Re: Settings are reset to default
« on: July 25, 2017, 11:15 PM »
Many thanks for your assistance, it's greatly appreciated

I will not use the configdir.ini at the moment and see if the issue recurs

11
Screenshot Captor / Re: Settings are reset to default
« on: July 25, 2017, 10:56 PM »
So far as I can tell by looking at Security level for the folder there are no restrictions on who can write to them

My question, I suppose, is will SC always look in the right place given that are two My Documents folders?

If I do use the ConfigDir.ini file does the entry need to start in column 1, obviously with no //

12
Screenshot Captor / Re: Settings are reset to default
« on: July 25, 2017, 08:58 PM »
I think you nailed the problem “ScreenshotCaptor.ini” was not where it should be

I uninstalled and reinstalled it again using the defaults

The problem is that my (inherited) PC was modified, they created (somehow) a new “My Documents” and the ini is located there : D:\MY_DATA\DonationCoder\ScreenshotCaptor    not in    C:\USERS\

See attachment for contents of   D:\MY_DATA\DonationCoder\ScreenshotCaptor\ScreenshotCaptor.ini

However, when I setup my preferences in the fresh install it found the folder and created a new ini file

Can I use the    ConfigDir.ini    with    CONFIGDIR=D:\MY_DATA\   to force SC to find the ini file?

13
Screenshot Captor / Re: Settings are reset to default
« on: July 25, 2017, 07:42 PM »
previous entry should say "...only one configdir.ini..."

14
Screenshot Captor / Re: Settings are reset to default
« on: July 25, 2017, 07:41 PM »
I was using the portable version, I deleted it because it was having the same issue.

Currently it’s installed via the installer in the default location : C:\Program Files (x86)\ScreenshotCaptor

I changed the “acquire from scanner” to Ctrl+Shift+Alt+B from none, it was still set after stopping and restarting SC

Next time I notice the other settings have changed I’ll check it as well

There is only configdir.ini on the PC in the above location at it has no active statement - all comments

I am the local admin on this PC

15
Screenshot Captor / Re: Settings are reset to default
« on: July 25, 2017, 07:15 PM »
They are set to the default values I change the "Ctrl+Alt+PrtScrn" to "Repeat Region", it defaults/changes back to the default 

16
Screenshot Captor / Re: Settings are reset to default
« on: July 25, 2017, 06:55 PM »
Thank you, newbie mistake and thanks for the spell check pickup

John

17
Screenshot Captor / Settings are reset to default
« on: July 25, 2017, 05:12 PM »
I have SSV v4.21.1 running on Win7 64bit Pro

I am experiencing an issue whereby my settings are being reset to their default at random times.  The settings include:
 - "Start with windows"
 - "Default new file name" and "custom date format"
 - "hot keys - standard"

I have experienced this issue with both the portable and installed versions of the program.

This is very frustrating, is there fix for the problem?

Many thanks,
John

Pages: [1]