avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • Monday April 6, 2020, 6:22 am
  • Proudly celebrating 15 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Code 19 in Device Manager  (Read 3978 times)


  • Supporting Member
  • Joined in 2008
  • **
  • default avatar
  • Posts: 6
    • View Profile
    • Donate to Member
Code 19 in Device Manager
« on: March 13, 2008, 05:07 PM »
I have XP Pro (SP2) OS on a Dell XPS 600.  Without ANY new hardware/software installs/upgrades my Dell All-in-one Photo 964 printer decided not to print anymore. I can copy, but not print, including test pages of course. In Device Manager (see attached pic's) under imaging devices I had the yellow exclamation point and the reason given as Code 19, Registry corrupted, blah, blah. But the Printer was not flagged. I ran Registry Fix to no avail. Tried to go back to a prior registry backup point(s), a prior restore point(s), uninstall drivers/reinstall drivers, uninstall & reinstall printer software, all to no avail. In Microsoft's database code 19 is dealing with filters listed for cd/dvd drives.  Before I drop kick this thing and reinstall the the OS and start over any body have any cool knowledge out there. I have some basic reasoning brain drain ability with PC's but need help with this please. I hate to take the time to reformat and install all the crap I have on here. Any further info you may need please ask also. Thank you very much.


  • Friend of the Site
  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 4,742
    • View Profile
    • Donate to Member
Re: Code 19 in Device Manager
« Reply #1 on: March 13, 2008, 06:22 PM »
I can't help, but have you tried talking to Dell? 
You might be lucky and find someone there who's come across this issue before.

If you're in the U.S., call 1-800-624-9896 (according to the Dell printer manual)

Good luck with the issue, I feel your pain!


  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,917
    • View Profile
    • Donate to Member
Re: Code 19 in Device Manager
« Reply #2 on: March 14, 2008, 01:56 AM »
Did you uninstall the printer and all associated software, then reinstall?  Worth a try!



  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 1,898
    • View Profile
    • Donate to Member
Re: Code 19 in Device Manager
« Reply #3 on: March 14, 2008, 04:52 AM »
C:\temp\err>err 19
# for decimal 19 / hex 0x13 :
  BTH_ERROR_REMOTE_USER_ENDED_CONNECTION                        bthdef.h
  EMPTY_THREAD_REAPER_LIST                                      bugcodes.h
# SCEP Add-on cannot find a valid certificate based on the
# serial number in the client's PKCS7 message (%2).  %3
# Please find support information at
# http://%1/certsrv/mscep/mscephlp.htm.
# Certificate Services did not start: The Subject Name
# Template string in the registry value
# HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CertSvc\Configuration\%1\
# is invalid.  An example of a valid string is:
# CommonName
# OrganizationalUnit
# Organization
# Locality
# State
# Country

  CR_FAILURE                                                    cfgmgr32.h
  LOG_MODULE_NETNAME                                            clusvmsg.h
  LLC_STATUS_INVALID_LOG_ID                                     dlcapi.h
  HIDP_GETCOLDESC_REPORT_ID                                     hidpddi.h
  IAAPI_BADTGINDX                                               iaapi.h
# /* Bad tag number index into encoded value */
  MD_ERROR_SUB500_BAD_METADATA                                  iiscnfg.h
  IME_RS_SYSTEMMODAL                                            ime.h
# called when system mode
  KDC_ERR_SERVICE_REVOKED                                       kerberr.h
# Credentials for server have been revoked
  POLICY_ERRV_GLOBAL_USER_FLOW_RATE                             lpmapi.h
  MAPI_DIAG_CONVERSION_LOSS_PROHIB                              mapidefs.h
  MMSYSERR_VALNOTFOUND                                          mmsystem.h
  MSIDBERROR_BADREGPATH                                         msiquery.h
# bad registry path string
  NRC_ILLNN                                                     nb30.h
# /* illegal name number                        */
  NDDE_INVALID_WINDOW                                           nddeapi.h
  NMERR_OUT_OF_MEMORY                                           netmon.h
  ODBC_ERROR_WRITING_SYSINFO_FAILED                             odbcinst.h
  OLE_ERROR_GENERIC,                                            ole.h
# Some general error                      */
# The certificate validity period will be shorter than the %1
# Certificate Template specifies, because the template
# validity period is longer than the maximum certificate
# validity period allowed by the CA.  Consider renewing the
# CA certificate, reducing the template validity period, or
# increasing the registry validity period.
  SCESTATUS_TRUST_FAIL                                          scesvc.h
  GE_SSC_ERR_WRONG_SIZE                                         ssc.h
# /* specified wrong size */
# Logging was requested, but the time service encountered an
# error
# while trying to set up the log file: %1.
# The error was: %2
  ERROR_WRITE_PROTECT                                           winerror.h
# The media is write protected.
  LDAP_CONSTRAINT_VIOLATION                                     winldap.h
# for hex 0x19 / decimal 25 :
  BTH_ERROR_UKNOWN_LMP_PDU                                      bthdef.h
  BAD_POOL_HEADER                                               bugcodes.h
# SCEP Add-on cannot find a valid certificate request ID
# based on the transaction ID in the client's PKCS7 message
# (%2).  %3  Please find support information at
# http://%1/certsrv/mscep/mscephlp.htm.
# Certificate Services revoked the certificate for request %1
# for %2.
  CR_INVALID_LOAD_TYPE                                          cfgmgr32.h
  LOG_MODULE_DHCP                                               clusvmsg.h
  LLC_STATUS_INADEQUATE_BUFFERS                                 dlcapi.h
  IAAPI_DUPLCOMPVALUE                                           iaapi.h
# /* Duplicate value for one component in a parsing value*/
  KDC_ERR_PREAUTH_REQUIRED                                      kerberr.h
# Additional pre-authenticationrequired [40]
  POLICY_ERRV_GLOBAL_DEF_PEAK_RATE                              lpmapi.h
  MAPI_DIAG_MULTIPLE_INFO_LOSSES                                mapidefs.h
  MSIDBERROR_BADMAXMINVALUES                                    msiquery.h
# value in MaxValue column of _Validation table is less than
# value in MinValue column
  NRC_NAMCONF                                                   nb30.h
# /* name conflict detected                     */
  NDDE_INVALID_SPECIAL_COMMAND                                  nddeapi.h
  NMERR_LOCK_NESTING_TOO_DEEP                                   netmon.h
  OLE_ERROR_NOT_EMPTY,                                          ole.h
# Client doc contains objects.            */
# The time provider NtpClient cannot determine whether the
# response received from %1 has
# a valid signature. The response will be ignored.
# The error was: %2
  ERROR_SEEK                                                    winerror.h
# The drive cannot locate a specific area or track on the
# disk.
# 46 matches found for "19"

These are all windows error messages for cod 19, but none seem to apply to what you are seeing here i think.

ah actuallly you mention the registry, so maybe it's the section in bold. Error codes come from the free downloadable  http://Microsoft Exc...ror Code Lookup Tool
« Last Edit: March 14, 2008, 04:58 AM by justice »