topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • Sunday October 25, 2020, 3:48 am
  • Proudly celebrating 15+ years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - centur [ switch to compact view ]

Pages: [1]
1
Keyboard issue fixed at my machine  :Thmbsup:

What do you mean with to "check if hotkey configuration still works fine" ? My FARR-launch hotkeys are working fine (but Im using language independent setting Win+Alt+Space). What other hotkeys should I check to help you with this?

2
:) Lucky you. I've spent a full week to figure wtf is going on with my language switcher. I overwrote my default confiigurations, hacked through registry, trying to not connect to any RDPs (I thought that initial cause was that RDP adds server layouts and not removing it properly). But only when I shutdown all my startup programs one by one and logging in and off each time - I figured that it's FARR. The "Bad" side of all my studies   - I realised that I can't just stop using FARR - it's too damn addictive.

3
Hi Jesse.
I have multiple keyboard layouts on my Win8 (as well as on my Win7). To illustrate that - you can go to Control Panel\Language and add another language, which could be used for displaying characters in non-unicode programs and language usually have keyboard layout (besides date formatting rules separators and all that culture specific stuff), which means you can quickly switch from one layout to another and type language specific letters =). I usually have 2 languages installed - English and Russian. And normally I'm pretty happy with en-US (US culture with MM/DD/YYYY date and qwerty-keyboard layout).

Recently I realized that en-US culture formatting is a bit confusing (TFS in visual studio applying en-US culture to date formatting and it becomes a mess, cause Russia and Australia using DD MM YYYY order for dates, not MM DD YYYY one). So I installed different, en-Au culture (and keyboard layout, that is actually standard qwerty) and removed en-Us completely. So now my system have 2 languages ( and 2 layouts) - en-Au and ru-Ru.

Here is how my default  language switcher (win+space) looks when FARR is not loaded:
http://i.imgur.com/TSzsHsN.png?1

When I launch FARR - en-US keyboard layout added:
http://i.imgur.com/8mT0rpI.png?1


No en-US culture added, just keyboard layout. This is a bit annoying cause now I have 2 en layouts and a ru one, as a result - for switching from en to ru I have to press Win+space twice, but from ru to en - only once.

What I read so far somewhere on SO or superuser (can't find exact ref right now) - Windows, not sure is it started with W8, but I didn't run into this issue on win7, could add program-specific layout if certain program explicitly trying to call for it (or something like that, my guesses about the cause could be complete bs). So probably FARR trying to use en-US specific layout and thus Win8 added corresponding entry to lang selector. Sometimes it could be usefull ( so you can use proper layout if no english layout installed), but in some cases, like mine - it should be avoided.

It'll be great if there will be a checkbox in FARR options to enable\disable that behaviour or any other way to configure this.

If you need more details - feel free to contact me by email, (nickname) at gmail com

4
I'm using latest version of FARR portable (v2.206.01) on Win 8 x64 and discovered a weird and annoying behaviour. I removed En-US Region and keyboard layout language from my system and replaced it with Australian one (cause I want DD/MM/YYYY dates everywhere and for other reasons). The issue I run into is that FARR adding EN-US keyboard layout to my list everytime I launching it and this behaviour is veeery annoying ( cause in that case I have 2 En layouts and one Ru one and have to cycle through en-en-ru setup to switch to russian).

I can't find any way to disable this behaviour in FARR, could it be added to options or if it's considered a bug - fixed in next release.
I didn't run into this issue when I used same portable setup on my Win7 x64, so looks like this issue specific to Win8

Thanks in advance

Pages: [1]