topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • April 21, 2018, 02:32 PM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Screenshot captor seems to lose its preferences  (Read 284 times)

psoriasis

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Screenshot captor seems to lose its preferences
« on: March 15, 2018, 02:32 PM »
Somtimes when it comes up it seems to revert to some nascent state where it's lost my preferences and doesn't even know the directory I specified for saving this info.

So, I want to know where/what files this info is kept if nothing else so I can save it off and restore it manually the next time it happens.

Obviously, I would like this not to happen at all.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 38,424
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Screenshot captor seems to lose its preferences
« Reply #1 on: March 15, 2018, 03:10 PM »
For portable version it obviously saves in the directory it's running from.
For normal installs on modern windows (beyond Windows XP), it will save in C:\Users\USERNAME\Documents\DonationCoder\ScreenshotCaptor\ScreenshotCaptor.ini

I would like to hear more about when this problem occurs..

psoriasis

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Re: Screenshot captor seems to lose its preferences
« Reply #2 on: March 15, 2018, 11:43 PM »
BTW, my .ini file is on the D drive then the same relative path.  I used standard windows (i.e. nothing hokey) to movie the Documents, and some other dirs, to the D drive.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 38,424
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Screenshot captor seems to lose its preferences
« Reply #3 on: March 15, 2018, 11:58 PM »
That shouldn't be any problem -- SC obeys the registry settings for where your documents are, so that's fine.
See if you can figure out when your settings seem to get lost.. Is it every time you exit and restart SC, or only when rebooting? Is it possible that a different copy of SC is being started, or something else unusual?

psoriasis

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Re: Screenshot captor seems to lose its preferences
« Reply #4 on: March 16, 2018, 12:18 AM »
So, I went to a backup and restored the Screenshot.ini.new into the Screenshot.ini (and ini.new) and that worked.

One odd thing.  It doesn't seem to start on windows boot.  I have the preferences set to startup.  I can go to the window startup list of task manager and I see screenshotcaptor  in the list and enabled and the properties show it's got the right path.