Well since I am trying to get back into coding, I guess I will get some opinions on a few things. One thing I have always sort of struggled with, and have changed my method many times over the years, is variable naming. My current way is pretty much a single letter to designate the datatype i expect to see in it (i for integer) and then a descriptive name, first letter of each word capitalized for enhanced readability. I really have never worried much about standard conventions to facilitate others reading my code because, frankly I have never written anything anyone would ever want to read.
But, who knows, if I can actually stick with it at some point I may be able to.
I also would like to see a few more threads on various, language agnostic if possible, ways to write code that is readable and such. Also, maybe the more experienced guys (im looking at you Mouser!!) can give us some pointers on how to decide when to write functions to replace code blocks and when to just do it in place. Here is one: When do you write a class instead of a series of functions or methods?