Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 23, 2017, 10:21 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Unable to delete/move clips from the Grid.  (Read 460 times)

shc

  • Participant
  • Joined in 2016
  • *
  • default avatar
  • Posts: 4
    • View Profile
    • Donate to Member
Unable to delete/move clips from the Grid.
« on: July 03, 2017, 09:59 AM »
Unable to delete/move clips from the Grid. Don't know when it became so.
(In the menu deleting is working.)

Recent operations:
(Haven't run it for a long period.)
Updated from 2.36.
Entered the new key.
Adjusted the layouts. Changed the columns, etc.

Any help?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 37,418
    • View Profile
    • Donate to Member
Re: Unable to delete/move clips from the Grid.
« Reply #1 on: July 03, 2017, 04:33 PM »
I seem to remember an old post about this and that the issue was something simple but was fixed.. But it sounds like you are using the latest version..

You say you can delete using the menu but not "otherwise".. can you try restarting the program and then letting me know exactly what you are trying to do that isn't working as you expect.

shc

  • Participant
  • Joined in 2016
  • *
  • default avatar
  • Posts: 4
    • View Profile
    • Donate to Member
Re: Unable to delete/move clips from the Grid.
« Reply #2 on: July 04, 2017, 02:50 PM »
The clip can be deleted in the Quick Paste menu via "Delete this clip now" command in its right-click menu (BTW, see below +1). However, the deleted clip can not be found in Recycle Bin. (Deleted permanently?) And the grid won't be refreshed unless I switch the groups.

But if I do deleting in the grid, the clips will not be deleted, though it shows the confirmation and I choose Yes.

And Unable to move clips to another group by drag-dropping.

Please give me the URL of that old post if it helps.

Where can I download the old versions?
I'm thinking to go back to see if it's OK on 2.36 (portable), if the reason is unclear for the moment.


+1:
I hope this right-click menu can be open via keyboard, e.g., by using Application key.

+2:
DataSize should be right-aligned.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 37,418
    • View Profile
    • Donate to Member
Re: Unable to delete/move clips from the Grid.
« Reply #3 on: July 04, 2017, 02:55 PM »
Are you using the portable version? What OS?

Try downloading the portable version and unpacking that somehere new and  see if everything works in that new install and database.

It sounds like maybe it's having some general problem manipulating clips.


shc

  • Participant
  • Joined in 2016
  • *
  • default avatar
  • Posts: 4
    • View Profile
    • Donate to Member
Re: Unable to delete/move clips from the Grid.
« Reply #4 on: July 05, 2017, 01:44 PM »
Finally found the bug after a long investigation.
It's caused by column reordering.

Example 1:
Use the default Standard layout;
Drag ID column to the right side of any other column;
The problem will occur.

Example 2:
Use the default Standard layout;
Drag any other column to the left side of ID column;
Delete a clip;
It will prompt an error:
Could not convert variant of type (String) into type (Boolean)


Win 7.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 37,418
    • View Profile
    • Donate to Member
Re: Unable to delete/move clips from the Grid.
« Reply #5 on: July 05, 2017, 03:42 PM »
interesting!!!
that sure sounds like a bug, i will try to reproduce here and fix.