Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 04, 2016, 04:26:31 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: ScreenshotCaptor and SMTP/SSL  (Read 1060 times)

cranioscopical

  • Friend of the Site
  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 4,367
    • View Profile
    • Donate to Member
ScreenshotCaptor and SMTP/SSL
« on: October 29, 2015, 07:50:24 PM »
I'm having a little problem when trying to send SMTP/SSL email from ScreenshotCaptor.

From SC without authentication I get, for obvious reasons:
Quote
SMTP Error Sending Email: 503 5.5.1 Error: authentication not enabled

I've adjusted my other software but can't see a way to switch SC to using SSL connections.

Have I missed something? If not, can anyone help me out with a suggestion about how to address/work around this?

@Mouser, would you consider enabling an option for this at some point (unless it's there and I didn't find it)?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: ScreenshotCaptor and SMTP/SSL
« Reply #1 on: November 02, 2015, 09:23:35 AM »
it's a flaw in the current version of screenshot captor -- i really need to add support for SSL email sending.. thanks for the nudge, i will try to do it asap.

there is a workaround -- which is to configure a custom email sender for SC and use one of the "sendmail" clones.  SC is built to allow you to do this, and i believe lanux128 on the forum does this.

cranioscopical

  • Friend of the Site
  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 4,367
    • View Profile
    • Donate to Member
Re: ScreenshotCaptor and SMTP/SSL
« Reply #2 on: November 02, 2015, 09:44:24 AM »
there is a workaround -- which is to configure a custom email sender for SC and use one of the "sendmail" clones.  SC is built to allow you to do this, and i believe lanux128 on the forum does this.
Thanks, looking forward to whenever you have the time to build in SSL, Meanwhile, I'll investigate your suggestion of a custom sender..  :Thmbsup:

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: ScreenshotCaptor and SMTP/SSL
« Reply #3 on: November 02, 2015, 08:23:59 PM »
there is a workaround -- which is to configure a custom email sender for SC and use one of the "sendmail" clones.  SC is built to allow you to do this, and i believe lanux128 on the forum does this.

i lifted the example on the sendEmail website and put it in the option provided by Screenshot Captor. btw sendEmail enables TLS by default.

%APPDIR%Tools\sendEmail\sendEmail.exe -f "your@emailhere.com" -t "%to%" -u "%subject%" -m "%body%" -s smtp.yourserverhere.com:587 -xu "your@emailhere.com" -xp "yourpasswordhere" -a "%file%"

cranioscopical

  • Friend of the Site
  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 4,367
    • View Profile
    • Donate to Member
Re: ScreenshotCaptor and SMTP/SSL
« Reply #4 on: November 03, 2015, 08:15:09 AM »
Quote
i lifted the example on the sendEmail website and put it in the option provided by Screenshot Captor. btw sendEmail enables TLS by default.

Thanks very much for taking the time to spell it out for me, much appreciated! I'm not so much slow off the mark as unable to find the mark in the first place.