Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 08, 2016, 10:13:29 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Do not open PDF at startup  (Read 1178 times)

bm92

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Do not open PDF at startup
« on: May 02, 2015, 02:35:19 AM »
Hello,
I recently updated to Screenshot Captor v4.9.6, from an older version.

My default directory for screenshots contains various files, and a PDF file (which has no relation with a screenshot).
Whenever I restart my computer this PDF opens in my PDF reader ! This annoyance seems to come from Screenshot Captor that scans the directory and only finds the PDF file (no image in the directory), and runs the reader on it.

In Preferences I could not find a way to avoid starting the PDF reader when selecting a PDF file. In fact I don't want this feature introduced in v4.9.5. It would be enough to start the reader with a double-click on the file.
A screenshot captor is primarily used to create an image, not a PDF.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,412
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Do not open PDF at startup
« Reply #1 on: May 02, 2015, 02:41:13 AM »
I will fix this weekend.
Many people do not like this launched of pdf viewer behavior; i will change it so that when you click a pdf file, it will simply show you a statusbar message reminding you that you can double click the file to open it in your default pdf viewer.

don4tor

  • Participant
  • Joined in 2014
  • *
  • default avatar
  • Posts: 6
    • View Profile
    • Donate to Member
Re: Do not open PDF at startup
« Reply #2 on: May 02, 2015, 05:44:40 AM »
I have the same problem as bm92.

Also it would be nice to have an option to completely disable Screenshot Captor's image manager for those of us who just use Screenshot Captor to take screenshot, and use a dedicated image editor like Photoshop when they want to edit it.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,412
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Do not open PDF at startup
« Reply #3 on: May 04, 2015, 12:15:59 AM »
Beta now won't auto open pdf files on selection, and has an option to hide them completely; download here: http://www.donationc...dex.php?topic=3474.0

don4tor

  • Participant
  • Joined in 2014
  • *
  • default avatar
  • Posts: 6
    • View Profile
    • Donate to Member
Re: Do not open PDF at startup
« Reply #4 on: May 04, 2015, 02:49:03 PM »
I'm amazed how fast you corrected this bug, every software editor should be like this :Thmbsup: