Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 29, 2016, 08:39:07 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: WARNING! - installing Internet Explorer 11 may necessitate Firefox re-install.  (Read 2109 times)

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,052
  • Slartibartfarst
    • View Profile
    • Donate to Member
I am a user of Firefox 26 from the beta channel. (OS is Win7-64 Home Premium.)
Today I downloaded and installed Internet Explorer 11 onto a laptop. It required a restart of the laptop, which spent a long time "adjusting settings" before it eventually shut down and restarted.
After restart, everything seemed fine until I started up Firefox, which crashed immediately it was started, before even getting up any browser window. This was consistently repeatable and popped up an error window with the choice of restart or resetting all the Firefox settings - the latter I wished to avoid doing.
Otherwise, Firefox worked OK in protected mode.

So, as an experiment, I download Firefox 26 from the beta channel and installed it. Worked a treat.
Problem solved.

UPDATE 2013-12-25 1142hrs: - just for the record in this thread I started:
The fact of Firefox crashing after I had installed IE11 was, it seems, just a coincidence. I kept FF on its last stable ß update and stopped allowing FF to automatically update. After skipping 3 updates this way, I allowed the 4th one, and it was stable. Subsequent updates have been stable also.
Meanwhile IE11 has been running solid/stable all the time.
« Last Edit: December 24, 2013, 04:51:38 PM by IainB, Reason: UPDATE 2013-12-25 »

4wd

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 4,407
    • View Profile
    • Donate to Member
While not Firefox specifically, the upgrade worked fine here on two Win7HP x64 machines running either Pale Moon x86 or x64.

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,052
  • Slartibartfarst
    • View Profile
    • Donate to Member
UPDATE 2013-12-25 1142hrs: - just for the record in this thread I started:
The fact of Firefox crashing after I had installed IE11 was, it seems, just a coincidence. I kept FF on its last stable ß update and stopped allowing FF to automatically update. After skipping 3 updates this way, I allowed the 4th one, and it was stable. Subsequent updates have been stable also.
Meanwhile IE11 has been running solid/stable all the time.

TaoPhoenix

  • Supporting Member
  • Joined in 2011
  • **
  • Posts: 4,548
    • View Profile
    • Donate to Member
last stable ß update and stopped allowing FF to automatically update.

1. You know Iain is HardCore when he actually used the Beta symbol!

2. How do you stop Firefox (and clones!) from automatically trying to update?


IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,052
  • Slartibartfarst
    • View Profile
    • Donate to Member
last stable ß update and stopped allowing FF to automatically update.
1. You know Iain is HardCore when he actually used the Beta symbol!
2. How do you stop Firefox (and clones!) from automatically trying to update?

1. "beta" --> "ß":
I have an AHK-L script that types the ß symbol:  :*:beta::ß

2. Getting control over auto-update of ß updates:
(a)
Quote
From: http://superuser.com...irefox-from-updating
Type about:config in the awesome bar and search for the key app.update.channel. Change the value to release to get the stable releases only.
___________________________

(b) Go to menu Tools | Options | Advanced | Update and select "Check for updates, but let me choose whether to install them".

TaoPhoenix

  • Supporting Member
  • Joined in 2011
  • **
  • Posts: 4,548
    • View Profile
    • Donate to Member
(b) Go to menu Tools | Options | Advanced | Update and select "Check for updates, but let me choose whether to install them".

Turns out I have already done this, and I'm already on the "Release" channel.

I just keep getting annoyed at the pop ups "do you want to install the updates". I'm on the verge of switching it over to "never look for updates". Has anyone here had any close calls where being one version back before updating truly was a security risk?

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,052
  • Slartibartfarst
    • View Profile
    • Donate to Member
...I just keep getting annoyed at the pop ups "do you want to install the updates"...
What it needs is a "silent" switch.
In about:config there is an app.update.silent setting - not sure whether that would fix it.

Otherwise, I couldn't find anything to help stop this - did a DuckGo search and browsed through about:config settings.
Then I found that you might be able to block the popup with ABP (AdBlockPlus) with "select an element to hide". Not tried it out though. To test it, you would need to set it when the popup occurs.