Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 02, 2016, 08:30:43 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: FolderPathEdit.Text setting in ini file, sometimes whole line is deleted  (Read 2261 times)

jhines97

  • Participant
  • Joined in 2013
  • *
  • Posts: 17
    • View Profile
    • Donate to Member
When I log in to my PC as a regular user account (for testing software interactions) I notice that the line in the ScreenshotCaptor.ini file for the FolderPathEdit.Text is removed from the ini file.  I had to set a mapped drive as the FolderPathEdit.Text (i.e. J:\DonationCoder\ScreenshotCaptor\Screenshots\) as simply using "Screenshots" should work, but since the my documents is redirected to a network share there is an error every time screenshot captor starts up that says that is can't find "\galaxy\users\etemp2\donationcoder\screenshotcaptor\screenshots".  Since "my documents" is redirected to a network share the path in the preceding line needs to begin with \\ (double backslash, not just a single backslash).  Anyhow, specifying a drive letter was working, but since for whatever reason the entire line is being removed from the ini file the fix isn't working anymore.  Anyone have any idea on how to fix this?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Sorry for the delayed response.

It's actually very important to me to ensure that network-paths work as well as they possibly can in Screenshot Captor.

But because i don't use such network paths myself, it's sometimes difficult for me to test stuff or understand the problems people are having.

Can you try to experiment a bit and break down for me as much as you can the precise problems you (and others?) are seeing?  If there are multiple issues let's try to tease them apart and make them as specific as possible, so i can focus on them one at a time.



And please make sure you are using the latest beta release for testing, download here:
http://www.donationc...ex.php?topic=35886.0

Specifically, note that the beta does include a fix for network paths -- maybe that addresses the issues you are seeing.

Last note: If paths are being "reset" by Screenshot Captor, it probably means that the program is concluding that the path does not exist or is not accessible.  That could be a bug, or it could be that the network share is not connected at SC startup time? First we have to figure out the scenario, then I can try to fix the program to accomodate it.

jhines97

  • Participant
  • Joined in 2013
  • *
  • Posts: 17
    • View Profile
    • Donate to Member
Re: FolderPathEdit.Text setting in ini file, sometimes whole line is deleted
« Reply #2 on: September 03, 2013, 02:02:25 PM »
I updated to the latest beta via the download link (4.6).  I made sure there was no profile already created for user "etemp".  I looked in the screencaptor.ini file in the default user folder to make sure the print margins were set to .3, .3, .3, .3 and that the FolderPath was set to "Screenshots".  After the computer had created the user profile and screenshot captor ran (screenshot captor is in the "startup") I received an error message of "Error creating non-exiting directory: '\galaxy\users\etemp\DonationCoder\ScreenshotCaptor\Screenshots'." (everything inside the double quotes was displayed in the error message, I attached a screen grab of the error message)  I am guessing the problem is that the program is trying to call "\galaxy\users\etemp\DonationCoder\ScreenshotCaptor\Screenshots" when it should be trying to call "\\galaxy\users\etemp\DonationCoder\ScreenshotCaptor\Screenshots" (notice the second \ prepending the server name - galaxy).

jhines97

  • Participant
  • Joined in 2013
  • *
  • Posts: 17
    • View Profile
    • Donate to Member
Re: FolderPathEdit.Text setting in ini file, sometimes whole line is deleted
« Reply #3 on: September 10, 2013, 10:48:29 AM »
It has been a week with no replies, do you need additional information mouser?  Oh, and I tested earlier with 4.60 and just today with 4.63.
« Last Edit: September 10, 2013, 11:26:43 AM by jhines97, Reason: Added Details »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FolderPathEdit.Text setting in ini file, sometimes whole line is deleted
« Reply #4 on: September 10, 2013, 07:08:21 PM »
Ok i think i understand the nature of the program now.. Your description of what's going on sounds correct -- it's just getting confused that the directory to save in starts with "\\".

Do I also understand that you have not edited the ConfigDir.ini file?

And remind me what operating system this is?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FolderPathEdit.Text setting in ini file, sometimes whole line is deleted
« Reply #5 on: September 10, 2013, 07:14:06 PM »
jhines, im sending you a personal message with debug version to test.

jhines97

  • Participant
  • Joined in 2013
  • *
  • Posts: 17
    • View Profile
    • Donate to Member
Re: FolderPathEdit.Text setting in ini file, sometimes whole line is deleted
« Reply #6 on: September 11, 2013, 10:05:43 AM »
Ok i think i understand the nature of the program now.. Your description of what's going on sounds correct -- it's just getting confused that the directory to save in starts with "\\".

Do I also understand that you have not edited the ConfigDir.ini file?

And remind me what operating system this is?

I am using Windows 2008 R2 (I test compatibility for programs for our terminal services users to try, and use the server to do screenshots for training materials).  I am not aware of the configdir.ini (all of my stuff was defined in the ScreenshotCaptor.ini file).  I sent your email back with the output from your debug exe program.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: FolderPathEdit.Text setting in ini file, sometimes whole line is deleted
« Reply #7 on: September 11, 2013, 01:21:57 PM »
Looks like jhines and I found the bug in the program that was affecting network paths; new beta is uploaded which fixes it.