Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 03, 2016, 05:40:06 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Problem with some keys/characters  (Read 2671 times)

TucknDar

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 1,104
    • View Profile
    • Donate to Member
Problem with some keys/characters
« on: July 16, 2006, 11:32:47 AM »
Weird thing happens sometimes... Occasionally it seems my keys are "switched around" on the keyboard, for instance when I want to type the '?' character by pressing Shift+the key wit '+' and '?' on it, I get the '_' character. this happens with most of the special character-keys, like -,:'*() etc.

This doesn't happen on a global scale on the system, only in some applications (has happened in Miranda and Opera so far). When I restart the application, the problem is gone.

Any idea what could be causing this?

ps: I found the problem kind of hard to explain, so I'll elaborate if you want to...

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Problem with some keys/characters
« Reply #1 on: July 16, 2006, 12:34:51 PM »
i seem to remember a sticky keys setting in windows that sometimes kicks in.. it's for accessibility problems.  that might be a clue.

TucknDar

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 1,104
    • View Profile
    • Donate to Member
Re: Problem with some keys/characters
« Reply #2 on: July 16, 2006, 12:53:10 PM »
Thanks, but sticky keys are disabled (no pun intended  :-\ ).

Can't reproduce this... weird, but at least it doesn't happen very often  :huh:

jgpaiva

  • Global Moderator
  • Joined in 2006
  • *****
  • Posts: 4,727
    • View Profile
    • Donate to Member
Re: Problem with some keys/characters
« Reply #3 on: July 17, 2006, 03:52:45 AM »
I know what's happening. That has happened to me.
It's because when you press alt+shift (i think that's the combination), you switch to another keyboard layout. If you're not english, most probably you're switching to the english layout. (i'm saying this because i had the exact same problem).
Just search for it on the control panel and remove the english keyboard layout.

TucknDar

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 1,104
    • View Profile
    • Donate to Member
Re: Problem with some keys/characters
« Reply #4 on: July 17, 2006, 04:11:23 PM »
I know what's happening. That has happened to me.
It's because when you press alt+shift (i think that's the combination), you switch to another keyboard layout.
:D Thank you thank you thank you!  :Thmbsup: Boy, am I happy it was a simple solution like that

oh, did I say Thank you?! Thanks!

jgpaiva

  • Global Moderator
  • Joined in 2006
  • *****
  • Posts: 4,727
    • View Profile
    • Donate to Member
Re: Problem with some keys/characters
« Reply #5 on: July 17, 2006, 06:09:51 PM »
Believe me, i've been through that.
It's so frustrating, you can't replicate it, it's not documented anywhere, and you generally can't understand what the hack is hapening.
Truth is: i found this by pure coincidence. I saw someone mentioning the hotkey somewhere and only than i understood that was my problem.
Well... Glad i helped out! :D