Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 04, 2016, 02:28:36 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Windows Script Host is not enabled on Win7 !  (Read 392 times)

shadowman

  • Participant
  • Joined in 2010
  • *
  • Posts: 19
    • View Profile
    • Donate to Member
Windows Script Host is not enabled on Win7 !
« on: October 25, 2016, 01:50:59 PM »
Hello Friends,
     recently i had installed some programs, which i don't recall now.
But after removing i have getting this errors.
WSH.pngWindows Script Host is not enabled on Win7 !
I tried searching this for a fix, and nowhere i can get a valid answer. I went through a number of sites. Here. But it didn't fix my problem. It's really buggin sometimes.
Does anyone know of a better solution for this. I don't want to restore my pc just for a single cause.


Quote
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Script Host\Settings
Double Click on it and give it Value Data 1 to enable it.

    A value of 1 will enable Windows Script Host
    A value of 0 will disable Windows Script Host.

I tried this method but it doesn't work. I am on Win7.x32bit version.
OS:Win XP SP3 and Win7 Pro
« Last Edit: October 25, 2016, 02:49:10 PM by Deozaan, Reason: Removed duplicate screenshot. »

MilesAhead

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 7,277
    • View Profile
    • Miles Ahead Software
    • Donate to Member
Re: Windows Script Host is not enabled on Win7 !
« Reply #1 on: October 25, 2016, 02:59:45 PM »
This page may be a bit more helpful:
http://www.winhelpon...ontact-administator/

Also instead of poking around in Task Manager to get which script caused the error dialog you could use Home Folder 2 from my page here:
http://milesaheadsoftware.org

Run HomeFolder2.exe and it will show an icon in the task tray.  Click on the error dialog to make sure it is the active window.  Press Shift and Number Pad Subtract keys.  Explorer should open to the folder containing the program that generated the error.

My guess is if you uninstalled some stuff the Registry probably lost some info or got corrupted.  If you have a Restore Point running that might fix it.

shadowman

  • Participant
  • Joined in 2010
  • *
  • Posts: 19
    • View Profile
    • Donate to Member
Re: Windows Script Host is not enabled on Win7 !
« Reply #2 on: October 26, 2016, 04:50:29 AM »
Hello Mileahead;
   thank you for your tool, i clicked on the error windows and win/system32 folder opened up. I remember one time, i had installed some
software, which installed lot of crap also some browsers. So i did a scan with Malwarebytes Anti-Malware and so far their is no error message.
There were a huge amount of trash to be deleted. So far so good, i didn't get the WSHost msg pop up.
Thank you for your suggestion, i am keeping that app for time being.
OS:Win XP SP3 and Win7 Pro

MilesAhead

  • Supporting Member
  • Joined in 2009
  • **
  • Posts: 7,277
    • View Profile
    • Miles Ahead Software
    • Donate to Member
Re: Windows Script Host is not enabled on Win7 !
« Reply #3 on: October 26, 2016, 06:44:57 AM »
You are most welcome.  I hope it all works out for you.   :Thmbsup: