Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • October 01, 2016, 08:50:02 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Difficulty with launching FARR when using ` key + focus on desktop.  (Read 3245 times)

stisev

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 123
    • View Profile
    • Donate to Member
Title says it all.

Being left-handed, I find I deviate more to keys on the left side of the my keyboard. Thus, I decided to use the `  (tilde) key to launch FARR. It is incredibly convenient, but there is one slight annoyance.  When focused is strictly on the desktop (and not any other windows or apps) FARR wont toggle. I use Win + A as backup, but I really would like to stick with the tilde key 100% of the time so that my work speed can increase without hesitation.
Is there any to prevent this from happening?  

There is one work-around -- run FARR using EventGhost D:\Applications\Donation Coder\FindAndRunRobot\FindAndRunRobot.exe with command line argument -toggle
This workaround royally sucks though because it is incredibly slower than FARR's wonderful hotkey integration.

I hope we can find a solution to this :(

I am running Windows 8.1 64bit.
« Last Edit: March 09, 2015, 07:41:29 AM by stisev »

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,054
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #1 on: March 09, 2015, 09:17:35 AM »
The tilde key is "~" (Shift+tilde).
The non-shift of the same key simply gives you "`" (on my US keyboard).
I would suggest giving FARR a hotkey combo that is unique and not used/reserved for anything else.
If you want to use your left hand to press the hotkeys, could I suggest that you use remapkey to make CAPS LOCK = Right Shift.
You could then (say) use as your FARR hotkey: Left Shift+Right Shift+ tilde
Nothing else is likely to use that.

As a possible solution to ALL CAPS accidents...
...
Tip - dispatching the CapsLock gremlin with Microsoft's remapkey.exe http://tips4laptopus...ck-gremlin-with.html
It refers to the Microsoft remapkey.exe utility.
...
Other keyboard mapping fixes are useful, but redundant if you use remapkey.exe, which works fine in Windows 2000, Windows XP, Windows Server 2003, Windows Vista, and Win7-64 Home Premium.

stisev

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 123
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #2 on: March 09, 2015, 09:21:16 AM »
Hi IainB,
I misspoke. I was simply using the >>  '  <<  key (NOT tilde).  It is strange. This seems like it's NOT just a FARR issue, but also a Eventghost issue. The only app that I can find that will allow me to launch hotkeys from the desktop is TLBhost (Truelaunchbar in portable mode)

Quote
If you want to use your left hand to press the hotkeys, could I suggest that you use remapkey to make CAPS LOCK = Right Shift
You could then (say) use as your FARR hotkey: Left Shift+Right Shift+ tilde

Sleeping pills def. kicking in, but can you explain this in more detail. How do I remapkey to make CAPS = Right Shift and what does that mean?  FARR will launch with CAPS?

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,054
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #3 on: March 09, 2015, 09:49:06 AM »
The "`" character (I don't know what it is called) is an authentic single key on the keyboard, and should not be used (even if it could be) as a single key to start an app up. That would be just bad practice.

Go and follow/read the link I gave above, to to see how Microsoft's remapkey works.
Then use remapkey to make CAPS LOCK = Right Shift
You then just tell Eventghost, or AutoHotkey, or whatever you use, to execute FARR when the keys  Left Shift+Right Shift+ tilde are pressed simultaneously.

By the way, never, ever take a sleeping pill and a laxative on the same night.



stisev

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 123
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #4 on: March 09, 2015, 09:50:57 AM »
Quote
By the way, never, ever take a sleeping pill and a laxative on the same night.

LOL. Ew!

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,279
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #5 on: March 09, 2015, 09:56:07 AM »
Quote
The "`" character (I don't know what it is called) is an authentic single key on the keyboard, and should not be used (even if it could be) as a single key to start an app up.


Don't knock it till you try it! That's the key I use on my laptop (which doesn't have a Pause/Break key) -- works well for me, and is in a convenient location.

tomos

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 10,251
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #6 on: March 09, 2015, 09:58:10 AM »
Or why not simply use Ctrl+[that-key-whatever-it's-called]
(it looks like the grave accent key http://en.wikipedia....rg/wiki/Grave_accent
odd - the US keyboard doesnt seem to have the accent going the other direction)

I have a quertz keyboard, but use the equivalent keys with FARR -- Ctrl+^ (which is same location as your "`")
Tom

stisev

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 123
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #7 on: March 09, 2015, 10:44:29 AM »
Quote
The "`" character (I don't know what it is called) is an authentic single key on the keyboard, and should not be used (even if it could be) as a single key to start an app up.


Don't knock it till you try it! That's the key I use on my laptop (which doesn't have a Pause/Break key) -- works well for me, and is in a convenient location.

I still can't get this while FULLY focused on the desktop. Can you? (Click somewhere on an empty desktop) and try hiding the this key we are talking about (the other tilde)

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,279
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #8 on: March 09, 2015, 11:03:39 AM »
I'm running Windows 7 and it works fine when focused on the desktop.

Can someone else with Windows 8 test this?  Surely there must be some explanation for such an odd thing.

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,054
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #9 on: March 10, 2015, 10:29:19 AM »
Quote
The "`" character (I don't know what it is called) is an authentic single key on the keyboard, and should not be used (even if it could be) as a single key to start an app up.

Don't knock it till you try it! That's the key I use on my laptop (which doesn't have a Pause/Break key) -- works well for me, and is in a convenient location.

Well, if you are unlikely to ever need that single keystroke for anything else, then I guess it would be fine. I might try it out ... if I can figure how to do that in the FARR Hotkey settings.    :tellme:

FARR Hotkey toggle settings:
I used to use Ctrl+SPACE to toggle FARR, but stopped doing that because Ctrl+SPACE is also the hotkey to create a "hard" space in MS Word. So I used the Pause key instead, but this became a real pain on the laptop I currently use as it has to be Function+Pause, and the Function and Pause keys are at opposing ends of two of the corners of the keyboard rectangle, thus necessitating a two-handed operation.
So I changed to Alt+Space, which is better as it can be done with the left hand only.

stisev

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 123
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #10 on: March 10, 2015, 10:31:07 AM »
Yes, can anyone with Windows 8.1 (pref. 64bit) test this?  Might be a UAC thing, since it almost always is. This MIGHT not be a FARR specific issue, since Eventghost is having the same strange issue (?).

Truelaunchbar doesn't have this problem, which is why I never noticed it before.

Ath

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 2,753
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #11 on: March 10, 2015, 10:44:27 AM »
So I changed to Alt+Space, which is better as it can be done with the left hand only.
That <Alt-Space> keypress opens the System menu on most Windows applications...

skajfes

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 231
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #12 on: March 11, 2015, 03:26:28 AM »
That <Alt-Space> keypress opens the System menu on most Windows applications...

I am using Alt-Space to launch FARR for years now, and I've never missed having opened the system menu. (I am using Win+arrow keys to manage window sizing and moving instead of the system menu)

There is also an alternative. You can use another Mouser tool called TapTap to invoke FARR using a double tap on Ctrl (or any other key)
TapTap
It is impossible to make anything foolproof because fools are so ingenious.

stisev

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 123
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #13 on: March 11, 2015, 06:24:24 AM »
I'm running Windows 7 and it works fine when focused on the desktop.

Can someone else with Windows 8 test this?  Surely there must be some explanation for such an odd thing.

mouser,
As suspected (sigh) and as most of my problems stem from, I have concluded that MS Window's UAC implementation is to blame for the blocking of the keystrokes.

Even if I turn the slider in the UAC control panel, I still have problems.  Disabling UAC thoroughly through a reg key, effectively giving the machine full and TRUE admin access using the following reg key

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"EnableLUA"=dword:00000000

« Last Edit: March 15, 2015, 06:03:01 PM by stisev »

stisev

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 123
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #14 on: March 15, 2015, 06:04:35 PM »
UPDATE:
Running explorer with full elevated priveledges (killing it and running as admin) fixes the problem above. Not my ideal solution would be an understatement of the century and I still don't know why it's happening :(

IainB

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 6,054
  • Slartibartfarst
    • View Profile
    • Donate to Member
Re: Difficulty with launching FARR when using ` key + focus on desktop.
« Reply #15 on: March 16, 2015, 10:39:00 PM »
The "`" character (I don't know what it is called) is an authentic single key on the keyboard, and should not be used (even if it could be) as a single key to start an app up. That would be just bad practice.

Following @mouser's comment:
...Don't knock it till you try it! That's the key I use on my laptop (which doesn't have a Pause/Break key) -- works well for me, and is in a convenient location.

 - using Win8-64 PRO I have tried this out as a single-key toggle for FARR. It works perfectly. I think I shall keep it reserved for that purpose, despite it being - from my training/experience - "just bad practice". It's really very convenient as @mouser points out.

By the way, I did not know it before, but I have learned now that the correct name for this key beneath the tilde mark (used as a Spanish writing accent) is the grave (a mark "`" placed over a vowel in some languages to indicate a feature such as altered sound quality. - ORIGIN C17: Fr. grave).
I would normally have no use whatsoever for the grave key, as I use grave/acute accents for French spelling over the vowel as built-in to the European character set installed in my laptop.
I do occasionally use the tilde when writing, so do not want to reserve that for something else.

As @Ath pointed out:
So I changed to Alt+Space, which is better as it can be done with the left hand only.
That <Alt-Space> keypress opens the System menu on most Windows applications...
- so, as well as adopting the grave key as the FARR toggle (arguably bad practice), I have also released the Alt+Space key combo back to the system (arguably good practice).   :-[