Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • October 01, 2016, 08:49:39 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Why is (was!) Google Translate suddenly greeting me "Error 403 (Forbidden)" ?  (Read 274 times)

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,046
    • View Profile
    • Donate to Member
For the last couple of years I have been using Google Translate via my right-click context menu in Firefox (mark a word > right-click > Search marked word in Google Translate > word translated into Danish) almost every day. It used to be so well working that I didn't bother to install any of my copies of WebWord or Babylon. Google Translate was fast & easy to use.

But that has changed!  :(

Quote from: Google Translate
403. That’s an error.

Your client does not have permission to get URL / from this server. (Client IP address: 2.1(xx.xxx.xx)6
)

GoogleERROR-2016-09-17.gifWhy is (was!) Google Translate suddenly greeting me "Error 403 (Forbidden)" ?

That’s all we know.

of course that's not "all we know"! But for the last couple of weeks it sure is all they have told me.

I don't understand it. I am not aware that anything relevant has changed in my Firefox 47. However, they list my proper IP address (without xes), so maybe it has to do with me as a person? I never log in to my Google account. Is that it? have Google upgraded the hard-playing ball?

If I arrive Google Translate any "normal" way, there is no problem.

Any idea?  :tellme:
« Last Edit: September 17, 2016, 04:52:44 PM by Curt »

tomos

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 10,251
    • View Profile
    • Donate to Member
Re: Why is Google Translate suddenly greeting me "Error 403 (Forbidden)" ?
« Reply #1 on: September 17, 2016, 01:01:02 PM »
How did you set up the context menu entry?
Or is it there by default?

It's not in my context menu, but I'm on Firefox ESR (38.xx).
Tom

Shades

  • Member
  • Joined in 2006
  • **
  • Posts: 2,079
    • View Profile
    • Donate to Member
Re: Why is Google Translate suddenly greeting me "Error 403 (Forbidden)" ?
« Reply #2 on: September 17, 2016, 02:09:15 PM »
Perhaps they think you have bested their translation service and act like sore losers about it... :P

On a more serious note: a string of text is passed to Google when you do the translation request. This string of text is like to be formatted in a certain way. Chances are that this format isn't accepted anymore by Google. Or maybe it is accepted from logged in users only. While they do have several impressive server parks...those are "hammered" 24/7. Google isn't a charity and with other Google services they have seen the impact when they applied the policy change to provide the best/full options of those services to logged in users.

It is likely that Google ((more) actively) implemented this policy now also to their translation service.

Now I don't have the translation option either in my Firefox 47.0.1 with only 10 add-ons/extensions (5 are for adblocking/security, 3 for development, one for tab handling and the last one for downloads). From your previous postings I understand your Firefox has much(!) more add-ons/extensions, so I think it is safe to assume one of those gives you the translation option in the context menu. Perhaps that one needs an update or allows you to alter the string in such a way that it is accepted again by Google. 

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,046
    • View Profile
    • Donate to Member
Re: Why is Google Translate suddenly greeting me "Error 403 (Forbidden)" ?
« Reply #3 on: September 17, 2016, 04:23:39 PM »
Thank you, tomos and Shades.

------------

1) Context Search: https://addons.mozil...ddon/context-search/
http://www.basson.at...addons/contextsearch

2) Add to Search Bar: https://addons.mozil...n/add-to-search-bar/
https://firefox.malt...ns/add-to-search-bar  However, this guy calls himself Dr. Evil...

------------

Quote from: addons.mozilla
Add to Search Bar
Very convenient to search on various sites : 5 of 5 stars
by Sierra - September 9, 2016 ·

Today I notice Google Translate site not working anymore, it shows 403 Forbidden.

-so I guess it's not me, but Google.

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,046
    • View Profile
    • Donate to Member
Problem solved.  :up:

I couldn't get the old procedure to work, so I went looking for an even older solution: Sherlock Holmes' brother, Mycroft Project. Their search box gives many answers, so it can be both difficult and time consumiing to find what you're looking for - but here is a link:
http://mycroftproject.com/search-engines.html?name=Google+Translate
« Last Edit: September 17, 2016, 05:29:30 PM by Curt »