Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 08, 2016, 12:03:17 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Need audio driver(s) for SigmaTel in Windows 7 ...  (Read 4814 times)

barney

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 1,282
    • View Profile
    • Donate to Member
Need audio driver(s) for SigmaTel in Windows 7 ...
« on: November 24, 2009, 09:00:15 PM »
OK,

Disaster just struck.  Restarted Win7, & the audio drivers won't load ... been working fine under Win7RC and even under Win7 for the last week or so.  However when I attempt to reload the drivers, Win7 says the installer won't work - even though it did before <sigh />.  Thought I needed to download new drivers, but having a damnable time finding the right download.  Win7 won't identify the sound card, just tells me it's high definition.  None of the hardware recognition & listing software I've used in the past tells me anything more.  Finally reinstalled Belarc Advisor, and it tells me the sound card is SigmaTel, Inc. - C-Major Audio Version 1.0.5405.0 nd574 .  Unfortunately, I can't use that to find the appropriate codecs on Gateway or SigmaTel site(s).

Box is a Gateway GT5064, 2.8 G cpu, 3 G ram, terabyte drives, sound card embedded on motherboard, if any of that is significant.

W/O sound, I lose a significant portion of usability, i.e., alerts, warnings, audio & video tutorials, voice chat, teleconferencing ... you get the picture.

Does anyone have any idea how to counteract this situation?

(Actually, I was pretty fond of Win7 up until now, in spite of a few unwarranted - to my mind - restrictions.)

Please help if you can ... I'm open to just about any suggestion (no, not Linux ... that's on another partition <chortle />.)

40hz

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 11,768
    • View Profile
    • Donate to Member
Re: Need audio driver(s) for SigmaTel in Windows 7 ...
« Reply #1 on: November 24, 2009, 10:08:13 PM »
Hi:

You most likely need this:

Gateway.gif

Download from this link:

http://support.gatew...Driver%206.10.5405.0

Luck! :Thmbsup:

daor79

  • Guest
Re: Need audio driver(s) for SigmaTel in Windows 7 ...
« Reply #2 on: November 25, 2009, 12:28:49 AM »
OK,

Disaster just struck.  Restarted Win7, & the audio drivers won't load ... been working fine under Win7RC and even under Win7 for the last week or so.  However when I attempt to reload the drivers, Win7 says the installer won't work - even though it did before <sigh />.  Thought I needed to download new drivers, but having a damnable time finding the right download.  Win7 won't identify the sound card, just tells me it's high definition.  None of the hardware recognition & listing software I've used in the past tells me anything more.  Finally reinstalled Belarc Advisor, and it tells me the sound card is SigmaTel, Inc. - C-Major Audio Version 1.0.5405.0 nd574 .  Unfortunately, I can't use that to find the appropriate codecs on Gateway or SigmaTel site(s).

If you need SigmaTel Drivers for Win7 try this link http://www.windows7u...SigmaTelDrivers.html

edited to remove spam links hidden in quoted text. -app103
« Last Edit: November 26, 2009, 12:29:53 PM by app103 »

Innuendo

  • Charter Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 2,255
    • View Profile
    • Donate to Member
Re: Need audio driver(s) for SigmaTel in Windows 7 ...
« Reply #3 on: November 25, 2009, 09:27:13 AM »
If you need SigmaTel Drivers for Win7 try this link http://www.windows7u...SigmaTelDrivers.html

Never heard of www.windows7update.com so thought I'd check it out. The page referenced gives a link to Microsoft's web site. I was using Firefox so I got an error message that I needed to be using IE8.

Fair enough...so I tried through IE8 & that link just leads to the Microsoft Update Catalog & returns 1,000 search results which none on the first page were what the OP needs.

I think 40hz has the right answer.

barney

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 1,282
    • View Profile
    • Donate to Member
Re: Need audio driver(s) for SigmaTel in Windows 7 ...
« Reply #4 on: November 26, 2009, 01:34:37 AM »
Hi:

You most likely need this:
 (see attachment in previous post)
Download from this link:

http://support.gatew...Driver%206.10.5405.0

Luck! :Thmbsup:

Thx, 40Hz, but that's the one that gave me an error ... not the correct audio drive for this system <sigh />.

Tried several others, to no avail.  This is really pulling my cork <groan />.

barney

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 1,282
    • View Profile
    • Donate to Member
Re: Need audio driver(s) for SigmaTel in Windows 7 ...
« Reply #5 on: November 26, 2009, 11:56:34 AM »
Update.

Finally got an older version of the driver installation software to run.  Installed v5.10.4487 of the SigmaTel drivers.  Still don't know why the drivers went away to start with, but audio is back.  Seems funny that the Vista-capable installer won't work, but an XP version will.

Anyway, the issue is resolved - for now <sigh />.

barney

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 1,282
    • View Profile
    • Donate to Member
Re: Need audio driver(s) for SigmaTel in Windows 7 ...
« Reply #6 on: November 28, 2009, 10:24:23 AM »
New update.

The previous fix worked until reboot.  Did not work a 2nd time  >:(.

Ran across Device Doctor - including a portable version -DeviceDoctor Portable - Repair Tool of the Week (http://www.technibbl...ir-tool-of-the-week/) at Technibble, free, and supports Win7.

Tried that.  Program ran, then downloaded the driver(s) I needed - had a little trouble connecting to the Web, but otherwise ran fine.  It doesn't install things, just downloads them and lets you do the install, which I like.  The site maintains its own database and stores the drivers locally, rather than trotting off to a vendor site.

Survived one reboot & one hibernation ... maybe it's fixed this time.

Anyway, the Device Doctor app looks a promising addition to my troubleshooting USB stick.

cmpm

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 2,025
    • View Profile
    • Donate to Member
Re: Need audio driver(s) for SigmaTel in Windows 7 ...
« Reply #7 on: November 28, 2009, 12:05:44 PM »
Sigmatel was updated to IDT PC Audio on  most gateway p2's.

http://www.idt.com/

Windows update may find it.
If not try Driver Genius 9.

http://www.driver-soft.com/

hm, correction, that's pentium d not 2
the pre coreduo machine
not sure if it's the same case with yours
but I had sigmatel and got udpated
but i can't remember from where
« Last Edit: November 28, 2009, 12:38:12 PM by cmpm »