Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 09, 2016, 05:43:04 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Removing Pulseaudio from Ubuntu 9.04  (Read 3513 times)

40hz

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 11,768
    • View Profile
    • Donate to Member
Removing Pulseaudio from Ubuntu 9.04
« on: June 14, 2009, 11:35:12 PM »
For those of us who use Linux for soundwork, one of the bigger annoyances we've had to contend with is Ubuntu's recent insistence on installing Pulseaudio as its default sound server. Unfortunately, removing Pulseaudio in Ubuntu is not as simple as firing up Synaptic (or issuing a sudo apt-get remove command) to get rid of it.

Because of all the audio hassles I was experiencing with Pulse, I eventually abandoned Ubu 9.04 and went back to 8.04. Recently, however, a solution to the 'pulse problem' has been identified by Dave Phillips over at the Linux Journal website.

While reading Dav's review of Ubuntu Studio I happened to notice this:

(Link to full article: http://www.linuxjour...ts-ubuntu-studio-904 )

Quote
Ubuntu Studio employs Pulseaudio as its default sound server. Unfortunately this employment stands in the way of directly using JACK, and any Linux distribution that advertises itself as an audio production system will assuredly be using JACK for its audio server, not Pulseaudio. The typical solution would simply remove Pulseaudio, but Ubuntu doesn't let that happen without removing the GNOME desktop, a rather drastic operation. Worse, the Pulseaudio daemon is persistent, so killall pulseaudio works only until the next call to the audio system, when the daemon reloads itself and remains in the way of a successful launch of JACK. Fortunately I discovered an excellent HOWTO titled Keeping The Beast Pulseaudio At Bay by a user with the handle of idyllictux. Thanks to his instructions I safely disabled Pulseaudio, and I recommend his advice to anyone who wants to put aside Pulseaudio.

After having read a large number of (mostly useless) forum posts on fixing Ubuntu's implementation of Pulseaudio, I was almost afraid to hope that this was finally going to solve my problem. But it did! Keeping The Beast Pulseaudio At Bay had the working solution for how to correctly remove Pulseaudio from Ubuntu Jaunty Jabberwocky Jackalope.


Here's the direct link:

http://idyllictux.wo...t-pulseaudio-at-bay/

Your mileage may vary. But if you're struggling with Pulseaudio on Ubuntu, why not give the above solution a try? It worked for me! :)


"O frabjous day! Callooh! Callay! He chortled in his joy." :Thmbsup: