Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 09, 2016, 01:16:19 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: MP3GainGUI and Windows / Office Installer bug  (Read 5843 times)

Ampa

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 592
  • I am cute ;)
    • View Profile
    • MonkeyDash - 2 Player strategy boardgame
    • Donate to Member
MP3GainGUI and Windows / Office Installer bug
« on: April 13, 2007, 06:25:56 AM »
I use MP3Gain along with its GUI to add replaygain information to my mp3 collection. Recently a peculiar bug has emerged that I really can't fathom...

When I launch MP3GainGUI the Windows installer appears (with the title Microsoft Office Enterprise 2007) and starts trying to install a component.

InstallerBar.png

This then tells me that the network component cant be found, and prompts me to search for the file 'EnterpriseWW.msi'

InstallerPrompt.png

If I cancel the dialog it simply reappears.

If I cancel the dialog 6 or 7 times in a row MP3GainGUI opens and functions correctly.

MP3GainGUI.png

It didn't do this last week!! What on earth is going on!!

I have googled briefly and discovered that other people have experienced similar issues, but none seem to have found a solution. Each case seems to be looking to configure / install some random piece of software  which is entirely unconnected with MP3Gain (not always Office, sometimes Adobe products or plugins).

I have reinstalled MP3Gain several times, using both the zip file and installer from the website - with no effect.

Some 'solutions' I've read are the usual guff... reinstall windows - reinstall office - use Linux! but none seems to get to the root of the problem.

So far as I can see MP3Gain is no longer updated - is there an equivalent active piece of freeware?
« Last Edit: April 13, 2007, 06:28:27 AM by Ampa »

Lashiec

  • Member
  • Joined in 2006
  • **
  • Posts: 2,374
    • View Profile
    • Donate to Member
Re: MP3GainGUI and Windows / Office Installer bug
« Reply #1 on: April 13, 2007, 06:58:19 AM »
Unless you use the commandline version, the only program I can think about is foobar2000, which has a ReplayGain scanning function, not only for MP3, but also for other formats.

jgpaiva

  • Global Moderator
  • Joined in 2006
  • *****
  • Posts: 4,727
    • View Profile
    • Donate to Member
Re: MP3GainGUI and Windows / Office Installer bug
« Reply #2 on: April 13, 2007, 07:34:07 AM »
This happens frequently.
I think it's related to the stupid ms installer.
It happened to me recently. I solved it by using a "fix ms installer" kind of thing that just removed the instalation files of office (not office itself). It did work, the stupid installer stopped appearing in places where it wouldn't make sense, BUT, the office shortcuts and file associations were deleted and everytime i opened any office app, the processor would go up do 100%, although everything worked as expected.

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: MP3GainGUI and Windows / Office Installer bug
« Reply #3 on: April 15, 2007, 09:49:21 PM »
Ampa, why don't you try the no-installer version?

http://mp3gain.sourc...rge.net/download.php
ws-mp3gain-1.png

Ampa

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 592
  • I am cute ;)
    • View Profile
    • MonkeyDash - 2 Player strategy boardgame
    • Donate to Member
Re: MP3GainGUI and Windows / Office Installer bug
« Reply #4 on: April 16, 2007, 07:13:56 AM »
Lanux: have already tried that. The issue is not with the MP3Gain installer, but with the general Windows installer which has got its wires crossed. I've read a bit more about this issue on Annoyances.org but have not actually found an elegant solution.

Most suggestions seem to involve deactivating the windows installer, blanket removal of installation records from the registry or mass reinstallation of various bits of software.

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: MP3GainGUI and Windows / Office Installer bug
« Reply #5 on: April 16, 2007, 08:23:24 PM »
oh, sorry about that.. were you beta-testing Office2007 before installing the retail version? btw, i did a search here but find anything relevant -> Google - installer EnterpriseWW.msi, maybe you'd like to have a look.. :)