Welcome Guest.   Make a donation to an author on the site October 31, 2014, 04:55:45 AM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
Learn about the DonationCoder.com microdonation system (DonationCredits).
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: treeview displays wrong contents after some inserting/moving/deleting  (Read 8603 times)
pencoe
Supporting Member
**
Posts: 16


View Profile Give some DonationCredits to this forum member
« on: October 11, 2006, 01:33:43 AM »

When i'm doing some editing about the structure if my launchbar, the shown content of groups becomes wrong.

Example: i have some root level item folowed by some groups. The group contents are not visible ("+" sign in front). Now i add some items to the content above these groups (using context menu). When i'm now opening a group (switching the + sign), the wrong content is displayed. After closing Prefs and reopening, everything is fine again.

Bye, Peter
Logged
lanux128
Global Moderator
*****
Posts: 6,120



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: October 11, 2006, 01:39:44 AM »

hi there pencoe,

welcome aboard!
btw, in your case, a screenshot would be nice. it makes things easier to understand.
Logged

mouser
First Author
Administrator
*****
Posts: 33,611



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #2 on: October 11, 2006, 01:46:11 AM »

i'll see if i can reproduce.. a good clue is that after prefers repoen its ok.

is it just the images that are incorrect or the actual node labels?
Logged
pencoe
Supporting Member
**
Posts: 16


View Profile Give some DonationCredits to this forum member
« Reply #3 on: October 11, 2006, 05:47:32 AM »

i added two snapshots

as you can see, after inserting two new nodes, the content of the third group is displayed in the first and second group too following the insertion point.


* Befor.jpg (57.18 KB, 283x704 - viewed 353 times.)

* After.jpg (69.93 KB, 350x712 - viewed 356 times.)
Logged
mouser
First Author
Administrator
*****
Posts: 33,611



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #4 on: October 11, 2006, 06:21:02 AM »

how strange! ok i'll look into it, you've given me enough to go on i think..
if you feel comfortable doing so (or after editing) it would help me if you sent the .mcf file defining your toolbars (mouser@donationcoder.com), but i'll see if i cant reproduce it without them.
Logged
mouser
First Author
Administrator
*****
Posts: 33,611



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #5 on: October 12, 2006, 01:49:54 AM »

i've uploaded a beta version here that hopefully fixes the problem:
http://www.donationcoder....ta/LaunchBarCommander.exe

please make a backup of your tree before doing too much experimenting (there is a built in backup function in tree config dialog Tools -> Maintenance -> Backup).
Logged
pencoe
Supporting Member
**
Posts: 16


View Profile Give some DonationCredits to this forum member
« Reply #6 on: October 12, 2006, 02:37:50 AM »

ok, i did some testing with this version: i created a new file, added some groups filled with some commands (see stage1). Then i added step by step three additional entrys above the existing groups (stage2 to stage4)

See yourself in the attached screenshots...

When i delete a node, everything works fine.


* Stage1.jpg (21.57 KB, 154x271 - viewed 359 times.)

* Stage2.jpg (22.6 KB, 154x289 - viewed 358 times.)

* Stage3.jpg (23.26 KB, 157x315 - viewed 350 times.)

* Stage4.jpg (23.98 KB, 160x329 - viewed 347 times.)
Logged
mouser
First Author
Administrator
*****
Posts: 33,611



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #7 on: October 12, 2006, 02:43:16 AM »

ok so yet something different strange is now happening..   Angry

can you send me your test.mcf so i can work with same file?
(mouser@donationcoder.com)
Logged
mouser
First Author
Administrator
*****
Posts: 33,611



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #8 on: October 12, 2006, 03:04:09 AM »

i've confirmed this, no need to send. working on it..
Logged
mouser
First Author
Administrator
*****
Posts: 33,611



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #9 on: October 12, 2006, 04:42:51 AM »

ok i think i've got it this time!

http://www.donationcoder....ta/LaunchBarCommander.exe
Logged
pencoe
Supporting Member
**
Posts: 16


View Profile Give some DonationCredits to this forum member
« Reply #10 on: October 12, 2006, 04:51:53 AM »

 Yep, this one seems to solve this problem!  Thmbsup

Thank you very much  Kiss

BTW: do you sleep sometimes?!?  smiley
Logged
mouser
First Author
Administrator
*****
Posts: 33,611



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #11 on: October 12, 2006, 04:55:18 AM »

pencoe -
when i have helpful users like you who are willing to test things and report bugs without getting mad, i thank my lucky stars and skip sleep until the bugs are killed smiley

well at least usually i try to, sometimes i have to go to sleep in a tent and hide from the bugs tongue

Logged
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.031s | Server load: 0 ]