topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • Sunday April 5, 2020, 3:00 am
  • Proudly celebrating 15 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: major problem on boot  (Read 682 times)

phoenix1971

  • Participant
  • Joined in 2016
  • *
  • default avatar
  • Posts: 15
    • View Profile
    • Donate to Member
major problem on boot
« on: March 23, 2020, 04:24 PM »
i hope somebody can help me,i have the launchbar on a USB stick,when i plug it into one pc it works exactly how ive set it up,however when i insert into another pc its as though it is a new install and just the very basics are shown and also no programs in the nodes, any advise welcome, cheers

Shades

  • Member
  • Joined in 2006
  • **
  • Posts: 2,641
    • View Profile
    • Donate to Member
Re: major problem on boot
« Reply #1 on: March 23, 2020, 05:46 PM »
Sounds to me like you store the configuration file(s) of your launchbar on the computer, not your USB stick. And when you use the pendrive on another computer, it will not find your configuration and needs to use the most minimal defaults before it is able to run on the other computer.

Better find out where you store your configuration file(s) and copy these into the folder that contains your launchbar on the pen drive. Most software check more than one location to find their configuration file. The default Windows user account folders are often used, Windows registry is often used, but also the folder that you run the application from. 

phoenix1971

  • Participant
  • Joined in 2016
  • *
  • default avatar
  • Posts: 15
    • View Profile
    • Donate to Member
Re: major problem on boot
« Reply #2 on: March 23, 2020, 08:57 PM »
yeah ive checked that,it was working perfect a day ago on both machines ,and now its a bugger lol,is there anywhere else to look for the files as i cant see anything here cheers

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,067
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: major problem on boot
« Reply #3 on: March 23, 2020, 09:09 PM »
It sounds like LBC is not loading your actual launchbar file.

LBC uses a couple of different files to store your data.  Let's look at how they work:

LaunchBarCommander.ini - stores some very basic options (but not any data for any launchbars or what nodes/buttons are on them).
LaunchBarCommander.mcp - this stores basically the main options of the program and which launchbar files are loaded (but again not the actual launchbar button node data)

Then you have the actual launch bar files which end in extension .MCF
These are the main files that hold your buttons and menus.

It's an unusual separation of data and it can lead to some confusion.



So in your case it must be that the program is not loading the .mcf file with your actual nodes.
When people experience this they sometimes think they have lost their data, but it's probably just that it's not loading the .mcf file (or that you failed to copy that file).
It may just need you to, from LBC, load the .mcf file.  After you exit it should remember for next time that it should load that .mcf file with your nodes/buttons, etc.

phoenix1971

  • Participant
  • Joined in 2016
  • *
  • default avatar
  • Posts: 15
    • View Profile
    • Donate to Member
Re: major problem on boot
« Reply #4 on: March 23, 2020, 10:20 PM »
ive backup up the current files in the preferences page,i assume that it backed it to a folder in my documents,do i just copy that into the launchbar folder on the flash drive? cheers

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,067
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: major problem on boot
« Reply #5 on: March 23, 2020, 10:55 PM »
when you use the LBC backup function it renames the files to have a .bak extension, so it's not like it will automatically load those.
so just copy over the most recent .ini,.mcp, and .mcf files.