topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • January 26, 2020, 05:55 AM
  • Proudly celebrating 14 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Last post Author Topic: Broken icons for 64bit programs  (Read 1562 times)

Faziri

  • Supporting Member
  • Joined in 2013
  • **
  • Posts: 10
    • View Profile
    • Donate to Member
Broken icons for 64bit programs
« on: December 23, 2019, 06:26 PM »
As previously mentioned here and some other topics, FARR somehow incorrectly loads icons for 64bit programs.

A perfectly working shortcut's properties as shown by the system:
DELLSON_2019-12-24_01-14-43[1].pngBroken icons for 64bit programs

The exact same shortcut file, shown by farr:
DELLSON_2019-12-24_01-16-41[1].pngBroken icons for 64bit programs

DELLSON_2019-12-24_01-20-48[1].pngBroken icons for 64bit programs

Is there a solution (or acceptable workaround like some hack in farr) to this issue in sight, please? It has confused (only just found it was farr all along) and annoyed me for years by now. I read that it was actually fixed before but then regressed.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #1 on: December 25, 2019, 08:17 AM »
I was going to post and say I didn't know why that might be happening, but I see the icons are problematic for shortcut links to 64bit apps.. I should be able to fix..
I'm going to do a FARR update this week so I'll try to get it done this week.. Would appreciate any help testing.

Faziri

  • Supporting Member
  • Joined in 2013
  • **
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #2 on: December 25, 2019, 08:23 AM »
Sure, I can help test (I'm a software dev, though not specialized in windows native). Thanks for picking this up.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #3 on: December 26, 2019, 01:51 PM »
Faziri, I don't think this will matter but can you show me the "Tweaks and Debugging" tab of your FARR preferences:
Screenshot - 12_26_2019 , 1_50_27 PM.png

Faziri

  • Supporting Member
  • Joined in 2013
  • **
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #4 on: December 26, 2019, 01:54 PM »
DELLSON_FindAndRunRobot_2019-12-26_20-52-59[1].pngBroken icons for 64bit programs

Turning that option off and restarting farr doesn't change anything

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #5 on: December 26, 2019, 02:10 PM »
Ok just checking..

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #6 on: December 26, 2019, 02:39 PM »
Here's the weird thing.. Here's my search for libre, on win 7 64bit, with libreoffice 64bit installed:
Screenshot - 12_26_2019 , 2_38_10 PM.png

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #7 on: December 26, 2019, 02:39 PM »
So the question is.. why is it showing fine for me but not for you..

Anyone else?

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #8 on: December 26, 2019, 02:42 PM »
In the very unlikely chance that it has something to with my last official build, I've uploaded a beta of FARR with my latest build; let's check to make sure that doesn't solve it:
Download beta version (2.233.01) from here (portable zip).

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #9 on: December 26, 2019, 02:43 PM »
It's possible that even though it's displaying properly on my machine, it's actually asking Windows for the wrong icon file, and that I can fix it.  I just want to eliminate other possibilities first..
What OS are you using?

Faziri

  • Supporting Member
  • Joined in 2013
  • **
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #10 on: December 26, 2019, 02:45 PM »
Well I'm om 10, so probably some influence from the OS changed between 7 and 10. Would you like to set up the source code and dev env on my pc and remote into it so you can debug it?

I'll try the beta in a minute.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #11 on: December 26, 2019, 02:50 PM »
Would you like to set up the source code and dev env on my pc and remote into it so you can debug it?

No, though I may have you try a debug-build that will log for me what files it thinks its asking for icons from.
Hopefully it's simply a matter of FARR mistakenly asking for the icon for exe that it thinks is in Program Files x86, when it should be specifying the file in Program Files\

Faziri

  • Supporting Member
  • Joined in 2013
  • **
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #12 on: December 26, 2019, 03:00 PM »
The beta doesn't help

2019-12-26_22-00-00_DELLSON[1].pngBroken icons for 64bit programs

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #13 on: December 26, 2019, 03:52 PM »
Ok let me upload a debug version for you to test.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #14 on: December 26, 2019, 03:58 PM »
Here's a DEBUG version that will log a LOT of debug info to a debug text file:
http://www.donationc...RunRobotPortable.zip

Unzip that in portable directory.  Exit regular farr, start this one, search for your libre calc, then exit farr soon after it shows up in the display.

The resulting debugout.txt file should contain information about how it found the icon images, etc.  and you can mail that to me ([email protected]);  it won't have any sensitive info in it, but feel free to look it through before you send it.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #15 on: December 26, 2019, 05:49 PM »
I've uploaded a new fixed version as a beta version -- I'd appreciate anyone telling me if they see anything that i made worse :)


Nod5

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 1,003
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #16 on: December 27, 2019, 11:24 AM »
Short on time, but just a quick confirmation that in Windows 10 .lnk files to 64bit applications show incorrect icons in FARR v 2.24. Aliases with results that include a path a to 64bit .exe show the correct icon.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #17 on: December 27, 2019, 12:25 PM »
Can you try the beta?

Nod5

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 1,003
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #18 on: December 28, 2019, 04:01 AM »
Can you try the beta?
Did a very quick test of the portable beta. Working icon for .lnk shortcut to 64bit (C:\Program Files\ ...) applications in Win 10.  :up:

Faziri

  • Supporting Member
  • Joined in 2013
  • **
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #19 on: December 28, 2019, 08:58 AM »
I just noticed another broken icon, but it seems to be a diffferent problem. This happens with both the latest release and this thread's beta.

2019-12-28_14-33-14_DELLSON_FindAndRunRobot[1].pngBroken icons for 64bit programs
2019-12-28_14-33-22_DELLSON_FindAndRunRobot[1].pngBroken icons for 64bit programs

The properties window is the one opened through farr, which for the previous issue showed the broken path. This time farr actually gets the path right. The "skip some icon lookups" option is disabled. This copy of Spek (0.8.2) is installed with Chocolatey (which shouldn't make any difference).

Also, the latest release from the homepage installs 2.229.01 while the website says it'll be 2.234.01. The beta installer installs the same version number, 2.229.01.

Copying the exe to another path makes the icon work:
2019-12-28_16-13-18_DELLSON_explorer[1].pngBroken icons for 64bit programs
« Last Edit: December 28, 2019, 09:13 AM by Faziri »

Nod5

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 1,003
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #20 on: December 29, 2019, 05:02 AM »
Faziri, it might help mouser if you explicitly say if the beta version fixes the original problem with .lnk shortcut to 64bit also on your PC.

I just noticed another broken icon, but it seems to be a diffferent problem.
I can't reproduce that. On my Win 10 PC .lnk files in
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\
or its subfolders show correctly in FARR.

Is the new icon issue you describe only happening to "Spek.lnk" ? Or for all .lnk shortcut files in that folder?

Faziri

  • Supporting Member
  • Joined in 2013
  • **
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #21 on: December 29, 2019, 03:11 PM »
>  it might help mouser if you explicitly say

We were in touch via email, no worries.

And yeah, only for spek.lnk. Attached the exe and shortcut (spek.alias = spek.lnk). This seems to be a different problem from the original, but it also only happens in farr, so...
2019-12-29_22-07-28_DELLSON_firefox[1].pngBroken icons for 64bit programs

Faziri

  • Supporting Member
  • Joined in 2013
  • **
  • Posts: 10
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #22 on: January 03, 2020, 05:48 PM »
So I figured out the problem; there's nothing wrong in farr, but the program installer. The icon path for this shortcut was set to `%SystemRoot%\Installer\{7CDF6754-F5A0-4F34-B589-197530FEF862}\ProgramIcon` — instead of the relevant exe/ico/dll path — which is actually the icon as shown. So false alarm, sorry. Very strange installer behavior.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,849
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #23 on: January 03, 2020, 06:23 PM »
happy ending  :P

Nod5

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 1,003
    • View Profile
    • Donate to Member
Re: Broken icons for 64bit programs
« Reply #24 on: January 04, 2020, 04:46 PM »
Confirming that icons work for 64bit applications also in the as of now latest beta.

By the way, I now noticed that FARR also accepts these ways of setting an icon from any absolute path (not sure if new or not)
/ICON="C:\test\test amazon.ico"
/ICON=C:\test\test amazon.ico

I like that we can use absolute paths. But that is not yet documented in the beta version of this help file page
http://www.donationc...l_search_phrases.htm

BTW my first hunch was that using /ICON without doublequotes around the absolute path could cause problems, but I acually didn't find any conflict case. For example this combination of special frontslash alias syntaxes does not cause a problem
/ICON=C:\test\test amazon.ico /hint="test hint"