topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 16, 2018, 05:55 PM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Bug: Posting to or reading a thread redirects to non-HTTPS site.  (Read 3412 times)

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 8,595
    • View Profile
    • The Blog of Deozaan
    • Donate to Member
1. Be on the HTTPS site.
2. Navigate to forum and begin writing a new post/reply.
3. Click Post.
4. Observe that you are now on the non-HTTPS site.
5. ...
6. Profit!

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 8,595
    • View Profile
    • The Blog of Deozaan
    • Donate to Member
Re: Bug: Posting to a thread redirects to non-HTTPS site.
« Reply #1 on: March 14, 2018, 01:31 AM »
Hmm, actually, it seems that the act of just reading any thread takes you to the non-HTTPS site.

Updated the topic to be more accurate.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 39,027
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Bug: Posting to or reading a thread redirects to non-HTTPS site.
« Reply #2 on: March 14, 2018, 01:32 AM »
Testing...
Doesn't happen here.  Post or read, I stay on https version of site.

Stoic Joker

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 6,483
    • View Profile
    • Donate to Member
Re: Bug: Posting to or reading a thread redirects to non-HTTPS site.
« Reply #3 on: March 14, 2018, 07:30 AM »
I can't reproduce the behavior either.

Ath

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 3,292
    • View Profile
    • Donate to Member
Re: Bug: Posting to or reading a thread redirects to non-HTTPS site.
« Reply #4 on: March 14, 2018, 12:23 PM »
@Deozaan, your logo links to a non-https image, could that be the cause of your issue?

wraith808

  • Supporting Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 9,891
    • View Profile
    • Donate to Member
Re: Bug: Posting to or reading a thread redirects to non-HTTPS site.
« Reply #5 on: March 14, 2018, 01:36 PM »
@Deozaan, your logo links to a non-https image, could that be the cause of your issue?

I think you're onto something; the security notice states that some images are not secure, and that attackers may be able to see the images you view from the site.

UPDATE: Actually, his logo seems to be hosted onsite, but the images in his .sig are not, and are not secure.

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 8,595
    • View Profile
    • The Blog of Deozaan
    • Donate to Member
Re: Bug: Posting to or reading a thread redirects to non-HTTPS site.
« Reply #6 on: April 04, 2018, 11:24 AM »
So all the rest of you can read this thread on the https site? If so, what happens to the images in my signature? I don't get any notice or prompt to allow non-https content. I just get automatically redirected to the fully non-https site when reading threads.

tomos

  • Charter Member
  • Joined in 2006
  • ***
  • Posts: 11,374
    • View Profile
    • Donate to Member
Re: Bug: Posting to or reading a thread redirects to non-HTTPS site.
« Reply #7 on: April 04, 2018, 11:40 AM »
So all the rest of you can read this thread on the https site? If so, what happens to the images in my signature? I don't get any notice or prompt to allow non-https content. I just get automatically redirected to the fully non-https site when reading threads.

not a problem here:
once https it stays that way (will see shortly what happens when I post**)
All your signature icons are still visible.

** [EDIT//] still https
Tom

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 8,595
    • View Profile
    • The Blog of Deozaan
    • Donate to Member
Re: Bug: Posting to or reading a thread redirects to non-HTTPS site.
« Reply #8 on: April 04, 2018, 02:21 PM »
After further investigation it seems that maybe I just got confused by the lock icon in my address bar.

https://streamable.com/3h24l

It seems that because some of the content is insecure (such as my signature images), the lock disappears and shows only the normal globe icon. And since the address bar doesn't show the HTTPS:// part of the URL this behavior led me to believe the site was no longer on HTTPS. But if I try to copy and paste from the address bar, it does include HTTPS after all.


wraith808

  • Supporting Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 9,891
    • View Profile
    • Donate to Member
Re: Bug: Posting to or reading a thread redirects to non-HTTPS site.
« Reply #9 on: April 04, 2018, 05:18 PM »
I still get the i in a circle (information icon?) instead of the lock in chrome.  When I click on it, it says that my connection to this site is not fully secure.  Attackers may be able to see the images on this site and modify them.

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 8,595
    • View Profile
    • The Blog of Deozaan
    • Donate to Member
Re: Bug: Posting to or reading a thread redirects to non-HTTPS site.
« Reply #10 on: April 09, 2018, 10:41 AM »
Thanks for the help, everyone!

I'm closing this thread to prevent spammers from posting.