Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • October 17, 2017, 04:55 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Forgets Settings on Boot  (Read 515 times)

Booma-Booma

  • Supporting Member
  • Joined in 2006
  • **
  • default avatar
  • Posts: 45
    • View Profile
    • Donate to Member
Forgets Settings on Boot
« on: May 04, 2017, 06:42 AM »
Hi All, I am having a bit of trouble with Screenshot Captor and it forgetting its settings.

I am using v4.20.1 and IT at work have setup roaming profiles. I think this is the problem. So as a first step I put ConfigDir.ini in the installation folder and have CONFIGDIR = D:\documents\ which is a folder on my d drive that isn't under the roaming profiles. In D:\documents I have ScreenshotCaptor.ini which is setup correctly.

I every time I boot the laptop up Screenshot captor seems to forget the settings. The odd thing is that it is looking at the d:\documents folder, but it doesn't seem to find the ScreenshotCaptor.ini because it creates a new folder to put the screenshots in and displays the quick access bar which I always turn off. There are also a few other settings like adding the screen capture to the clipboard and not playing any capture sounds.

Any ideas would be appreciated.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 37,485
    • View Profile
    • Donate to Member
Re: Forgets Settings on Boot
« Reply #1 on: May 04, 2017, 12:36 PM »
It sounds like you are basically diagnosing the problem correctly and trying to solve it in the correct way.

It may simply be a matter of it putting the ini file in a SUBDIRECTORY of D:\documents.

Here are a couple of things to try:
  • 1. Exit SC and restart it, to eliminate the possibility of it being confused by starting up right when windows boots.
  • 2. Exit SC and see if you can find where IT is saving the ScreenshotCaptor.ini file.   Maybe delete (move) the one you manually put someplace, and find the one IT creates.  Then you will know where it thinks it should be saving it.
  • 3. That should confirm for you whether it is seeing your ConfigDir.ini file at least.  Look in the parent directory of the Screenshots folder.
  • 4. Confirm whether it is "forgetting settings" even when you exit and restart it -- or if this is only happening on reboot.

kmatzdorf

  • Supporting Member
  • Joined in 2017
  • **
  • Posts: 16
    • View Profile
    • Donate to Member
Re: Forgets Settings on Boot
« Reply #2 on: May 08, 2017, 12:07 PM »
I have noticed that if screenshot captor does not exit cleanly (like when it was hanging earlier after too many automatic captures), that it did not save the settings.  The saving of settings maybe only happens on exit?

So if your reboot/restart isn't shutting down screenshot captor first, and you hadn't previously exited cleanly after changing settings, that might be what is going on.