Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • August 19, 2017, 03:49 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Code Highlighting Tags Broken  (Read 1297 times)

Stoic Joker

  • Honorary Member
  • Joined in 2008
  • **
  • Posts: 6,352
    • View Profile
    • Donate to Member
Code Highlighting Tags Broken
« on: October 01, 2016, 08:25 AM »
IIRC there is a proper form to report board issues in...but damn if I can find it at the moment ... So I'll just drop this here.

I've been trying to send (PM) some C++ code to a guy since Friday, but every time I use the code highlighting tags (to preserve the formatting) the page blows up saying it can't be loaded.

Is it really just my day (/week...) in the barrel, or is the board glitching on the code tags?

wraith808

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 8,874
    • View Profile
    • Donate to Member
Re: Code Highlighting Tags Broken
« Reply #1 on: October 01, 2016, 11:38 AM »
Is it only in PMs?  Or does the same thing happen inline in posts?

And the official section is here: http://www.donationc...index.php?board=21.0

But I guess mouser will move it if it is a big deal...

Renegade

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 13,237
    • View Profile
    • Donate to Member
Re: Code Highlighting Tags Broken
« Reply #2 on: October 01, 2016, 10:02 PM »
You could use Pastebin if needed.

4wd

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 4,603
    • View Profile
    • Donate to Member
Re: Code Highlighting Tags Broken
« Reply #3 on: October 02, 2016, 09:28 PM »
Is it only in PMs?  Or does the same thing happen inline in posts?

I can't do any code highlighting at all in the forum unless I type in the tag and style.  Used to be able to select text and then select the Code Highlighting and it would do it.

Tried Edge, Firefox, and Chromodo, same thing in all of them.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 37,320
    • View Profile
    • Donate to Member
Re: Code Highlighting Tags Broken
« Reply #4 on: October 02, 2016, 09:35 PM »
Quote
I can't do any code highlighting at all in the forum unless I type in the tag and style. Used to be able to select text and then select the Code Highlighting and it would do it.

ah you're right.. well that's been broken for a year then.. i will fix.


4wd

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 4,603
    • View Profile
    • Donate to Member
Re: Code Highlighting Tags Broken
« Reply #5 on: October 02, 2016, 09:45 PM »
Quote
I can't do any code highlighting at all in the forum unless I type in the tag and style. Used to be able to select text and then select the Code Highlighting and it would do it.

ah you're right.. well that's been broken for a year then.. i will fix.

Not so, it was working on September 5th in my post here

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 37,320
    • View Profile
    • Donate to Member
Re: Code Highlighting Tags Broken
« Reply #6 on: October 02, 2016, 11:01 PM »
ah well that's weird i must have broken it on the recent update then..

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 37,320
    • View Profile
    • Donate to Member
Re: Code Highlighting Tags Broken
« Reply #7 on: October 02, 2016, 11:13 PM »
Should be fixed now (you may have to reload a page to get it to grab the new js file).  Somehow i deleted a bit of the editor javascript on the last update.