Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 11, 2016, 05:50:32 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: SSC 4.30 portable Preferences UI locking up_viewing or making changes  (Read 1841 times)

cathie28

  • Participant
  • Joined in 2011
  • *
  • default avatar
  • Posts: 84
    • View Profile
    • Donate to Member
Using v4.30 portable in Vista x64, 7 GB free RAM, plenty of free disk space.
Noticed after I got the Windows error message (may be coincidence) mentioned in other thread,
Quote
---------------------------
Access violation at address 008713AE in module 'ScreenshotCaptor.exe'. Read of address 059F1780.
---------------------------
OK
 
that the prefs UI would open OK, allow me to browse it, but then wouldn't close.  If I just finished browsing & hit cancel or made changes, & clicked Apply, took ~ 1 min to accept them & change the button color.  Though, doesn't seem it ever grayed out the Accept button, once change were made & accepted.

During the wait time, only indication it was working (I assume it was), is a 1/10 sec. flash, very near cursor that was hovered over the prefs UI.  Too fast to tell what the image was.  Eventually, it finished.
Once when I hit Cancel in the prefs UI, it took so long, just shut down SSC.
All this has happened several times in one day.  Nothing unusual going on in task manager & no msgs in Event Viewer.
 

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
is it possible that SC cannot save in the directory where you are running it from?
or where your configdir.ini is telling it to save?

cathie28

  • Participant
  • Joined in 2011
  • *
  • default avatar
  • Posts: 84
    • View Profile
    • Donate to Member
If you mean configdir_default.ini...
then this is what is in that file:
Quote
PORTABLE=TRUE
CONFIGDIR = .
// CONFIGDIR = %MYDOCUMENTS%
Course, last line is a comment.  But, the locations of configdir is blank.  I assume because it's portable.  But that's also how previous versions of configdir_default.ini looked. 

That file is located in the root folder of the prgm files.
There's also a ScreenshotCaptor.ini & a ScreenshotCaptor.ini.new - both in the root folder of the program files.  The changes I've made look like they're being stored in both.
No, there's no problem w/ SSC writing to that partition.   

Do you need to manually edit the config file to tell it where to save custom settings, even though the file is already in the root folder?

I'd have assumed (like most portables), it either saves the config file to the same folder / drive, etc., that the prgm files are on,  as it appears to be doing here.  I've never had to manually enter where to save config settings in a portable app - unless I wanted to change it from default location.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
yeah that looks fine.  it should (and from your description looks like it does) obey configdir_default.ini.

but it sure sounds like something is going wrong when its saving its settings..

i suppose i could send you a special debug version of the program to help us identify where things are going wrong..

cathie28

  • Participant
  • Joined in 2011
  • *
  • default avatar
  • Posts: 84
    • View Profile
    • Donate to Member
Alright.  How do you want to get it to me?  I'm assuming it's not that big, so you could send it to my registered email address - if you're able to see it.

Preference screens continue to be very slow to respond - like running out of RAM (not the case)  or serious cypherin' problems.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
We'll talk over email and I'll send you a debug version, and then post a report here when we solve it.

cathie28

  • Participant
  • Joined in 2011
  • *
  • default avatar
  • Posts: 84
    • View Profile
    • Donate to Member
After initial problems w/ the edit preferences process being very slow to apply / accept changes, then close the UI, I couldn't repeat the problem the next day or since.  Either another app (perhaps another screen shot capture prgm) was conflicting or Windows - Vista - just needed rebooting. 

Since I'm using portable version, don't understand why Windows would need rebooting (if that was a factor), but ....  SSC prefs changes seem to work fine & quickly now.  Was no reason to run the debugging version, since it wasn't repeating the problem.