Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • October 24, 2016, 09:23:05 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: UTF-8 bug?  (Read 1156 times)


  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 48
    • View Profile
    • JobMob
    • Read more about this member.
    • Donate to Member
UTF-8 bug?
« on: April 08, 2013, 10:05:07 AM »
I'm using v2.17.01 on Win8 64-bit.

Here's how to reproduce the bug:

  • With CP+H enabled, copy this Hebrew text: מסלול סיוע לקידום חברות מתחילות
  • Now paste that same text, but do it by selecting it from the CP+H popup, and this is what you get: îñìåì ñéåò ì÷éãåí çáøåú îúçéìåú

It's worth noting that if I open the Main Window and scroll through the excerpts, there the copied text is rendered correctly in Hebrew.


  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Posts: 9,027
  • [Well, THAT escalated quickly!]
    • View Profile
    • f0dder's place
    • Read more about this member.
    • Donate to Member
Re: UTF-8 bug?
« Reply #1 on: April 08, 2013, 10:37:58 AM »
Does CHS support Unicode characters at all?

(most of? all of?) mouser's stuff is written in Borland C++ Builder, which didn't use to have Unicode support. A few quick searches on the board doesn't seem to indicate that mouser has switched to a version with Unicode support (...which would probably mean a fair amount of source code changes as well).
- carpe noctem