Website Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • August 30, 2015, 03:03:27 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Icon not displayed in standard warning popup window (Win7x64)  (Read 2107 times)

MerleOne

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 941
  • 4D thinking
    • View Profile
    • Donate to Member
Icon not displayed in standard warning popup window (Win7x64)
« on: January 20, 2012, 09:59:28 AM »
Hi,
I am having this issue with a recent Win7x64 machine : I have created on the Desktop a folder that contains shortcuts of installed applications, instead of having them all around the desktop.  When I installed CCleaner for the first time, I moved its launch icon to this folder by drag and drop.  

When I install a new version, the launch icon being re-created. The actual issue occurs when I move this recreated icon into the folder : Windows warns me that CCleaner.lnk already exists there and asks me if I want to overwrite it, keep the old version or keep both. *BUT* the ccleaner icon is missing from this popup warning window.  And this occurs also for all  other links in a similar situation, when the link already exists in the folder, it's not CCleaner specific.

I have tried many times to re-generate the icon user database, to no avail.  Here it is how it works on a normal system :

IconOK.jpgIcon not displayed in standard warning popup window (Win7x64)

Here the CCleaner icons are perfectly displayed (XP here).  Not on my Win7 system.  I tried to look on Microsoft online help, but with little results.

Thanks for any hint on how to solve this !
.merle1.

Ath

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 2,532
    • View Profile
    • Donate to Member
Re: Icon not displayed in standard warning popup window (Win7x64)
« Reply #1 on: January 20, 2012, 11:37:20 AM »
Replayed that scenario, my reasonably normal Windows 7 x64 displays this:
Screenshot - 20-01-2012 , 18_36_29.pngIcon not displayed in standard warning popup window (Win7x64)

Innuendo

  • Charter Member
  • Joined in 2005
  • ***
  • gravatar avatar
  • Posts: 2,182
    • View Profile
    • Donate to Member
Re: Icon not displayed in standard warning popup window (Win7x64)
« Reply #2 on: January 20, 2012, 01:05:35 PM »
Oh, this is exciting....I just tried it as well. My first attempt was to just copy a shortcut on my desktop twice into a randomly created folder. My result was the *opposite* of Ath's screenshot above (the icon was present next to Copy and Replace with no icon next to Don't Copy).

My second attempt was copying a shortcut from the Start Menu into that folder twice. The result of that experiment was that there wasn't an icon next to either Copy and Replace *or* Don't Copy! Three cheers for consistency, eh?  ;D

And now there's one more reason on my list why I don't and won't use Windows Explorer for file management.

J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,905
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Icon not displayed in standard warning popup window (Win7x64)
« Reply #3 on: January 20, 2012, 01:30:58 PM »
And I tried it and got no icons in that same dialog:

[attachthumb=#1][/attachthumb]

Jim

MerleOne

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 941
  • 4D thinking
    • View Profile
    • Donate to Member
Re: Icon not displayed in standard warning popup window (Win7x64)
« Reply #4 on: January 20, 2012, 05:08:36 PM »
Thanks for trying on your system.  This is exactly what I get.  Sometimes, it does work though, usually just after a fresh boot and I get both icons to be displayed.  

Afterwards, when I open the folder and drag & drop an existing icon into the open folder, I get the 2nd icon ok most of the time

Clipboard01.jpgIcon not displayed in standard warning popup window (Win7x64)

I have an AMD Radeon HD 6950 as graphics card.  Is yours also an ATI by chance ?
.merle1.

J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,905
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Icon not displayed in standard warning popup window (Win7x64)
« Reply #5 on: January 20, 2012, 09:12:13 PM »
Not here. I'm running a new Windows 7 Pro64-bit  with a GeForce GTX 570 (1280MB) graphics card.

Jim

MerleOne

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 941
  • 4D thinking
    • View Profile
    • Donate to Member
Re: Icon not displayed in standard warning popup window (Win7x64)
« Reply #6 on: January 21, 2012, 06:37:09 AM »
Not here. I'm running a new Windows 7 Pro64-bit  with a GeForce GTX 570 (1280MB) graphics card.

Jim

Then I guess it's another of those Win7x64 "features".... ;)
.merle1.

4wd

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 3,962
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Icon not displayed in standard warning popup window (Win7x64)
« Reply #7 on: January 22, 2012, 08:03:51 AM »
This is probably the same sort of bug as the disappearing tray icons.

That can be fixed, (albeit temporarily), by restarting explorer.exe - have tried that?

MerleOne

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 941
  • 4D thinking
    • View Profile
    • Donate to Member
Re: Icon not displayed in standard warning popup window (Win7x64)
« Reply #8 on: January 24, 2012, 01:23:01 AM »
Thanks. I am not sure on how to restart Explorer.exe and it reverts to this behavior after a short while anyway.  Since it's a non blocking issue, I can wait some more time for Microsoft to solve it (in Win7, not Win8 !).  But now the question would be : is Microsoft aware of this issue and how to report it to them ? 
.merle1.

4wd

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 3,962
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Icon not displayed in standard warning popup window (Win7x64)
« Reply #9 on: January 24, 2012, 03:03:10 AM »
Thanks. I am not sure on how to restart Explorer.exe .....

Run Task Manager, click the Processes tab, right-click the explorer.exe task and select End Process and hit OK.
Select File->New Task (Run...).
Type in explorer.exe and hit OK.

Quote
I can wait some more time for Microsoft to solve it (in Win7, not Win8 !).

The disappearing Tray icons "feature" has been there an awful long time, (since XP).....how long do you want to wait?

J-Mac

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 2,905
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Icon not displayed in standard warning popup window (Win7x64)
« Reply #10 on: January 24, 2012, 04:06:35 AM »
Besides just quitting and restarting explorer.exe you need to delete items under the following registry key:

HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify

The two items are IconStreams and PastIconStreams.

After deleting both of those items, then quit explorer.exe and restart it.

As always you should first export both of the above items - or the key "TrayNotify" itself, just in case. Though I have been using this fix for a couple years without a problem. Supposedly for Vista but works in Windows 7 for me.

Here's a reference link, and if you search you can find more of the same:

http://www.howtogeek.com/howto/windows-vista/clean-up-past-notification-icons-in-windows-vista

Thanks!

Jim