Welcome Guest.   Make a donation to an author on the site September 01, 2014, 06:29:46 PM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
Free DonationCoder.com Member Kit: Submit Request.
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: It is impossible to remove the network connection icon from the system tray.  (Read 6184 times)
superboyac
Charter Member
***
Posts: 5,663


Is your software in my list?

see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« on: August 20, 2010, 04:01:57 PM »

I know I've been ranting and raving lately, but here's another one.

There is NO way to completely remove the network connection icons in the system tray of XP.  You know the one, the little computer with the red "X" (when it's not connected).  For some reason, it is impossible to remove this thing without some pretty decent computer hacking.  At least, I haven't heard about a way so far.  The only way to really remove it is to actually disable that network adapter in the devices menu.  But that's not good.  I want the device enabled, I just want the icon to never be in the tray...ever.

What's even more confusing and frustrating is that if you go to the connection properties, there's the somewhat deceptive settings about this whole thing (see the last two checkboxes):


But that doesn't really work.  The icon will still show up in various situations.  I've read about it online, how it will never really go away even if you uncheck those options.

So, why?  Why is this such an impossible issue?  What's wrong with these companies?  When did we stop paying attention to the little things that matter, and only focus on the shiny, largely useless features?
Logged

Deozaan
Charter Member
***
Posts: 6,329



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #1 on: August 20, 2010, 04:12:41 PM »

The only way I could ever get the LAN network icon to go away was to disable the network adapter, as you said. That works fine if you are using WiFi, but you'll still have the WiFi network icon displayed there.

Those two checkboxes should make it go away, and sometimes in XP I was able to get it to go away temporarily. But it would always come back again after a reboot or who-knows-what.

Windows 7 at least allows you to hide them. Thmbsup
Logged

superboyac
Charter Member
***
Posts: 5,663


Is your software in my list?

see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #2 on: August 20, 2010, 04:15:13 PM »

Windows 7 at least allows you to hide them. :Thmbsup
At least they fixed it.  That's good.

Yeah, this issue is normally seen on laptops.  most laptops will connect using the wifi, which is fine.  but they also have an ethernet jack with its own adapter.  When it's not connected, the icon will ALWAYS show up, no matter if the checkboxes are unchecked or not.  That's the lame part.  Most desktops that are hard-wired will not see this problem.
Logged

lanux128
Global Moderator
*****
Posts: 6,088



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #3 on: August 20, 2010, 04:44:26 PM »

you can use a tray manager like PSTray to hide them..
Logged

superboyac
Charter Member
***
Posts: 5,663


Is your software in my list?

see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #4 on: August 20, 2010, 04:50:15 PM »

you can use a tray manager like PSTray to hide them..
yes, I do use ps tray.  I guess i don't have it on my laptop.  Sometimes, though, with the network connections, ps tray doesn't always recognize the setting.  Even though you've set it to hide, it will show up again upon rebooting.  Actually, I don't remember if that was the network connection icons or some other weird program that was giving me that problem.  It usually happens with icons where the status name changes, and that confuses ps tray, and it shows up again.
Logged

techidave
Supporting Member
**
Posts: 956


see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #5 on: August 21, 2010, 05:36:05 AM »

You can hide the tray icons in xhttp://www.online-tech-tips.com/computer-tips/how-to-hide-system-tray-icons-in-windows-xp/ also.  I do it all the time.  here are the instructions.
Logged
cyberdiva
Supporting Member
**
Posts: 908


see users location on a map View Profile Give some DonationCredits to this forum member
« Reply #6 on: August 21, 2010, 10:11:55 AM »

You can hide the tray icons in xhttp://www.online-tech-tips.com/computer-tips/how-to-hide-system-tray-icons-in-windows-xp/ also.  I do it all the time.  here are the instructions.
If only it were that simple!  I've tried this any number of times, but each time, the network connection icon returns.  It sometimes takes a day or so, but then it's baaaaaaaaaack!   Angry
Logged
techidave
Supporting Member
**
Posts: 956


see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #7 on: August 21, 2010, 12:09:38 PM »

are you selecting the "hide when inactive" or the "always hide" in the dropdown box? 
Logged
cyberdiva
Supporting Member
**
Posts: 908


see users location on a map View Profile Give some DonationCredits to this forum member
« Reply #8 on: August 21, 2010, 06:04:10 PM »

are you selecting the "hide when inactive" or the "always hide" in the dropdown box?  
I've tried both.  Neither provided a lasting solution, alas.  I've found it does work for some of the other programs, but not the network connection icon.
Logged
sazzen
Supporting Member
**
Posts: 83


View Profile Give some DonationCredits to this forum member
« Reply #9 on: September 28, 2010, 03:57:13 PM »

 Grin It isn't impossible! I know because I don't have a little computer with a red X in my system tray. I'd love to tell y'all how I managed to get rid of it, but I haven't the foggiest. With the vast extent of my computer knowledge, I probably right-clicked on it and chose "Disappear".
Logged
Deozaan
Charter Member
***
Posts: 6,329



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #10 on: October 01, 2010, 09:08:19 PM »

Grin It isn't impossible! I know because I don't have a little computer with a red X in my system tray. I'd love to tell y'all how I managed to get rid of it, but I haven't the foggiest. With the vast extent of my computer knowledge, I probably right-clicked on it and chose "Disappear".

You probably disabled the device, which does indeed make it disappear, but superboyac said he didn't want to go that route.
Logged

Babis
Charter Member
***
Posts: 84

View Profile Give some DonationCredits to this forum member
« Reply #11 on: October 06, 2010, 12:38:05 AM »

I have a similar problem: Animate windows when minimizing and maximizing keeps reseting to default (enabled) even though I uncheck the checkbox daily. I searched the web and many others have the same problem with no apparent solution. 
Logged
Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.037s | Server load: 0.19 ]