Welcome Guest.   Make a donation to an author on the site April 24, 2014, 06:52:26 PM  *

Please login or register.
Or did you miss your validation email?


Login with username and password (forgot your password?)
Why not become a lifetime supporting member of the site with a one-time donation of any amount? Your donation entitles you to a ton of additional benefits, including access to exclusive discounts and downloads, the ability to enter monthly free software drawings, and a single non-expiring license key for all of our programs.


You must sign up here before you can post and access some areas of the site. Registration is totally free and confidential.
 
The N.A.N.Y. Challenge 2014! Download dozens of custom programs!
   
   Forum Home   Thread Marks Chat! Downloads Search Login Register  
Pages: [1]   Go Down
  Reply  |  New Topic  |  Print  
Author Topic: character encoding keeps changing to Cyrillic in WinXP  (Read 2622 times)
lanux128
Global Moderator
*****
Posts: 6,049



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« on: May 04, 2009, 11:07:23 PM »

i noticed recently that i can't type certain characters without them being turned into Russian chars. i checked the regional settings then i looked at the character encoding on my browser and email programs and also my office programs but they all show as 'English - United States' or its equivalent (Western ISO 8859).

later while fiddling with the font settings, i found out that all the fonts' script has been changed to 'Cyrillic' instead of 'Western' (see pic). changing them back is now an issue because once i closed the dialog, it's reverted to Cyrillic encoding. so can someone help me with this problem?

Logged

muntealb
Member
**
Posts: 90

View Profile Give some DonationCredits to this forum member
« Reply #1 on: May 05, 2009, 10:44:09 AM »

Did you also check the language options ?

Regional and Language Options>Languages>Text Services>Details>Default input language

Regional and Language Options>Advanced>Language for non-Unicode programs
Logged
lanux128
Global Moderator
*****
Posts: 6,049



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #2 on: May 05, 2009, 08:35:13 PM »

yes i did but i couldn't find the 2nd item: "Language for non-Unicode programs". here are the screenshots from PC.




Logged

fenixproductions
Honorary Member
**
Posts: 1,168



see users location on a map View Profile WWW Give some DonationCredits to this forum member
« Reply #3 on: May 05, 2009, 09:48:48 PM »

Just guessing...

1. Try to delete fonts cache file (C:\WINDOWS\system32\FNTCACHE.DAT) and restart your PC.

2. remove all non-english localisation settings (like Cyrillic support) and install again after restart,

3. export two registry keys and compare them with ones from correctly working Windows:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Font

4. there is possibility that system fonts (System, Fixedsys, Small Fonts, MS Serif, MS Sans Serif, Courier, Arial CE, Courier New CE, Times New Roman CE, Helv, Tms Rmn) are corrupted, so you can always take them from other PC and install again,
Logged

Надо было учиться, а не камни в школу бросать...
--
f0dder is my personal hero smiley
lanux128
Global Moderator
*****
Posts: 6,049



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #4 on: May 05, 2009, 10:31:53 PM »

thanks fenix, will try out the suggestions..
Logged

muntealb
Member
**
Posts: 90

View Profile Give some DonationCredits to this forum member
« Reply #5 on: May 05, 2009, 11:55:02 PM »

yes i did but i couldn't find the 2nd item: "Language for non-Unicode programs". here are the screenshots from PC.
 

It's easy to find it. There are 3 tabs in the main window (Regional and Language Options) :

Regional Options
Languages
Advanced

The setting for non-Unicode programs is in the Advanced tab.

Logged
lanux128
Global Moderator
*****
Posts: 6,049



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #6 on: May 06, 2009, 12:20:03 AM »

It's easy to find it. There are 3 tabs in the main window (Regional and Language Options) :

Regional Options
Languages
Advanced

The setting for non-Unicode programs is in the Advanced tab.

thanks i found it but the setting is the same as yours..
Logged

lanux128
Global Moderator
*****
Posts: 6,049



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #7 on: May 06, 2009, 12:24:25 AM »

Just guessing...

1. Try to delete fonts cache file (C:\WINDOWS\system32\FNTCACHE.DAT) and restart your PC.

no, it didn't work..


2. remove all non-english localisation settings (like Cyrillic support) and install again after restart,

i don't how to do this.. Sad


3. export two registry keys and compare them with ones from correctly working Windows:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Font

i compared with another PC and they were almost the same except for some app-installed fonts.


4. there is possibility that system fonts (System, Fixedsys, Small Fonts, MS Serif, MS Sans Serif, Courier, Arial CE, Courier New CE, Times New Roman CE, Helv, Tms Rmn) are corrupted, so you can always take them from other PC and install again,

haven't got down to this yet, maybe i should have the repair CD on the standby..
Logged

lanux128
Global Moderator
*****
Posts: 6,049



see users location on a map View Profile WWW Read user's biography. Give some DonationCredits to this forum member
« Reply #8 on: May 08, 2009, 01:26:18 AM »

4. there is possibility that system fonts (System, Fixedsys, Small Fonts, MS Serif, MS Sans Serif, Courier, Arial CE, Courier New CE, Times New Roman CE, Helv, Tms Rmn) are corrupted, so you can always take them from other PC and install again,

haven't got down to this yet, maybe i should have the repair CD on the standby..

ok, i've also done this. i extracted the system fonts from the WinXP CD and installed them again but no avail. i did a full-system scan for malware but again came to nought. i'd been thinking of reinstalling windows if there can't be any other solution. Sad
Logged

Pages: [1]   Go Up
  Reply  |  New Topic  |  Print  
 
Jump to:  
   Forum Home   Thread Marks Chat! Downloads Search Login Register  

DonationCoder.com | About Us
DonationCoder.com Forum | Powered by SMF
[ Page time: 0.031s | Server load: 0.09 ]