Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 10, 2016, 08:13:36 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: "Do not show icon in system tray when minimized" not work?  (Read 2811 times)

wudile

  • Participant
  • Joined in 2008
  • *
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
"Do not show icon in system tray when minimized" not work?
« on: March 02, 2009, 08:56:31 PM »
I ticked "Do not show icon in system tray when minimized", but after I pressed ESC to close FRR, the icon is still in system tray. Is there any other thing I need to set?

wudile

  • Participant
  • Joined in 2008
  • *
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Re: "Do not show icon in system tray when minimized" not work?
« Reply #1 on: March 02, 2009, 11:00:42 PM »
I just found that if I opened Options dialogue from sys tray, then close it, the sys tray icon will disapear. But when I open FRR again by hotkey, the sys tray icon will appear again.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: "Do not show icon in system tray when minimized" not work?
« Reply #2 on: March 02, 2009, 11:11:19 PM »
ok im going to look into it

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,435
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: "Do not show icon in system tray when minimized" not work?
« Reply #3 on: March 04, 2009, 05:18:52 AM »
ok i see the problem.. if you have the Memory Use set to default value (Average) they icon does not hide.  Setting it to "Stay in Memory Longer" (as i keep mine) causes the hide functionality to work.

you can change that setting if you want to confirm my findings..

i've fixed the problem and posted a silent update, so if you redownload or run updater and force it to redownload, you should have the fix.
Going to try to correct one more bug (hidden system tray icon) before i publish the new version.
« Last Edit: March 04, 2009, 05:24:14 AM by mouser »

wudile

  • Participant
  • Joined in 2008
  • *
  • default avatar
  • Posts: 5
    • View Profile
    • Donate to Member
Re: "Do not show icon in system tray when minimized" not work?
« Reply #4 on: March 04, 2009, 06:13:10 AM »
thanks, it works now.

BTW, it seems that "stay in mem longer" is recommended, but not default option for new install.