Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 07, 2016, 02:41:17 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: [XCHAT] Can't receive messages containing umlauts or special character  (Read 7542 times)

bamboo123

  • Participant
  • Joined in 2009
  • *
  • Posts: 9
    • View Profile
    • Donate to Member
Hello ppl,

I found some issue with latest official version (v1.19.01) as well as with the pre release version (v0.4.0-alpha) from gjehle. Both version do not print/receive messages containing umlauts or special characters like äöüßéá etc (tested with xchat 2.8.6 on an ubuntu 8.10 32bit system).

PS: Other users receive my (send) messages containing umlauts without problems, as well as i see them on my screen. the problem is only with receiving such messages.
PSS: I forgot to mention, that i use "ISO-8859-15 (Western Europe)" as character set in xchat.
« Last Edit: February 25, 2009, 07:50:52 PM by bamboo123 »

gjehle

  • Member
  • Joined in 2006
  • **
  • Posts: 286
  • lonesome linux warrior
    • View Profile
    • Open Source Corner
    • Read more about this member.
    • Donate to Member
Re: [XCHAT] Can't receive messages containing umlauts or special character
« Reply #1 on: February 26, 2009, 07:12:52 AM »
Hi Bamboo,

thanks for reporting this (also thanks for the mail you sent pointing me here).
This problem never occurred to me (I'm usually using UTF-8) but I'll look into it as soon as I find some spare time, hopefully next weekend, but no promises :x

Can you give me some background?
Are you on Windows or Linux and which version is it?
What version of XChat are you running?
Did you compile it yourself or are you running a binary version?

bamboo123

  • Participant
  • Joined in 2009
  • *
  • Posts: 9
    • View Profile
    • Donate to Member
Re: [XCHAT] Can't receive messages containing umlauts or special character
« Reply #2 on: February 26, 2009, 07:33:24 AM »
(...) (tested with xchat 2.8.6 on an ubuntu 8.10 32bit system).
The xchat version is a pre compiled package from the ubuntu (linux) backports (Version: 2.8.6-2ubuntu1).

gjehle

  • Member
  • Joined in 2006
  • **
  • Posts: 286
  • lonesome linux warrior
    • View Profile
    • Open Source Corner
    • Read more about this member.
    • Donate to Member
Re: [XCHAT] Can't receive messages containing umlauts or special character
« Reply #3 on: February 26, 2009, 07:36:54 AM »
(...) (tested with xchat 2.8.6 on an ubuntu 8.10 32bit system).
The xchat version is a pre compiled package from the ubuntu (linux) backports (Version: 2.8.6-2ubuntu1).

gee, stupid me.
I should open my eyes a bit more ;-)

bamboo123

  • Participant
  • Joined in 2009
  • *
  • Posts: 9
    • View Profile
    • Donate to Member
Re: [XCHAT] Can't receive messages containing umlauts or special character
« Reply #4 on: February 27, 2009, 01:17:03 AM »
I also noticed, that it's impossible to set a crypted Topic, when the channel name contains a special char on iso-15: #abendeßen :No such channel.

EDIT: I tried some things and found out, that the error only occurs, when the channel name contains special characters. On querries and normal channels messages containing special characters work fine. Hope that helps to fix the bug.
« Last Edit: February 27, 2009, 05:59:15 AM by bamboo123 »

housetier

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • default avatar
  • Posts: 1,321
    • View Profile
    • Donate to Member
Re: [XCHAT] Can't receive messages containing umlauts or special character
« Reply #5 on: February 27, 2009, 09:29:28 PM »
well it's spelled "Abendessen" anyway ;)

there is no ß after a short vowel: "Straße" (long a) but "Stress" (short "e")

Anyway thank you for taking your time to report this issue  :up:

gjehle

  • Member
  • Joined in 2006
  • **
  • Posts: 286
  • lonesome linux warrior
    • View Profile
    • Open Source Corner
    • Read more about this member.
    • Donate to Member
okay, this might tie into the issues with UTF we had before and it's (afaik) not an issue with mircryption per se.
we already have a workaround for utf8 in the code for the xchat plugin.
it looks like someone is sending you UTF8 data while you don't expect it (using ISO charset).
to be honest, i don't see any simple way to fix this right now.
my tip: try using UTF8 and educate others to do the same

bamboo123

  • Participant
  • Joined in 2009
  • *
  • Posts: 9
    • View Profile
    • Donate to Member
a shame, others are to lazy to switch to utf8... i fixed the problem, by removing the special characters from the channel name (aka changed the channel name.).

bamboo123

  • Participant
  • Joined in 2009
  • *
  • Posts: 9
    • View Profile
    • Donate to Member
Re: [XCHAT] Can't receive messages containing umlauts or special character
« Reply #8 on: September 21, 2009, 03:40:38 PM »
Hi, yet another problem with umlauts: mircryption for xchat doesnt decode messages right, which got crypted with a key beginning with an umlaut (eg ü). The messages received are decrypted like the key way set wrong.