Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 03, 2016, 12:58:01 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Please fix this  (Read 3404 times)

flyingpants

  • Participant
  • Joined in 2009
  • *
  • default avatar
  • Posts: 1
    • View Profile
    • Donate to Member
Please fix this
« on: January 12, 2009, 12:59:09 PM »
I use alt+F4 to close windows. Sometimes it doesn't do anything in FARR. Sometimes it works but then launches item #4 in the list.
I also have to hit escape various amounts of times (up to 3 times) to get it to work depending on where it is in the program.

tab and shift-tab don't work properly either.

8)

wreckedcarzz

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 1,623
    • View Profile
    • Donate to Member
Re: Please fix this
« Reply #1 on: January 12, 2009, 05:14:10 PM »
 :o Same problem here, just launched FARR via PB (Pause Break) and hit Alt F4, and Trackmania launched! :huh:

Mouser... we have issues! Please fix! :P

d4ni

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 129
    • View Profile
    • Donate to Member
Re: Please fix this
« Reply #2 on: January 12, 2009, 07:12:37 PM »
Launches the 4th result (if present, otherwise does nothing) for me.

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Please fix this
« Reply #3 on: January 12, 2009, 07:29:13 PM »
the reason might be the settings as seen in the screenshot.

ws-Farr-keyboard.png

wreckedcarzz

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 1,623
    • View Profile
    • Donate to Member
Re: Please fix this
« Reply #4 on: January 12, 2009, 09:11:00 PM »
But that should be Alt+4 not Alt+F4... :P

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: Please fix this
« Reply #5 on: January 12, 2009, 09:53:37 PM »
But that should be Alt+4 not Alt+F4... :P

as it happens to be, the function key is involved in launching items. anyway to close Farr, you can either press Esc or Pause key.

ws-Farr-keyboard-1.png
http://www.donationc...shortcut_summary.htm

wreckedcarzz

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 1,623
    • View Profile
    • Donate to Member
Re: Please fix this
« Reply #6 on: January 13, 2009, 12:54:46 AM »
Hmm... kind of strange and logical at the same time I guess. Just kind of unusual to override a Windows hotkey, I suppose.

Last second thought: You can also double click the top left of FARR (where the icon would be) to close it as well. That might work better if your hand is on the mouse and it is faster... depends on the situation I guess. Figured I would point out that it works even with the skinning system, though.

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,405
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Please fix this
« Reply #7 on: January 13, 2009, 06:17:55 AM »
i suppose i should make it an option whether to use alt+Fkeys

d4ni

  • Supporting Member
  • Joined in 2008
  • **
  • Posts: 129
    • View Profile
    • Donate to Member
Re: Please fix this
« Reply #8 on: January 13, 2009, 07:28:51 AM »
Wouldn't simply binding ALT + F4 to 'exit farr' fix it? F4 launches 4th result, fine. But when it's pressed with Alt simultaneously it should register it appropriately. Perhaps because no action is bound to ALT + F4 it registers it as just F4?

Bottom line; Alt + F4 != F4.