Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 10, 2016, 10:41:51 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: XULRunner question  (Read 5056 times)

jpprater

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 90
    • View Profile
    • Donate to Member
XULRunner question
« on: November 04, 2008, 01:31:04 PM »
After looking at the link I saw on XULRunner in the last newsletter, I decided to try it out and see what it was about.  I'm having issues running anything with it.  If I download an XULRunner package (.xulapp or .xpi extension), XULRunner should start that package with XULRunner.exe <packagename>.  All I ever get running this is "Error:  App:Name not specified in application.ini".  If I unzip the xulapp or xpi file (change the extension to .zip and extract) and then look in the application.ini file, I can see Name= defined under the [App] section.  If I then run XULRunner.exe application.ini, it works perfectly.  Any thoughts as to why XULRunner won't take a .xulapp or .xpi file? :(

Ehtyar

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,237
    • View Profile
    • Donate to Member
Re: XULRunner question
« Reply #1 on: November 04, 2008, 01:51:20 PM »
That is the correct behavior, as any introductory tutorial/documentation would tell you. XPIs should be installed via 'xulrunner.exe --install-app drive:\path\to\package.xpi drive:\path\to\install\to', then xulrunner should be invoked on the resulting application.ini.

Ehtyar.

jpprater

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 90
    • View Profile
    • Donate to Member
Re: XULRunner question
« Reply #2 on: November 04, 2008, 02:00:16 PM »
That is the correct behavior, as any introductory tutorial/documentation would tell you. XPIs should be installed via 'xulrunner.exe --install-app drive:\path\to\package.xpi drive:\path\to\install\to', then xulrunner should be invoked on the resulting application.ini.

Ehtyar.
Erm, actually, there aren't any tutorials that say a word about this.  I tried running XULRunner --install-app, but didn't see anything special about doing that (since I had already unzipped the file manually).  Thank you for your help.