Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 09, 2016, 11:16:43 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: I am stumped ...  (Read 6603 times)

techidave

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,012
    • View Profile
    • Donate to Member
I am stumped ...
« on: August 12, 2008, 07:03:15 PM »
We have a few old die hards who do not want to trade in their Works 4.5 for Word 2003.  The problem which just started is when you create a new works document and save it as a .wps then when windows creates an icon it places the Word icon beside it.  The file association was set to word but I changed it to Works but it still has the word icon on it. 

I have looked for some kind of preference file in Works but have not been able to find it.

Perhaps someone out here has run into this problem before.

thanks in advance,
Dave

Dirhael

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 383
    • View Profile
    • defreitas.no
    • Donate to Member
Re: I am stumped ...
« Reply #1 on: August 12, 2008, 07:31:08 PM »
You probably just have to rebuild your icon cache. The easiest way to do this would probably be to just use the Tweak UI powertoy for XP. Alternatively, kill explorer, delete %localappdata%\IconCache.db & reboot (not always required but it's probably a good idea anyway).
Registered nurse by day, hobby programmer by night.

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,092
    • View Profile
    • Donate to Member
Re: I am stumped ...
« Reply #2 on: August 12, 2008, 07:47:06 PM »
Replace jpg with wps:

Quote from: windowsxp.mvps
Change the default icon shown for JPG files

After changing the file association for JPG files in the Folder Options - File Types dialog, Windows Explorer may still show the Windows Picture and Fax Viewer icon for JPG files, rather than the corresponding application's icon. To avoid this, first change the default icon for JPG files via File Types dialog Advanced button, and then associate the files to your preferred program.

In case the Advanced button is missing, click the Restore button. This will associate the image back with Windows Picture and Fax Viewer, and the Advanced button would be available now. Now, click Advanced and change the icon for the file-type to your preference. Once done, reset the file-association back to your application.

Another option is to set the defaulticon string by editing the registry directly. Open REGEDIT and navigate to:

[HKEY CLASSES ROOT\jpegfile\DefaultIcon]

Backup the key to a file, as explained here

Example: Set the (default) value to:

C:\Program Files\Internet Explorer\IEXPLORE.EXE,8

Restart Windows. If the changes are not reflected in the folder, rebuild the icons using these steps:

    * Right-click Desktop, choose Properties
    * Click the Appearance Tab
    * Click Advanced button
    * Choose Icon from the drop-down list
    * Set it's size to 31 and press OK, OK

Repeat the above steps and set the value back to 32 (defaults)
http://windowsxp.mvps.org/jpgicon.htm

techidave

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,012
    • View Profile
    • Donate to Member
Re: I am stumped ...
« Reply #3 on: August 12, 2008, 07:53:46 PM »
its not the jpg that is messed up.  I did d/l tweakui and tried the rebuild icons but it didn't change anything.

Not sure what to try or where to look  :(

Dirhael

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 383
    • View Profile
    • defreitas.no
    • Donate to Member
Re: I am stumped ...
« Reply #4 on: August 12, 2008, 08:03:36 PM »
its not the jpg that is messed up.  I did d/l tweakui and tried the rebuild icons but it didn't change anything.

Not sure what to try or where to look  :(

Did you reboot after rebuilding the cache? If not, it's worth a try. Also, as Curt mentions in his post you could try taking a look here (my screenshot is of the *.doc filetype but the same applies to any other):
Registered nurse by day, hobby programmer by night.

f0dder

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Posts: 9,029
  • [Well, THAT escalated quickly!]
    • View Profile
    • f0dder's place
    • Read more about this member.
    • Donate to Member
Re: I am stumped ...
« Reply #5 on: August 12, 2008, 08:09:00 PM »
When you click a .wks file with word icon, does it load up in word or works?

Iirc, there's filetype associations and then there's filetype associations. I'm pretty sure I've experienced a "new-style" association overrule an "old-style" association. It's been years, so I can't remember the details, but it took some registry futzing to get it right. Your best bet is probably finding some filetype association manager application, I'd be surprised if one didn't exist :)
- carpe noctem

techidave

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,012
    • View Profile
    • Donate to Member
Re: I am stumped ...
« Reply #6 on: August 12, 2008, 08:12:12 PM »
yes I did try a reboot but that didn't help.  I also check the file associations and it was set to a works 4.0 word processor type.  

she does have some word docs (not many) so it would be easier for her to tell the difference by looking at the icon.

techidave

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,012
    • View Profile
    • Donate to Member
Re: I am stumped ...
« Reply #7 on: August 12, 2008, 08:14:39 PM »
when i click a .wks it opens up with works.

lanux128

  • Global Moderator
  • Joined in 2005
  • *****
  • Posts: 6,258
    • View Profile
    • Coding Snacks by Lanux128
    • Read more about this member.
    • Donate to Member
Re: I am stumped ...
« Reply #8 on: August 12, 2008, 08:23:32 PM »
several applications seems to have a preference for the WPS extension. since f0dder has already mentioned about changing within Windows and that didn't work for you (see pic). maybe WAssociate could be of help here.

ws-wps-extension-1_ver001.png

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,425
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: I am stumped ...
« Reply #9 on: August 12, 2008, 08:26:07 PM »
nice screenshots lanux, what incredible screenshot program did you use to make those?

techidave

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,012
    • View Profile
    • Donate to Member
Re: I am stumped ...
« Reply #10 on: August 12, 2008, 09:02:14 PM »
here are some screenshots showing file association for wps.

Darwin

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 6,984
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: I am stumped ...
« Reply #11 on: August 12, 2008, 09:29:44 PM »
nice screenshots lanux, what incredible screenshot program did you use to make those?



Seriously, I thought and wondered exactly the same thing!
"Some people have a way with words, other people,... oh... have not way" - Steve Martin

Darwin

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 6,984
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: I am stumped ...
« Reply #12 on: August 12, 2008, 09:34:10 PM »
techidave - did you try WAssociate? There's also Associate This, which might be worth a try.
"Some people have a way with words, other people,... oh... have not way" - Steve Martin

nosh

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,426
    • View Profile
    • Donate to Member
Re: I am stumped ...
« Reply #13 on: August 12, 2008, 11:07:01 PM »
Here's one more to add to the list.
Clipboard01.jpg

Iconphile review at freewaregenius.

Curt

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 7,092
    • View Profile
    • Donate to Member
Re: I am stumped ...
« Reply #14 on: August 13, 2008, 05:10:04 AM »
its not the jpg that is messed up. 

I am sorry for not making the wording unequivocal.
Please, re-read the article, and read every "jpg" as if it said "wps".

techidave

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 1,012
    • View Profile
    • Donate to Member
Re: I am stumped ...
« Reply #15 on: August 13, 2008, 09:03:45 AM »
Sorry about that Curt, the very first line too. b :-[

I now have to wait until the end of the day and she is gone before I can try the other suggestins.

Daleus

  • Supporting Member
  • Joined in 2007
  • **
  • Posts: 147
    • View Profile
    • Donate to Member
Re: I am stumped ...
« Reply #16 on: August 13, 2008, 12:07:35 PM »
I'm sure one of the previous suggestions will sort out the problem.  However, I thought I'd add my 2 cents.

I recall years ago, when Works started getting loaded on every computer shipped in NA, that the Works icon was very similar, if not completely identical, to the Word icon.

I recall that I had a very cynical reaction to that, assuming that M$ was hoping to cash in on the incompatibility between Works and M$Office.  You know how it goes, give the free piece of **** and when they find out that it's compatible with bugger all, they'll come running for the full office suite.

You may ultimately have to find a new/create your own icon.  Of course, the best course of action would be to expose your user to the type of derision scorn and brutal demeaning that I have found to be useful, when a user sticks with a piece of software that is limitlessly bad.

;)

Cheers!
Daleus, Curmudgeon-at-Large

cranioscopical

  • Friend of the Site
  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 4,368
    • View Profile
    • Donate to Member
Re: I am stumped ...
« Reply #17 on: August 13, 2008, 09:04:27 PM »
expose your user to the type of derision scorn and brutal demeaning that I have found to be useful, when a user sticks with a piece of software that is limitlessly bad.

;)

So, you don't like Windows?  ;)