Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 06, 2016, 10:11:30 AM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Sleep is killing my mouse  (Read 7899 times)

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,714
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Sleep is killing my mouse
« on: February 21, 2008, 01:49:19 PM »
After mouser posted that entry about putting your computer into sleep mode or hibernation to save power and reduce startup times, I set my PC to do just that.

I set it up to go into sleep mode because in hibernate mode it takes longer to boot up and shut down. Anyway, it's been working great all this time up until yesterday.

Yesterday I woke up my computer and the mouse didn't work. I jiggled the cord and reseated the cables to make sure it was plugged in still. When that didn't work I rebooted. When that didn't work I shut the computer down and reseated the cables again. When that didn't work I removed the USB to PS2 adapter and plugged it directly into the USB port with the PC on. Windows made the little bleepy noise to indicate a USB device had been plugged and in a few seconds the mouse was working again. Problem solved, right?

Wrong!

Now every time I resume from sleep mode I have to unplug my mouse and plug it back into the USB port to get it to work. What can I do to get my mouse back permanently?

It's a Logitech TrackMan Wheel and I've never installed any drivers for it because it doesn't have any special buttons and has always worked just fine without them. I have Windows XP SP2. I have no idea what might have changed to cause this device to stop working.


mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #1 on: February 21, 2008, 02:09:33 PM »
i think i have the answer, and this is a very important trick to know.

There are at least 2 different kinds of Standby modes (S1 and S3) that a PC can go into.  S1 leaves the fans and usb connections on, S3 turns off the fan and usb (this is the quite mode).

If you have a USB hardware device that does not wake up properly from sleep, then your solution might be to go to your bios and force it to use S3 mode instead of S1.

nite_monkey

  • Member
  • Joined in 2006
  • **
  • Posts: 727
    • View Profile
    • Just Plain Super
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #2 on: February 21, 2008, 04:56:38 PM »
it was doing it when he had the mouse plugged into the ps2 port with the usb to ps2 adapter, so I wouldn't think that is the problem either. I would suggest trying to install the drivers, and see if that does anything, because with me, windows likes to corrupt drivers randomly, and I have to update them, so your copy of windows might have corrupted the default drivers for the mouse, I dunno.
[Insert really cool signature here]

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,714
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #3 on: February 22, 2008, 12:31:20 PM »
i think i have the answer, and this is a very important trick to know.

There are at least 2 different kinds of Standby modes (S1 and S3) that a PC can go into.  S1 leaves the fans and usb connections on, S3 turns off the fan and usb (this is the quite mode).

If you have a USB hardware device that does not wake up properly from sleep, then your solution might be to go to your bios and force it to use S3 mode instead of S1.

Okay so my question is why would changing it to S3 help if S3 turns off USB connections?

And by the way, my Sleep mode is quiet. No fans, no nothing. It goes down in a couple of seconds and takes maybe 15-20 seconds to come back up. When I use hibernate, though, it seems like it takes longer to hibernate than to actually shut down.

Am I mistaken in thinking that Sleep is S1 and Hibernate is S3?


mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #4 on: February 22, 2008, 12:33:48 PM »
you are mistaken.

hibernate is complete power off and memory state is saved and restored from disk.

s1 and s3 are both low-power sleep modes which keep the ram active.

what you want to try is the sleep mode that keeps power to the USB devices.

i mispoke before -- you are using currently S3 mode it sounds like.  and you want to try to force it to use S1.

Lashiec

  • Member
  • Joined in 2006
  • **
  • Posts: 2,374
    • View Profile
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #5 on: February 22, 2008, 12:39:20 PM »
Maybe if you tick off the box named "Allow the system to turn off this device to save energy" (loose translation) in the Properties dialog for your "USB root hub" (loose translation again) accessed via the Device Manager, you could use the most advanced state without problems. The ethernet port also suffers from the same problem, but unchecking the box helps.

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,714
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #6 on: February 22, 2008, 04:39:25 PM »
Thanks for the clarification on S1 and S3, mouser.

I shut off my computer to try the mouse back in the PS/2 port again and ran into some troubles getting my PC to turn on again.

Finally I managed to get it back on and now the mouse works in the PS/2 port. I haven't tried sleep mode or shutting down again because now I'm afraid that the PC won't turn on again.

I did go in and uncheck the "allow the system to turn off this device" for my USB Root Hubs, but now that the mouse is plugged into the PS/2 port again we'll see what happens.


Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,714
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #7 on: February 24, 2008, 12:51:30 AM »
Well, after turning my computer on (from completely off) today my PS/2 mouse wasn't working again, so I plugged it back into the USB port and tested the difference with S1 and S3 sleep. S3 is definitely the culprit in stopping the USB from working during sleep, and unfortunately Lashiec's suggestion to uncheck those boxes didn't help. So I changed it to S1 mode and it works as it should.

Unfortunately, S1 sleep isn't quiet and it seems to me no use since all the lights are on and the fans are spinning. My wife will think it's on still and try to shut it off. S3 sleep was great until my PS2 mouse stopped working. I'm not sure what it is, since it was working when I shut it down but it stopped working when I turned it on.

It's a USB mouse with a USB->PS/2 adapter. I suppose it's possible that the adapter is failing. Maybe I can find another one to test it with. I was really enjoying the benefits of quiet S3 sleep.


mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #8 on: February 24, 2008, 12:53:07 AM »
i suggest you borrow another mouse from a friend and see if it sleeps ok.  if it does, get a new mouse.

Cloq

  • Charter Member
  • Joined in 2006
  • ***
  • default avatar
  • Posts: 268
    • View Profile
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #9 on: February 24, 2008, 01:16:47 AM »
You may also want to see if your motherboard support website offers a bios update or if it is a brand PC (e.g DELL) go to their support site and see if there is a firmware update.

These days bios updates work wonders.

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,714
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #10 on: February 24, 2008, 12:30:56 PM »
Well here's the thing: I've come to the conclusion that sleep mode is working as it should be. S3 is "deep sleep" and turns off USB ports. S1 isn't and doesn't.

My problem seems to be that something is wrong with my PS2 port (or USB->PS2 adapter) to keep stopping the mouse from working whenever my PC is shutdown or enters sleep mode.


mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #11 on: February 24, 2008, 01:25:27 PM »
well cloq has a point though, that although you are right about the problem, a fix might come from any of:
  • motherboard bios update
  • mouse driver update
  • windows update
  • buying a new mouse

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,714
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #12 on: February 25, 2008, 12:37:59 PM »
I switched out my USB->PS2 adapter with the one for my other computer and now my mouse survives shutdowns and sleep mode. Hooray for S3 sleep!

The question now is, what will happen to my mouse on my other computer.  :-\


mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #13 on: February 25, 2008, 01:39:28 PM »
so it was the usb->ps2 adapter that caused the problem? i would have never guessed that one adapter would work and the other wouldn't.  good to know.

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,714
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #14 on: February 25, 2008, 01:44:50 PM »
so it was the usb->ps2 adapter that caused the problem? i would have never guessed that one adapter would work and the other wouldn't.  good to know.

It seems that way. Maybe the adapter is failing. Loose screw or something. :-\


Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,714
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #15 on: February 26, 2008, 01:32:52 PM »
Well, I was wrong. Using the other USB->PS2 adapter allowed the mouse to survive a couple of power cycles/sleep modes but it's done the same thing now.

In other news, my PC is beeping at me because my CPU fan will occasionally slow way down to maybe 120rpm (that's a guess, but it's so slow I can actually see the sticker rotate clearly). So it looks like I need to get another CPU fan.

« Last Edit: February 26, 2008, 01:36:05 PM by Deozaan »

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 7,714
    • View Profile
    • The Blog of Deozaan
    • Read more about this member.
    • Donate to Member
Re: Sleep is killing my mouse
« Reply #16 on: February 27, 2008, 11:02:09 AM »
Good news everyone!

I got a new CPU fan (which was a pain to install!) and now my system is so quiet I thought it got shut off when I got home from my class today. I think I can now use S1 sleep mode and leave my mouse in the USB port without any problems.