Home | Blog | Software | Reviews and Features | Forum | Help | Donate | About us
topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • December 03, 2016, 10:00:24 PM
  • Proudly celebrating 10 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Issues with ESC; trying to leave the joint fast…  (Read 3008 times)

nontroppo

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Posts: 649
  • spinning top
    • View Profile
    • nontroppo.org
    • Donate to Member
Issues with ESC; trying to leave the joint fast…
« on: October 08, 2005, 04:53:56 PM »
Why do I have to click ESC twice to exit FARR once I started searching? This is even when it has completed a search after letter entry; I originally thought the first ESC halts the search and the second exits, but even when no search is performed ESC needs to be hit twice (first ESC highlights the text so it seems). I'd rather have ESC simply be a one-hit exit button.

Also, when I hit ESC, FARR triggers the default sound which I find annoying, can we have an option to disable the sound effects?
FARR Wishes: Performance TweaksTask ControlAdaptive History
[url=http://opera.com/]

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Issues with ESC; trying to leave the joint fast…
« Reply #1 on: October 08, 2005, 05:01:09 PM »
let me try to fix sound, the beep is not by me but by the system itself.

as far as having to hit escape twice
this is on purpose.

you can close it with one key by hitting the hotkey again (break or whatever).

escape always cancels search (if running) and selects text.
the selecting of text is very useful i find for running new searches.

ie run a search on zzzzz
then hit escape
and start typing new search.

there needs to be a way to quickly reselect current text and then type over it (replace it).
escape seems well suited for this, especially given that the hotkey is the quick close key already.

momonan

  • Charter Member
  • Joined in 2005
  • ***
  • Posts: 227
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Issues with ESC; trying to leave the joint fast…
« Reply #2 on: October 08, 2005, 05:06:31 PM »
I had to hit esc twice, too, at first.  But, once it was convinced I meant business, it is well behaved, and I only have to hit esc once.  BTW, if you enter and exit with pause/break or alt+space bar, you don't get a noise.
in and out with pause/break or alt+space bar: only tap once and get no boing noise
in with anything and out with esc, and it boings.
When you can't be a good example, then you'll just have to be a horrible warning - Catherine Aird

nontroppo

  • Charter Honorary Member
  • Joined in 2005
  • ***
  • Posts: 649
  • spinning top
    • View Profile
    • nontroppo.org
    • Donate to Member
Re: Issues with ESC; trying to leave the joint fast…
« Reply #3 on: October 09, 2005, 04:21:02 AM »
Hmmm, I have several apps where ESC always exits so I prefer consistency (I'm left-handed so ESC is faster for me too), but I understand why you have it as you do, even if it is is non-optimal for me.

OK another question to replace ESC, can you make alt+space symmetrical — what I mean is I use one finger to activate it, rolling from <alt> to <space> but when I'm running fast I sometimes hit <space> first before <alt> — I want either direction to trigger FARR, is that possible?
FARR Wishes: Performance TweaksTask ControlAdaptive History
[url=http://opera.com/]

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 36,406
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Issues with ESC; trying to leave the joint fast…
« Reply #4 on: October 09, 2005, 04:24:30 AM »
can't do anything about space+alt, its built into windows.

i suppose i could always add an option that says escape always exits, if people really want this..

-

but if i do ill add it to a tab labeled "crazy options" so they don't distract people  ;)