topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • September 20, 2018, 09:05 PM
  • Proudly celebrating 13 years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - jhines97 [ switch to compact view ]

Pages: [1]
1
Screenshot Captor / Re: greyscale + negative for Auto Print
« on: September 11, 2013, 01:59 PM »
I use the fit to page option, and I have set the margins down to .3 all the way around.  This way a screenshot gets autoprinted, inverse colored, and fills the letter sized paper I am printing to.  I use screenshot captor to also capture images to disk sometimes for making screenshots that get inserted into documentation, but that could probably be done with the snipping tool for all I use it for.  Sorry, can't be of help.

2
Screenshot Captor / Re: greyscale + negative for Auto Print
« on: September 11, 2013, 01:02 PM »
Thanks for all the hard work getting the inverted colors working, and now I know which ini lines define the print margins in the program.   :)

3
Screenshot Captor / Re: greyscale + negative for Auto Print
« on: September 11, 2013, 12:53 PM »
Glad the inverted colors are working.

I think the old print settings used to be called "printop_" and you may still see those in the ini file; the new print settings are in the ini file under "EditStreamedPrintSettings" and should be non-blank.

I believe I see the settings you are referring to.  Are these the settings and can you give me any insight as to what they mean?

EditStreamedPrintSettings.Text="PRSETv1:000000000000F03F000000000000F03F000000000000F03F000000000000F03F0401000000000000F0BF000000000000F0BF000000000000F03F0004000000050000009A9999999999B93F01010000000000000000"
EditStreamedPrintSettings2.Text="PRSETv1:333333333333D33F333333333333D33F333333333333D33F333333333333D33F04010000000000803140ABAAAAAAAA0A2540000000000000F03F0004000000050000009A9999999999B93F01010000000000000000"
EditStreamedPrintSettings3.Text="PRSETv1:333333333333D33F000000000000D03F000000000000D03F333333333333D33F04015555555555753140ABAAAAAAAAAADE3F000000000000F03F0004000000050000009A9999999999B93F01010000000000000000"

4
Ok i think i understand the nature of the program now.. Your description of what's going on sounds correct -- it's just getting confused that the directory to save in starts with "\\".

Do I also understand that you have not edited the ConfigDir.ini file?

And remind me what operating system this is?

I am using Windows 2008 R2 (I test compatibility for programs for our terminal services users to try, and use the server to do screenshots for training materials).  I am not aware of the configdir.ini (all of my stuff was defined in the ScreenshotCaptor.ini file).  I sent your email back with the output from your debug exe program.

5
It has been a week with no replies, do you need additional information mouser?  Oh, and I tested earlier with 4.60 and just today with 4.63.

6
Screenshot Captor / Re: greyscale + negative for Auto Print
« on: September 10, 2013, 10:47 AM »
I tried the beta and the invert colors thing works great!  My only issue is that the print margins are stored somewhere different?  I opened the ini file to see why I had 1 inch margins all around the printed screenshot.  The margin entries in the ini file were all blank.  I set the print margins to .3 all the way around.  I logged off, and then back on.  The print margins in the program were still set to .3, but the ini file shows blank for the margins.  Where are the settings stored now?

7
Screenshot Captor / Re: greyscale + negative for Auto Print
« on: September 04, 2013, 05:20 PM »
Can that option be used with auto print?

8
Screenshot Captor / Re: greyscale + negative for Auto Print
« on: September 04, 2013, 04:30 PM »
I wasn't sure if the greyscale needed to happen before the invert colors thing.  I didn't know if a color image inverted very well.  I think the author of the abandoned PrintScreen32 software had the invert as a sub-option of the greyscale option because it might be strange if someone inverted an actual color image ...

9
Screenshot Captor / greyscale + negative for Auto Print
« on: September 04, 2013, 04:02 PM »
I generally print to a black and white (not color) laser printer.  Back when I was using Windows XP I used a screenshot program called PrintScreen32.  PrintScreen32 did not have near as many options or the configurability of Screenshot Captor.  However, one feature that it did have that I can't seem to find / figure out with Screenshot Captor is that you could set the image to be sent to the printer as always greyscale, and if the image were set to greyscale you could invert the colors (so black would become white, dark grey would become light grey, etc).  Anyhow, the application I am doing most of my screen printing from is an iSeries terminal.  The background of the screen is black, and the text is mostly white (some of the text is light blue, yellow, or green).  With Screenshot Captor every screen shot I take and send to the laser printer uses a good bit of toner (since most of the page is black).  Is there a way to set the image to get greyscale and inverted before being sent to the printer?

10
I updated to the latest beta via the download link (4.6).  I made sure there was no profile already created for user "etemp".  I looked in the screencaptor.ini file in the default user folder to make sure the print margins were set to .3, .3, .3, .3 and that the FolderPath was set to "Screenshots".  After the computer had created the user profile and screenshot captor ran (screenshot captor is in the "startup") I received an error message of "Error creating non-exiting directory: '\galaxy\users\etemp\DonationCoder\ScreenshotCaptor\Screenshots'." (everything inside the double quotes was displayed in the error message, I attached a screen grab of the error message)  I am guessing the problem is that the program is trying to call "\galaxy\users\etemp\DonationCoder\ScreenshotCaptor\Screenshots" when it should be trying to call "\\galaxy\users\etemp\DonationCoder\ScreenshotCaptor\Screenshots" (notice the second \ prepending the server name - galaxy).

11
When I log in to my PC as a regular user account (for testing software interactions) I notice that the line in the ScreenshotCaptor.ini file for the FolderPathEdit.Text is removed from the ini file.  I had to set a mapped drive as the FolderPathEdit.Text (i.e. J:\DonationCoder\ScreenshotCaptor\Screenshots\) as simply using "Screenshots" should work, but since the my documents is redirected to a network share there is an error every time screenshot captor starts up that says that is can't find "\galaxy\users\etemp2\donationcoder\screenshotcaptor\screenshots".  Since "my documents" is redirected to a network share the path in the preceding line needs to begin with \\ (double backslash, not just a single backslash).  Anyhow, specifying a drive letter was working, but since for whatever reason the entire line is being removed from the ini file the fix isn't working anymore.  Anyone have any idea on how to fix this?

12
Screenshot Captor / Re: How do you set Auto Print options?
« on: August 27, 2013, 10:53 AM »
I assume you will announce once the beta has been tested and is available for download (so I can update)?

13
Screenshot Captor / Re: How do you set Auto Print options?
« on: August 22, 2013, 10:16 AM »
I set the ini file to .3 for the four print margin settings.  I looked at the ini file after I printed through the normal process (selecting the print button on the form that pops up).  The settings stayed after a normal print (and the print out had the smaller margins).  I looked at the ini file after I changed the form to hide and turned on autoprint. The settings were back to blank:

print op_marginbottom=
print op_marginleft=
print op_marginright=
print op_margintop=

I think autoprint is setting the margins back to "default" settings.  Is there a workaround for this?

14
Screenshot Captor / How do you set auto-print options?
« on: August 21, 2013, 07:25 PM »
I tried setting the margins in the ini file, but autoprint does not appear to pay attention to them.  Is there a place I can set the margins for autoprint?

15
Screenshot Captor / Re: How do you set Auto Print options?
« on: August 21, 2013, 07:21 PM »
Did you ever get something set for this?

16
Is there a fix for this?  I am having the same issue.

17
How do I set the margins for the "Auto Print" function?  I tried setting the margins in the print dialogue (and the settings of .3 stayed).  However, the "Auto Print" uses the default margins of 1".  How can I set Auto Print to use margins of .3?

Pages: [1]