topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • Thursday February 22, 2024, 2:29 am
  • Proudly celebrating 15+ years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: Random M.2 SSD Disconnects  (Read 3622 times)

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 9,743
    • View Profile
    • Read more about this member.
    • Donate to Member
Random M.2 SSD Disconnects
« on: July 10, 2022, 08:22 PM »
Some time ago I was hoping to get some faster I/O speeds for a Raspberry Pi project, so I got an M.2 SATA SSD and an enclosure to connect it to the Raspberry Pi. I quickly found while trying to copy the boot image onto the SSD that it frequently disconnected/disappeared from the filesystem. I could never reliably reproduce it, but it often seemed to break in the middle of large/sustained file copies. I did manage to get things set up for the Pi and get it to boot from the SSD. But it wouldn't be too long before the entire Pi would become unresponsive because the drive would disappear and the Pi couldn't read or write anything to it until I rebooted.

I assumed it was a problem with the enclosure rather than with the SSD, and rather than looking into it further I just put the project on hold for a few months until I came across the DeskPi Pro 2.0 case, which has connections for mounting an M.2 SATA SSD to an internal 2.5" SATA slot.

The issue still persisted whether in the enclosure or in the case, on both Linux and Windows, so I've since sold the Raspberry Pi and the DeskPi because it wasn't working for my intended use. I realize now that it was probably the SSD that was faulty, since the problem remained across different devices and OSes, with only the SSD being the common factor.

Because the drive is unreliable, I've been using it only as a kind of temporary backup device for short-term backups or other ultimately unimportant experiments. Large/sustained copy operations of a few GB in size will often break partway through because the drive disappears, but if I can get the data copied to the drive, it seems to stay there. But it's not just large copy operations that break the thing. I've left the drive tucked away by my PC tower, plugged in, and even when I haven't actually used the drive for weeks I occasionally notice that it's no longer appearing in my list of drives and I have to disconnect it and reconnect the USB cable to get it to show up again.

It's a (Silicon Power) SP M.2 2280 SATA III A55 256GB.

This is my first experience with M.2 drives, and though I'd like some of the theoretical faster speeds, I've been hesitant to buy another. Is this kind of thing a known or fairly commonplace issue with M.2 drives? Is there anything I can do to fix the issue or am I out of luck? Is there something I'm doing wrong? Did I just get a faulty drive which should have been replaced under warranty? Or perhaps I bought a make or model that is known for being unreliable?
« Last Edit: July 28, 2022, 11:57 PM by Deozaan »

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,896
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Random M.2 SSD Disconnects
« Reply #1 on: July 10, 2022, 10:21 PM »
Never heard of such things, i have an M.2 and works like normal drive, no disconnected.  but i'm not using an enclosure and i wonder if that has something to do with it?

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 9,743
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Random M.2 SSD Disconnects
« Reply #2 on: July 10, 2022, 11:50 PM »
I experienced the same issue when mounted internally using Linux and when using it externally with an enclosure on Windows, so I think it's the drive.

Ath

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 3,606
    • View Profile
    • Donate to Member
Re: Random M.2 SSD Disconnects
« Reply #3 on: July 11, 2022, 12:25 AM »
You could request a replacement under warranty from the supplier, as it clearly doesn't work as is to be expected & intended.

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 9,743
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Random M.2 SSD Disconnects
« Reply #4 on: July 11, 2022, 01:02 AM »
Okay, so Ath's comment got me looking into things.

I actually had the timeline a little reversed. I actually bought the SSD and enclosure at the same time and it kept disconnecting on both Windows and Raspberry Pi OS which I assumed was the enclosure's fault. Then, a few months later I got the DeskPi Pro 2.0 case which has a 2.5" SATA adapter and even using that I still experienced the disconnections and eventually realized it might be the drive itself. But the 30-day return window had long expired by then. (I've updated the OP with the correct timeline of events and fleshed out some details.)

When Ath mentioned replacing under warranty from the supplier (which I read as manufacturer) I thought that maybe it had a 1-year warranty and that just maybe it was still within that 12-month window. But it turns out I bought the SSD 13 months ago.

But after a little more research, it looks like it actually has a 3-year warranty. So I'm going to attempt to RMA it.
« Last Edit: July 11, 2022, 01:24 AM by Deozaan »

4wd

  • Supporting Member
  • Joined in 2006
  • **
  • Posts: 5,637
    • View Profile
    • Donate to Member
Re: Random M.2 SSD Disconnects
« Reply #5 on: July 11, 2022, 01:32 AM »
Sounds like it's thermally unstable.

Fwiw, I have the following NVMe M.2 drives in different computers and never had a problem:

Corsair P1 500GB
Kingston A2000 500GB (2 of)
Samsung PM981 256GB (OEM early version of the 980)
Timetec 1TB (I think these are SK Hynix own brand)

Deozaan

  • Charter Member
  • Joined in 2006
  • ***
  • Points: 1
  • Posts: 9,743
    • View Profile
    • Read more about this member.
    • Donate to Member
Re: Random M.2 SSD Disconnects
« Reply #6 on: July 28, 2022, 11:57 PM »
Hmm... I thought I had written a follow up response before, saying that 4wd's theory sounded likely to me, and reporting that I had actually shipped it off to be replaced via RMA.

Anyway, I got a replacement SSD through the warranty process today. I've got it back in the Sabrent USB 3.2 Tool-free enclosure for M.2 PCIe NVMe and SATA SSDs, and though I haven't done much with it yet, I've copied over about 75 GB worth of data just to test it out and it has done so without disconnecting or any other errors. So it looks like this is a good one.

Thanks to everyone for their feedback and for getting me to look into the RMA process. :Thmbsup:

mouser

  • First Author
  • Administrator
  • Joined in 2005
  • *****
  • Posts: 40,896
    • View Profile
    • Mouser's Software Zone on DonationCoder.com
    • Read more about this member.
    • Donate to Member
Re: Random M.2 SSD Disconnects
« Reply #7 on: July 29, 2022, 08:34 AM »
awesome