ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > General Software Discussion

Alienware Aurora R4-Cannot Open Command Center


Hello.  I have an Alienware Aurora R4.  I have had no troubles with it, I love it actually. However, this morning when I started my computer the Alienware Command Center would not run. There is an error with d3d9.dll, same error for the thermal controller when I run it alone. This software is essential to control the fans, vents and lights. I am in serious need of help.

I have tried:

Repair install


Ran the .netFX repair tool from Microsoft

Tried to update DirectX

Tried compatibility mode with Windows 7 (I am running Windows 10)

Tried running all executables in the directory as admin

Ran DISM and system file checker

Ran DXDiag

No errors were found with any of the tools I ran. I am at the end of my knowledge.  What else can I do to troubleshoot?  I cannot seem to find the dmp files to examine them, but I do have the event logs.


            C:\Program Files\Alienware\Command Center\CommandCenter.exe

Alienware Aurora R4

32gb DDR3


Windows 10 Pro 64bit with the creator's update.

Video drivers are current. I am not overclocked.


Not sure what else to suggest, but maybe a "known good" d3d9.dll will help?

This is from my own PC (64-bit Win 10 Pro 1703, like yours) found in C:\WINDOWS\SYSTEM32\d3d9.dll

[link removed]

Same version and hash, but I tried it.  Didn't work.  Thank you though!

this one sounds plausible to me:

The DLL is there.  I checked.


[0] Message Index

Go to full version