ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > FARR Plugins and Aliases

FARR Plugin: FCalc v1.12 (Mar 25, 2015)

<< < (22/23) > >>

Exiting the application seems to be a good trigger, I'd say 95% of the time when right clicking the tray icon and selecting "Exit Find and Run Robot" I get the exception, but only when FCalc is installed and the troubleshooting log is disabled. The exception pops up 6 times - always the same addresses, then a popup saying "Abnormal program termination". It could actually be 100% of the time, but I'm not certain of that. I'm running portable off a USB stick. The very same stick works without issue on Windows 8, I switch between a few different systems, it's only the Windows 10 installs that are a problem. It does the same thing when run elevated.

It's probably not a big deal, the primary reason it annoys me is because I run off a USB stick. I exit FARR when I need to eject the stick (usually in a hurry), and it crashes almost every time. I disable the troubleshooting log because I sync the USB stick, and I like to keep the list of files that have to be synced every time to a minimum.

and the troubleshooting log is disabled.
--- End quote ---

that might be a good clue -- it sounds like maybe i just overlooked some code trying to write to the non-existent troubleshooting log.
ill see if i can figure out why that might be and fix it.

I did a bit more testing. It happens even if the file exists on the file system, but only when the option in FARR is disabled. It doesn't appear to actually log anything on exit, which is when the issue seems to occur. It has also started happening on my Windows 8.1 system, which makes me think something in my environment has changed, but nothing has really changed recently. Here is everything logged on my system while the log is enabled for a start then exit (which is all I need to do to reproduce the issue with the log disabled):

::: [ Starting Find and Run Robot v2.226.01 on Friday October 30, 2015 at 03:32:31 PM ] :::
*Loading plugin: FCalc\FCalc.dll
::: [ Program ends on Friday October 30, 2015 at 03:32:54 PM ] :::

I want to use '='  to open fcalc so I entered this to "Regular Expression (custom override)":

It opens fcalc just fine, but when I hit enter fcalc disappears and the command line gets replaced with 'fc'.  So I tried using this regex instead:

^=(.*)$|^=$|^fc (.*)$|^fc$
... which keeps fcalc opened, but it stops functioning (or at least stops reacting to me entering more expressions).

Thanks for any suggests-
-ottenm (March 15, 2010, 07:24 AM)
--- End quote ---

Use ^(?:fc |=)(.*)$

Trying to calculate an angle in a right-angle triangle.

I know to get the angle I want, I need

is this possible using Fcalc?
if not, can anyone recommend something?
(I tried a few online calculators but they dont allow pasting :-/ )

more in depth post about my problems :p in the Calculor thread:


[0] Message Index

[#] Next page

[*] Previous page

Go to full version