topbanner_forum
  *

avatar image

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
  • Tuesday April 23, 2024, 5:26 am
  • Proudly celebrating 15+ years online.
  • Donate now to become a lifetime supporting member of the site and get a non-expiring license key for all of our programs.
  • donate

Author Topic: FR: Disable a node but keep the gap (dimmed or invisible)  (Read 2344 times)

voxel

  • Supporting Member
  • Joined in 2014
  • **
  • Posts: 12
    • View Profile
    • Donate to Member
Hello Mouser.
I hope everything is going well for you.

As always, thank you for your great applications and especially for LBC. I really couldn't live without it. Every time I set up a computer I am absolutely lost until I install it.
Unfortunately I have had to do it several times lately, between some catastrophic errors or system upgrades.
All this has led me to consider a small suggestion for a future LBC upgrade.

I always use the same configuration, 3 bars (left, top and right) with all the software, directories and links I use. The icons are always in the same place, so this way I move the mouse to the same spot with almost no thinking.

The thing is that I don't install (or reinstall) everything at once. Normally I do the most necessary things first and the rest as I need them.
Sometimes I turn off, in the configuration, what I don't have installed, but that makes the rest of the icons in the bar move out of place.

So the idea is that it would be nice, apart from the current option (deactivated and hidden) other options to be able to deactivate a node but that it remains in place:
-deactivated and dimmed.
-deactivated and invisible.
This way it would not change the position of the rest of the icons.
Now you can achieve something similar using "Node Override" "Force: No icons" (Min. item Width/Height set to the icon size). It removes the icon completely and keeps the gap, but it is not a very practical way.
Maybe with a context menu with "disabled dimmed, disabled invisible" in the tree view.......

Anyway, thanks again and best regards.