ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > DcUpdater

DcUpdater fails to check for updates

(1/2) > >>

Hi,  For at least the last week DcUpdater has failed each time to check for updates.  There is no error message, just the text in red saying it failed.  It seems more like a possible server issue than a software problem.

Happening to me as well. The text is "get version failed"


Simply download and extract the 32-bit libcurl.dll and replace the one in your DcUppdater.exe directory. Badda bing, badda boom! Success on the very first try.

You can stop reading here.

Notes for ScreenshotCaptor Developers:

I just spent 1 hour fiercely attempting to debug this issue. I'm not really a software developer but I know enough. I found it's the 2010 version of libcurl.dll that DcUppdater.exe (yes a typo, 2 P's) uses lacks modern SSL support.

After MUCH ProcMon.exe trial and error with a dozen various copies of libcurl that all failed due to various OpenSSL certificate library issues and dozens of DLL dependencies, I finally found a version that works!! And it's all in 1 single file! (the linked above)

From what I can tell, this build of libcurl is specially compiled to use Windows SSL support rather than the default OpenSSL libraries and files etc, which is why it's so conveniently self contained all in 1 DLL. I'm using Windows 7 64-bit (but DcUppdater.exe is 32-bit).

However, if you need to support older OS like XP that may possibly (?) lack the current SSL support, then the solution will be to use a modern build of libcurl.dll with OpenSSL support instead, as that completely bypasses using any Windows SSL support (which is why Firefox can still connect to SSL websites on Windows XP but Chrome cannot. Firefox uses their own OpenSSL support while Chrome depends on Windows's SSL support.)

Unfortunately I tried very hard, and still was unsuccessful in getting the OpenSSL version to work. (I didn't find the much simpler Windows SSL version until the end.) ProcMon showed it trying to open C:\Program Files (x86)\Common Files\SSL which did not exist, so I created it, then I tried adding the :

cacert.pem (I think these 2 are the same file, simply renamed)

along with:


Which got DcUppdater.exe to run but still had various errors depending which versions I tried. I found a number of libraries from searching my hard drive, along with some libcurl binary distributions online. Ultimately it kept trying to open an openssl.cnf and I copied one of those but that didn't work either and I reached a dead end, unless the solution was to edit the openssl.cnf to match the location of the cacert.pem which I did not try.


Yay! Thank you for your time in sorting this out.  I am guessing this is due to OS updates?

Thank you for posting this! I will try to update the official version of DcUpdater asap.


[0] Message Index

[#] Next page

Go to full version