ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > Jibz's Tools

Dina: Ubuntu & other Linux distros dropping support for bitmap fonts

(1/2) > >>

A component used in Linux font rendering called "Pango" has intentionally dropped support for bitmap font formats.
See their issue thread about it here for details of why:
Short version is, they want to delete a lot of nasty old code and use some other component, which will allow them to get past some otherwise unsolvable problems. Unfortunately bitmap support is lost in this new design.

This version of Pango is making its way into Linux distributions like Ubuntu "Focal" (for release March 2020) I think it is already released in Arch.
The upshot is all bitmap fonts appear as 'tofu' (boxes of hex digits).

I filed a bug against Ubuntu's Focal release:
and I chatted with Canonical staff (I'm a Canonical employee) who told me there isn't much they can do. They don't have the resources available to do much other than go along with whatever the upstream Pango devs decide to do.

All hope is not lost for Linux Dina users! They will still support bitmaps that are packaged up as a "Vector format which contains embedded bitmaps." People report some success converting other bitmap fonts using various tools. I say "some" success, because bitmap font users are upset that the output has ugly problems such as such as spacing between characters, and everyone else doesn't really care, which is saddening. But in my experiments (below), these problems didn't manifest for Dina, possibly because it is monospace.

I have tried:

1. GUI app FontForge. I tried installing this to do the conversion on Dina, I infer from the conversation linked above that one needs to use the dialog produced by the 'File / generate' menu option, but I am totally unable to understand the UI of its many dozens of options.

2. Command line app fonttosfnt. Using an invocation like:

--- ---    fonttosfnt -v -r -b -c -g 2 -m 2 -o DinaR.otb DinaR.fon
I then did my normal font install process (copy the resulting otb file to my ~/.fonts/dina directory, and ran 'fc-cache -f')

This produced a useable Dina font! However it isn't quite right. Only two of the smaller sizes are visible, and the 'regular' font seems significantly heavier than I expect, as though it were 'bold' and the bold were 'double bold'. I don't yet know why. I just realized I'm only using v2.92 of Dina, I'll try again with the latest release (v2.93) and report back any successes.

Also, I tried an identical fonttosfnt invocation on Dina's BDF files, but that gives me an error "Couldn't select character map: 6".

Fare thee well, fellow bitmap officionados,

Tried fonttosfnt again with Dina v2.93, same results. Smallest size is available (and looks perfect.) Next size up is available, but looks too bold. No other sizes are available.

I tried just installing the output I get from converting DinaR.fon (instead of from all four files.) I expected this to give me the "regular" font in all sizes. Instead it gave me regular, italic, bold, and bold italic, all in size 6. This sounds like a clue that I don't understand what I'm doing.

Tried using GUI app FontForge, using the instructions in this comment:

UPDATE: All Dina characters come out invisible in font selection dialogs, but if you click around blindly to select a Dina font, then everything displays just fine in gnome-terminal. (this behavior seems to apply regardless if I run fontforge on the Dina?.fon files, or the BDFs.)

Hooray, a victory! This is the best option as far as I can tell.

UPDATE2: I posted the output of my conversion here:

Using somebody's TTF conversion of Dina from here works pretty well:

Problems are:
* It's a version of Dina from March 2010
* Although Dina shows up fine in my terminal, at all sizes, with italics and bold, for some reason the font is invisible in font-selection dialogs, so you have to click blindly on empty spaces to select it.

That makes me want to re-check my output from fontforge, above. Maybe that was blank in the font selection dialog but would have rendered ok in my terminal app? to be continued...

> this makes me want to re-check my output from fontforge...

YES! Done, and the fontforge output is visible in gnome-terminal, even though it looks invisible in font selection dialogs. Not ideal, but workable. I updated my fontforge post above to reflect what's actually going on.

Dina on Linux is BACK! :-)


[0] Message Index

[#] Next page

Go to full version