ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > Living Room

Samsung SSD 860 EVO woes - workaround


Carol Haynes:
I have jsut added a 1Tb Samsung SSD 860 EVO to my aging system (and upgraded to a Radeon RX580 at the same time). Motherboard i a Gigabyte GA-990FXA-UD3 with and 8 coure CPU and 36Gb RAM.

Windows 7 Pro installed in AHCI mode happily enough (I hate windows 10 and am sticking to Windows 7 as long as I can) but seemed to take longer than I expected and then I started suffereing 30 second freezes every few seconds - the system logs confirmed the devie was being reset each time. I used Samsung Magician to see if I could get a sense of what was happening and the speeds were terrible when I benchmarked the drive (it took 14 minutes to do the benchmark!!!)

After a bit of research there seems to be compatability essues with the SSD and AMD drivers - I updated the AMD Chipset drivers to the current version but it mad no difference. I also couldn't update the SSD firmware to see if the latest firware fixewd the issue (it just kept saying there was no firmware but couldn;t install it).

FWIW I seem to have found a workaround - I unstalled AMDs chipset drivers and then went into Control Panel and use the Standard AHCI driver from Microsoft. Now I have updated the SSD firmware and everything seems to be running stable.

Benchmark now runs in about 30 seconds and I seem to be getting reasonable speeds but RAPID Mode is still disabled and compatibility checker says:

VID 1002 Under the current system environment, some functions in Magician CANNOT be run.
If multiple iterations of Read and Write are performed, RAPID mode may become inactive due to system internal errors on some of the AMD / AsMedia Controller or Driver.
--- End quote ---

If you have an AMD/ATI system and have long freeze issues it is worth making a note.

Anyone else come across this and have a better solution???

Same thing here a couple of months ago when I installed an 860 EVO 500GB.

Dropping back to Microsoft generic AHCI drivers is about the only solution.


[0] Message Index

Go to full version