ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > General Software Discussion

How to REALLY stop ******* Windows Update on Win10?

(1/5) > >>


This morning I woke up to a computer that was turned on - "oh great, Windows Update resumed from standby again, and even did it in spite of me turning off wake timers". That would have been a minor annoyance to start the day with, unfortunately it also turned out the image file backing my persistent ramdisk had been corrupted, and I had forgotten to add the folders on it I cared about to my backup set.

I'm sick and tired of the forced reboots in general, it's ******* bad attitude of Microsoft not allowing power users to turn them off, and that they're forced even when applications have unsaved data and tell Windows that they're not ready to shut down really ought to bring a class action lawsuit. Oh, and the

I could almost live with the forced reboots, except that windows update ******* resumes the device from standby in order to do the reboots. Yes, even though I've modified the power plan settings to not allow wake timers. This is... I mean, it's beyond contempt for us users.

I've tried several solutions in the past, like disabling orchestration services, deleting the UpdateOrchestrator task files, deleting the content of the task files and removing ACLs for even the SYSTEM user to the files, et cetera -they always get recreated at some point in time during a system update.

So... are there any existing solutions to bloody STOP this insanity from happening? Any gpedit policies (that don't require enterprise edition of Win10) and actually work?

Or do I have to write a tool that continually scan for the task files and delete them if they're re-added, check for the reboot dialog box and try to cancel it, etc?

Yeah, I guess Windows only resumes from standby, not poweroff - but I prefer standby for my desktop machine, so I can just pick up where I left off.

Yeah... I looked into this a while ago.  The only ways are (a) by policy because businesses wouldn't put up with this and MS knows it or (b) some 3p solution.  I've tried a few.  The only one that sticks is deleting the task.  I even tried using their settings in the registry- and they changed them.  I was getting close to creating some custom way to monitor for those tasks, as I saw that they'd been added even after I removed them, added a bogus task and then locked that one from access.  I think the task removal is all that's required from my use of it, but who knows.

I believe the necessary policies only work on enterprise versions, not even pro versions >_<

Removing the task files are not enough, they get re-created. The same goes for setting all ACLs to deny access, Windows will eventually go "Lol, I'm LOCALSYSTEM, bitch, what are you gonna do about it?" and reset/recreate the ACLs.

I have two computers running Windows 10.

One of them, from the beginning of time, has always woken up from sleep at the same time every day, ground the hard drive for several minutes, and then gone back to sleep.
The other one has never been woken up from sleep to install updates or whatever, as far as I can tell.

I have no idea what the difference is between the two machines to explain why it would happen on one but not the other.

Hello Sir, did you tried all THIS methods?

In my (bad english) words:
Turn Auto-Updates OFF from System Settings and Configure Network Connection as "metered" <<< MOST IMPORTANT!
More is not needed and works 100% for me since day 1.

If above does for some reason do not work for you, i can search my eMails for a "block all microsoft" firewall rule.
Afterwards no telemetry etc is sended and you can not argue with Microsoft Services anymore (like Cortana and such)


[0] Message Index

[#] Next page

Go to full version