ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > Find And Run Robot

Opening a file/URL by passing as parameter to application doesn't work for me.

(1/2) > >>


I want to access an excel file from network, but if I use the notation "excel.exe file_url" FARR doesn't give any reaction.

e.g.  "excel.exe \\computer\share\file.xlsx"

if I run this command in command prompt, the file opens successfully. If I omit excel.exe FARR can call the file successfully, but for some cases, like the below case, I need this function:

I want to open but specifically with chrome: (IE is default browser)


etc. none of them work.  If I put the address in double quotes it gives an error ( bad invocation of...)

How should I achieve this?

Thanks in advance.



It's a bit confusing -- it's because FARR doesn't know that you are telling it commandline parameters.  Perhaps it should be smart enough to figure that out..

The workaround is the explicit method of specifying commandline parameters, from the help file topic on "Passing commandline parameters..":

You can now pass commandline arguments to any launched program by typing "++ any args here" at the end of your search string.
For example:
ping.exe ++ -n 2
--- End quote ---

So in your case:
chrome.exe ++

The easier solution if you are doing this kind of thing quite a bit might be to create an alias that knows that when you type
It knows you want to launch chrome.exe with the url passed.
This would have the advantage of being instant and not requiring any searching.

Thanks for your fast response :o, unfortunately it still didn't work that way. Same no reaction.
I will take a look at the part of documentation that you've mentioned.



Unfortunately it seems the function doesn't work as documented, at least in my environment. Do you have any other suggestions?
(Windows 8.1 64 bit)



Have you tried using an alias?
Can you explain a little bit more about what's not working? Can you try other applications to see if it's just chrome thats failing to launch or something else going on? I tested here and it seems to be working.


[0] Message Index

[#] Next page

Go to full version