ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE. Software > Screenshot Captor

Grab selected region

<< < (4/6) > >>

I've run into this frustrating glitch more than once.  I've tried 4.20.1, 4.21.1, I tried the old zip you linked.
No matter what I do, fresh install, old install, any version now, the screen magnifies immediately after I tell it to "select a region", OR, if I simply hit the print-screen button to capture the entire screen, it captures a zoomed image.

I'm running Windows 10 Pro 64-bit, a single monitor (65" screen). The computer DOES have to use AMD's Radeon scaling ability to scale the screen SMALLER since the graphics card wants to make the image larger than the 1920x1080p borders for some reason. So AMD software changes the "HDMI Scaling" by 6 percent in order to shrink the image to fit the 65" tv.

With that said, I've been using this Screenshot Captor software for a couple years now.  And the software worked GREAT until the recent SC update.  After that, it just started auto-zooming all the time, and I can't seem to find a version that DOESN'T do it now.

EDIT!!! I'm a computer technician... but my brain was really not working earlier (apparently).  I realized that if NONE of your versions of software worked properly, then it wasn't SC that changed, it was something else. And since we're talking about AMD Scaling issues or 'scaling' issues in almost every situation , I uninstalled my AMD video drivers and reinstalled them.  The issue was caused by AMD's own drivers interacting with SC somehow causing the magnification. After driving re-install, works perfectly again.

Excellent detective work -- and thanks for sharing -- hopefully this will help someone else who encounters the same problem.

@Evanrude: Oops, sorry. I forgot to say thanks for your potentially useful feedback (above) when I had earlier cross-posted it to:
Re: Pasted images too large with new laptop « Reply #17 on: 2017-12-10, 12:38:58 »

Excellent detective work -- and thanks for sharing -- hopefully this will help someone else who encounters the same problem.
-mouser (December 10, 2017, 05:01 PM)
--- End quote ---

Sadly, as soon as I rebooted my computer, the zooming issue when capturing screenshots has returned.
If I reinstall video drivers, it fixes it until I reboot again, and it starts all over.  So, at this point I'm just lost , and there doesn't seem to be any way to 'disabled' the zooming.   Doing a full print screen zooms, doing a print region zooms, and you can't 'move' the zoomed region. It just auto pics a place and zooms in.  Only way to get out of the zoom is then to hit escape.

Well, at least you are one step forwards, insofar as you would seem to have established (conclusively?) that "After driving re-install, works perfectly again."
Some thoughts:

* What you have subsequently discovered, however, is that, somehow, "the driver re-installation" fix is not "sticky". That is, a reboot of the PC unsets it and it reverts to the previous ("zooming problem") state.
* What that might indicate is that the settings created at the driver re-install point are kept in a (possibly temporary) file, which is being overwritten or ignored when the PC is rebooted. This might be by design - for example, where reinstalling a driver normally has to be followed by a reboot.
* It may be that you actually need to get a newer/different driver - i.e., one more suited to your display hardware device or to overcome this problem. A search of forums dealing with problems for this PC's display driver might be in order. Have you already fully explored that avenue? It is unlikely to be a problem that is unique to you and you might be able to find a lot of useful/relevant info.
* My only experience of something similar to your so far inexplicable problem was with a Touchpad device in an HP laptop, where the Touchpad settings kept episodically reverting to some default, for no apparent reason. It drove me half-bonkers, as that was my main mouse-like device. I eventually discovered - by trail-and-error - that restarting the Touchpad driver executables/services would restore my preferred settings, This was a workaround only, not a fix, as the settings continued to episodically revert to default. I later discovered that I could ensure that my settings were saved in a named configuration file, and that, when the problem recurred, I could restore my defaults by reloading that default config file, via the Touchpad GUI. So something was apparently periodically taking precedence over my settings, restoring a default settings, but I still haven't figured out how/why that continues to happen, and I cannot locate the necessary Touchpad settings default file to edit it, so it continues to be a workaround which I am obliged to live with, meanwhile.
* It may be that you need to consider how to refresh your particular display driver with your preferred settings. Most display/GPU hardware has that facility nowadays, usually via manufacturer-specific software installed in the system files somewhere on the PC. It may even be that you only need to define that (say) the SC executable is assigned to use such-and-such a display hardware - e.g., On my HP Pavilion laptop, for each application, I can choose whether it defaults to using either the Intel GPU or the NVIDIA GEFORCE GPU. In its "virgin" state, the system defaults to using the Intel GPU, but some games, for example, might perform differently/better via the NVIDIA GEFORCE GPU.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version