ATTENTION: You are viewing a page formatted for mobile devices; to view the full web page, click HERE.

Main Area and Open Discussion > DC Gamer Club

Fallout 3 (GOTYE) on Windows 10 Pro.

(1/2) > >>

Note: "GOTYE" = "Game of the Year Edition".

We had been given some gift vouchers to spend at a high street IT chain store, so we went to their store to buy a computer game, and came away with my daughter's choice, which was Fallout 3.
It installed the Steam delivery system and required GFWL (Games For Windows Live) to be installed and running as well.
After a bit of mucking about recovering our relatively unused GFWL signon ID/Password, Steam, the game, and GFWL were installed and ran fine on a Samsung-S3 (Series 3) laptop with standard Windows 10 update.

A couple of days later I installed the thing (Steam, the game, and GFWL) on a Toshiba Satellite L855D laptop with Windows 10 Pro. It all seemed to install OK, but it wouldn't run - kept coming up with the same nondescript error at startup:
      Fallout 3 Launcher
      Fallout 3 Launcher has stopped working
      A problem caused the program to stop working correctly.
      Windows will close the program and notify you if a solution is available.
      [Close program]

For several hours I scoured the discussion forums, searching for a solution or a workaround.
Not being able to run Fallout 3 on Win8 or Win10 seemed to be a common problem.
There were two very useful posts at

* ULTIMATE Fallout 3 Setup Guide READ THIS!
* Fallout 3 runs GREAT with these easy steps!
However, after several hours of playing Sherlock Holmes and repeatedly reinstalling the thing on the Toshiba-L855D, using different tweaks here and there, I still couldn't get Fallout 3 to run. So near, and yet so far! Very frustrating.
I checked and compared, and found that game installation folders/files and Steam components were identical on both laptops, but I had noticed that, on both laptops, GFWL Client had been set to run at Windows startup, and, out of interest tonight I compared the GFWL files as installed on each laptop, and noticed a difference:

One subfolder was different: C:\Program Files (x86)\Microsoft Games for Windows - LIVE\Redist\DirectX
 - on the ToshibaL855D, there were only two files in that folder, and though the same two were in the corresponding folder on the Samsung-S3, on the latter the folder held a few more files, so I copied them across to the ToshibaL855D folder, leaving it with these in all:


I then ran DXSETUP.exe, after which I stopped and restarted the GFWL Client, logged in to GFWL, and then started the Fallout 3 game after searching for the link using the Start menu: "Fallout 3 - Game of the Year Edition".
It seems to work OK now, though I have only now started playing it.
I suspect it will have been worth all the trouble, but I thought I'd post my notes about it here, in case they might be of help/use to others with similar Fallout 3 problems under Win10.

Related: Windows 10 won't run games with commonly hated DRM platforms

Fallout 3 is a pretty good game, it suffers the same fate as most Bethesda games though, the main story is shoddy and the game is buggy in general. But let yourself cut loose and just wander and there's a good chance you will wander into some interesting content. Just my two cents. Also, for the love of god, be sure to invest into a build (A good tip is to invest into a single weapon skill, a utility skill like lockpicking, science or speech and some more general purpose skills like medicine, sneak or repair). Don't try to be good at everything, you will end up not being able to do anything.


Just a note to say that on an HP Pavilion 15 laptop with an i7 processor, Fallout 3 GOTYE for a while now has no longer worked properly under Win10-64 Pro after the Anniversary update, and still doesn't after subsequent updates.
It still works on the Samsung-S3 laptop though.    :tellme:

On the HP Pavilion 15 laptop, the symptoms are, whether the game is launched:

* (a) via the link for the Steam GOTYE launch icon, or
* (b) directly via the Game Launcher icon, - though the usual warning about "This app might not work correctly ... under this version of Windows...", everything seems to work just fine, even after a "continue" from last game saved or a specific saved game is selected from the menu.
What happens then is that the game starts to load and one or two statistics reports (number of things killed, etc.) are displayed about the loading game, then the game crashes with a nondescript Windows apology being displayed. This is consistently repeatable.

I checked that the files listed above for C:\Program Files (x86)\Microsoft Games for Windows - LIVE\Redist\DirectX were all present and correct, and ran DXSETUP.exe - which completed OK - but it seemed to make no difference, and still the game crashed exactly as described (as above in this comment).

It also seems to make no difference whether one enables the Intel Integrated Graphics processor or the NVIDIA Geoforce GPU.

Fallout New Vegas seems to work fine with no probs though.

Stumped. Very frustrating.


[0] Message Index

[#] Next page

Go to full version